LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-23-2005, 07:26 PM   #1
kiranherekar
LQ Newbie
 
Registered: Aug 2005
Posts: 5

Rep: Reputation: 0
FC4-Starting sshd: Privilege separation user sshd does not exist FAILED


Hi,
After I do "service sshd start" on FC4 I get the following error message even after disabling firewall using system-config-securitylevel.
"Starting sshd: Privilege separation user sshd does not exist FAILED]".
Please Help.


Thanks & Regards,
Kiran.

Last edited by kiranherekar; 12-23-2005 at 07:44 PM.
 
Old 12-23-2005, 08:53 PM   #2
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Have a look in /etc/passwd and /etc/group and see if "sshd" is in them. If not, add them (as root):
Code:
groupadd -g 33 sshd
useradd -u 33 -g 33 -c sshd -d / sshd
Then try again.

Last edited by Tuttle; 12-23-2005 at 08:59 PM.
 
Old 12-24-2005, 12:52 PM   #3
jtison
LQ Newbie
 
Registered: Dec 2005
Location: Connecticut, USA
Distribution: Fedora Cores 9, 10, 15, 17; SLES 10 & 11; RHEL 6.x
Posts: 17

Rep: Reputation: 0
Wrong sub-forum

This is the Red Hat distro area. Fedora is no longer Red Hat, although Red Hat (the corporation) still sponsors Fedora Core. (Confused yet? So are a lot of people.)

I make the point because your questions pertaining to FC4 are going to get much better visibility in the Fedora distribution forum than they will here.

With all that said, tuttle's advice is a good place to start.

Peace,
--Jim--
 
Old 12-24-2005, 03:06 PM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,174
Blog Entries: 4

Rep: Reputation: 428Reputation: 428Reputation: 428Reputation: 428Reputation: 428
Moved: This thread is more suitable in Fedora and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 12-26-2005, 05:41 PM   #5
mastahnke
Member
 
Registered: Feb 2002
Location: IL
Distribution: Ubuntu currently, also Fedora, RHEL, CentOS
Posts: 111

Rep: Reputation: 15
Another option, is to simply change a line in the /etc/ssh/sshd_config .

You can change

Code:
UsePrivilegeSeparation yes


Code:
UsePrivilegeSeparation no

It will lower your security settings a litte, as unauthenticated ssh connection attempts will be running as root rather than as sshd in /var/empty, but it is another option.
 
Old 12-29-2005, 02:22 PM   #6
kiranherekar
LQ Newbie
 
Registered: Aug 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Hi Tuttle,
Thanks a lot for your advice,sshd started without any problems after adding user sshd.
jtison I'll take care that I post my questions to rigth forums.

Thanks & Regards,
Kiran.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sshd: privilege separation? Half_Elf Linux - Software 15 02-23-2008 12:54 AM
starting sshd how to.. bruse Linux - Networking 5 04-22-2005 04:26 AM
sshd starting twice ryedunn Linux - Software 4 01-30-2005 09:47 PM
Enabling SSH in mandrake 9.2 - sshd vs. sshd-xinetd DogTags Linux - Newbie 7 11-25-2003 12:17 PM
sshd failed vcheah Linux - Software 0 12-31-2001 03:49 PM


All times are GMT -5. The time now is 02:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration