LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   FC3-- YUM errors (http://www.linuxquestions.org/questions/fedora-35/fc3-yum-errors-436638/)

Sheetal Stephen 04-19-2006 02:33 AM

FC3-- YUM errors
 
Hello,

I am using FC3 and was trying out some cmds and got the following messages.... :confused:
can anyone suggest me how to rectify it ....


# yum update

You have enabled checking of packages via GPG keys. This is a good thing.
However, you do not have any GPG public keys installed. You need to download
the keys for packages you wish to install and install them.
You can do that by running the command:
rpm --import public.gpg.key
For more information contact your distribution or package provider.

# yum install xen kernel-xen0 kernel-xenu

You have enabled checking of packages via GPG keys. This is a good thing.
However, you do not have any GPG public keys installed. You need to download
the keys for packages you wish to install and install them.
You can do that by running the command:
rpm --import public.gpg.key
For more information contact your distribution or package provider.

# rpm --import public.gpg.key
error: public.gpg.key: import read failed.


Thanks..
Sheetal ..

Sheetal Stephen 04-19-2006 09:58 AM

I found similar error faced by other people... and different solutions to it.

1. for rpm --import error i tried this and it worked.
rpm --import /usr/share/rhn/RPM-GPG-KEY-fedora

2. but i still get error with yum update.
error--
# yum update
Setting up Update Process
Setting up Repo: development
Cannot find a valid baseurl for repo: development

I found one solution as --

Edit the file /etc/yum.repos.d/fedora-devel.repo. Find the line enabled=1 and change it to enabled=0
Ensure that at least the files fedora.repo, fedora-updates.repo and fedora-extras.repo have the line "enabled=1".

But now i am in a fix....
I was tryin out something for the xen virtualization s/w.
In it was mentioned to make enable=1 for /etc/yum.repos.d/fedora-devel.repo
and enable=0 for the other files.

now wat shld i do ?

lebabyg 04-19-2006 11:12 AM

the enable =0 line basically tells yum not to use that repository. The error was most likely caused by the fact that your /etc/yum.repos.d/fedora-devel.repo was not correct. Could you post the output of the file here? Or you could have a google around to see if xen is available from another repo other than the fedora-devel. Use that instead? regards,
Graham

Sheetal Stephen 04-20-2006 12:49 AM

this is the file --- /etc/yum.repos.d/fedora-devel.repo

[development]
name=Fedora Core $releasever - Development Tree
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/
mirrorlist=http://fedora.redhat.com/download/mirrors/fedora-core-rawhide
enabled=1

fira 08-30-2006 02:31 AM

Thanks for the post....
It helped me out

decrepit 08-30-2006 08:51 AM

As FC3 is now in legacy mode some of the old repos may no longer work, have a look here to set up the legacy repos
http://fedoralegacy.org/


All times are GMT -5. The time now is 07:58 PM.