View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 12-17-2004, 09:28 PM   #1
Registered: Apr 2004
Distribution: Debian
Posts: 193

Rep: Reputation: 30
FC3, updated kernel now HAL daemon fails

hi -

Let me preface this, I am completely new to fedora and red hat. (and noob otherwise )

I installed fc3, it went rather smoothly. upon boot, i got a smartd failure error, and had and am still having problems getting my wireless nic to work.

anyway, i ran the up2date thing, and updated the kernel. then i updated the rest of the stuff. at some point, upon rebooting i noticed that HAL daemon failed.

the order i did things-

install fc3
upgrade kernel
install nvidia drivers
update rest of stuff

i noticed the HAL daemon failed after the fourth step. from what i can find, it appears HAL is something for gnome, I did not install gnome i choose KDE instead.

My question is, how can i stop this from failing/loading, and do i need it?

Old 12-20-2004, 06:47 AM   #2
Senior Member
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
HAL is part of the Project Utopia stack of stuff for plug-and-play. I don't think that KDE uses it fully, but the configuration tools do.

If you open the Log Viewer utility you'll be able to read the logs for error messages.

It's probably a good idea to only introduce the Nvidia drivers and any third-party wireless stuff once you're happy that the rest of the system is OK.

smartd will fail if the hard drives in your machine don't support SMART, so that's not necessarily an error.
Old 12-20-2004, 09:36 AM   #3
Registered: Apr 2004
Distribution: Debian
Posts: 193

Original Poster
Rep: Reputation: 30
hm thx. so i may need that.

i didnt think i needed the smartd, so i disabled it.

hopefully i can get the wireless working today.
Old 12-22-2004, 08:02 PM   #4
LQ Newbie
Registered: Dec 2004
Location: Warsaw IN
Distribution: FC3 / Slamd64
Posts: 22

Rep: Reputation: 15
Cool SMartD

how did you disable smart drive ? i get the same error on my machine . Funny thing is , when i was running FC1 the smartD worked fine . The same time I moved to FC3 the drive started giving the error .

Also , when you switched to FC3 , did you notice that the kernel folder is in a different spot . Maybe FC1 was in the wrong spot ? Anyway , i tried to slim it down a bit , by removing support for stuff i dont have , and the makefile wouldnt "make" . RPM update for 2.6.9-681 went fine , but i wanted to tweek it .

Old 01-03-2005, 11:32 AM   #5
Registered: Apr 2004
Distribution: Debian
Posts: 193

Original Poster
Rep: Reputation: 30
service smartd stop
chkconfig smartd off


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
hal daemon not recognize floppy mount points gatons Linux - Hardware 1 01-26-2006 05:27 AM
FC3 fstab HAL confict... dr_sloppy Linux - Newbie 2 01-24-2005 09:32 AM
HAL daemon & mount permissions tuxrules Fedora 1 01-19-2005 10:08 PM
updated to FC3 kingcobrawoods Linux - General 1 01-07-2005 09:39 AM
FC3 Kernel build fails at_work_with_jf Fedora 1 12-28-2004 04:54 AM

All times are GMT -5. The time now is 12:36 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration