LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 07-31-2004, 03:31 PM   #1
zipo13
LQ Newbie
 
Registered: Mar 2004
Posts: 24

Rep: Reputation: 15
FC2 with grub boot/init very slow


Hi,
I've been using FC2 for the last month an everything seems to be in order.
2 things that annoy me:
1) I'm using GRUB. Just after I select to boot linux I get 2 grub messages about loading the kernel and then the initrd command.
Right after that the line:
Uncompressing linux... Ok, booting the kernel.
audit(1091311588.522:0): initialized

then nothing happens for about a minute and then I get
Redhat nash version 3.5.22 starting
and the boot continues...

I have no clue why it takes a minute to pass that step....

2) after step 1 all loads fine until eth0 is brought up.
I use DHCP so I understand it takes time to obtain an IP address but it takes about 8-10 sec' to pass that stage.
When I put a static IP address to eth0 it doesn't happen.
Anything I can do about this? I want to use DHCP.

Any help will be great
 
Old 07-31-2004, 04:22 PM   #2
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
Hi Zipo13,
All the misteries in this lap minute are in the initrd. It is a compressed file system. When you boot, after linux is uncompressed, it takes control, uncompress this file system to memory and mounts it. Right after, it calls an script in the root of this filesystem, called linuxrc. Normally all this script does is load the needed modules to access your disk, checks it for inconsistencies and after, it mounts your default root and starts to operate from this root. For me, the strange is the message "audit....", but maybe you are using the kernel of the 2.6 series and this would be a standard message and I don't know this kernel.
If you want to get a look into the initrd procedure, you may uncompress it and mount it for exploration.
For this, create a directory to mount it, uncompress into tmp and mount it with the following commands:
Code:
mkdir /mnt/initrd
gunzip -c /boot/"your-initrd-file-name.img" >/tmp/temp-initrd
mount -o loop /tmp/temp-initrd /mnt/initrd
cd /mnt/initrd
"your-initrd-file-name.img" is the initrd you have in /boot and specified in the /boot/grub/grub.conf or /boot/grub/menu.lst.
After you play enough with it you may unmount it and remove the temporary file and the directory, after cding to another directory. All operations here are assumed as user "root".
Code:
cd # go home directory
umount /mnt/initrd
rm /tmp/temp-initrd
rmdir /mnt/initrd
 
Old 07-31-2004, 08:40 PM   #3
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Has this been happening since the beginning? Or, did you "upgrade" your kernel? That audit line looks suspicious. I'd think that either you're running a kernel with the NSA security code in it (I haven't so that's why I suggest that) or perhaps you have enabled something in the kernel which allows an integrity check at bootup. I saw something like that when I was compiling my kernel, but didn't enable it, as I run a desktop. Its not mission critical.

As far as the DHCP issue, I don't know if there's a way to speed that up or not. I hope that you're not comparing that wait to the supposedly non-existant one in Windows. The network is not up sometimes until after a user has logged in on that OS, so don't be fooled. Are you using dhcpd? Or another dhcp daemon?
 
Old 08-01-2004, 12:02 PM   #4
zipo13
LQ Newbie
 
Registered: Mar 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks for the info,
I Haven't checked anything yet since I'm at work but I'll check once I have a chance.

For more info that might help:
I had the problem since the beginning.
I installed FC2 which came with the 2.6.5 kernel and then upgraded it via up2date to the 2.6.6 kernel.
Both what is supplied officially by the Fedora project.

I'm using a SATA HD if that matters.

I would have post the exact loading messages if I could but I don't know if or where they are saved.
Any way I'll soon post the GRUB loading script but I think its standard except for the noapic kernel option that I use because of hangs I had with the mandrake install:
http://www.linuxquestions.org/questi...hreadid=157831
 
Old 08-01-2004, 04:20 PM   #5
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Quote:
Originally posted by zipo13
...For more info that might help:
I had the problem since the beginning.
I installed FC2 which came with the 2.6.5 kernel and then upgraded it via up2date to the 2.6.6 kernel.
Both what is supplied officially by the Fedora project.
Wierd.
Quote:
I'm using a SATA HD if that matters.
Sometimes SATA is a problem, but if Mandrake boots fine, its not that, likely.
Quote:
I would have post the exact loading messages if I could but I don't know if or where they are saved.
dmesg (sometimes requires you to be root) or
Code:
less /var/log/messages
will yeild what you seek.
Quote:
Any way I'll soon post the GRUB loading script but I think its standard except for the noapic kernel option that I use because of hangs I had with the mandrake install:
http://www.linuxquestions.org/questi...hreadid=157831
Not likely the cause either, as it does its job - to bootstrap your system, but might be good to look at it.
 
Old 08-02-2004, 01:29 PM   #6
zipo13
LQ Newbie
 
Registered: Mar 2004
Posts: 24

Original Poster
Rep: Reputation: 15
OK,
I loaded without the quiet kernel option and understood whats the problem.
On the other hand I don't know how to solve it ;)
below is the dmesg output -not all but just the important part
----------------------------8<------------------------------------------
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
divert: not allocating divert_blk for non-ethernet device lo
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE2: IDE controller at PCI slot 0000:00:09.0
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
NFORCE2: BIOS didn't set cable bits correctly. Enabling workaround.
NFORCE2: 0000:00:09.0 (rev a2) UDMA133 controller
ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
hda: LITE-ON COMBO SOHC-5232K, ATAPI CD/DVD-ROM drive
Using cfq io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
SiI3112 Serial ATA: IDE controller at PCI slot 0000:01:0b.0
SiI3112 Serial ATA: chipset revision 2
SiI3112 Serial ATA: 100% native mode on irq 11
ide2: MMIO-DMA , BIOS settings: hde:pio, hdf:pio
ide3: MMIO-DMA , BIOS settings: hdg:DMA, hdh:DMA
hde: no response (status = 0xfe)
hdg: Maxtor 6Y160M0, ATA DISK drive
ide3 at 0x2284d0c0-0x2284d0c7,0x2284d0ca on irq 11
hde: no response (status = 0xfe), resetting drive
hde: no response (status = 0xfe)
hdg: max request size: 64KiB
hdg: 320173056 sectors (163928 MB) w/7936KiB Cache, CHS=19929/255/63
hdg: hdg1 hdg2 < hdg5 hdg6 hdg7 >
hda: ATAPI 52X DVD-ROM CD-R/RW CD-MRW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
----------------------------8<------------------------------------------
There are 3 20 sec' pauses.
all caused by the hde which I don't have.
On the other hand I don't have hdf too but I don't see it giving me trouble.
My SATA drive reside in hdg and is detected correctly.
Other than that I have only 1 IDE device which is hda the CD-RW drive.
Do you know whats causing this and how do I solve it?
 
Old 08-02-2004, 11:11 PM   #7
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Why don't you disable IDE2 in your BIOS and see if it stops. Since you don't have anything on that controller, you should have good results. I'll tell you why I suggest this. I read an article in a PC Magazine about how to speed up your boot. So, I followed the suggestions, thinking, "hey this makes sense."
For example, I have disabled the slave on IDE0 and IDE1, as I have only 1 hard drive, on its own cable, and one cdrom drive, on its own cable, for faster transfers. As well, I have disabled the serial ports and parallel ports since I don't use them either. No ill effect, but I sure get to the bootloader faster!
Perhaps this will solve your problem (or move the drive to the first sata controller instead...)
 
Old 08-03-2004, 05:01 AM   #8
zipo13
LQ Newbie
 
Registered: Mar 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Hi,
The IDE hard drives are disabled in my BIOS already. All but the IDE that is connected to the CD-RW.
I googled and found this message about someone who has the same problem with Fedora and SATA drive on an ABIT mother board which is exactly what I have.
Sounds like a Fedora problem to me but I'm not sure...
anyway I'll try the work around that was suggested and see if it helps.
see more details at:
http://linux.derkeiler.com/Mailing-L...4-01/0269.html
 
Old 08-03-2004, 01:22 PM   #9
zipo13
LQ Newbie
 
Registered: Mar 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Thumbs up

Well it helped.
Adding hde=none to the kernel parameters did the job and now the time is cut from 1+ min' to about 8 sec'
Thanks for all the help...
 
Old 08-03-2004, 02:15 PM   #10
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Excellent! Glad you "reported back". Another hit for google-seekers to help them too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC2 andWin XP dual boot ...grub tumblin_dice Fedora 1 11-04-2004 10:28 AM
Cannot boot XP Home with GRUB from FC2 Conpen2000 Linux - Newbie 18 08-30-2004 07:43 AM
Very slow boot with errors on FC2 Thin Fedora 3 08-01-2004 07:23 AM
grub.conf - Trying to dual boot XP and FC2 LogicNZ Linux - Newbie 4 07-01-2004 04:01 AM
grub making my redhat boot into init 1? seth Linux - Software 3 08-25-2003 11:49 PM


All times are GMT -5. The time now is 06:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration