LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-19-2004, 12:53 PM   #1
paul_linux_user
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora Core 1
Posts: 9

Rep: Reputation: 0
FC2 and ATi Radeon 9200


Hi,
i'm running Fedora Core 2, on a new pc. i've never had linux on this system before, so installing these drivers is new to me.
following the instructions on the ati site, i've installed the rpm and run its configuration program.
however when i restart X, its still using the Mesa GL driver and not the accelerated one.
the howto just says to run through their instructions again....but still, no effect.

has anyone got a fool-proof method of getting this up and running?

thanks.
 
Old 05-19-2004, 06:34 PM   #2
k0rupt
LQ Newbie
 
Registered: Dec 2003
Location: Ontario Canada
Distribution: Gentoo w/ Kernel 2.6.7
Posts: 18

Rep: Reputation: 0
Hey there Paul,

I am under the impression and FC2 doesn't use XFree86 anymore (which is what the ATI drivers on their site use). FC2 uses X.org which as far as I know there is no drivers for yet..

Anyone, if im wrong feel free to correct me...

I don't know how to fix it, only that I can't.
 
Old 05-19-2004, 09:22 PM   #3
Xyre
Member
 
Registered: Dec 2003
Distribution: Slackware 10
Posts: 32

Rep: Reputation: 15
yes, becuase if you run glxgears, youll get errors about Xlib (x.org) and xfree86-dri, its a shame, becuase id love to run ut2004 and some of my screensavers
 
Old 09-30-2004, 07:00 AM   #4
coolzero
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Rep: Reputation: 0
And can we install XFree86 on FC2?
 
Old 10-04-2004, 02:49 AM   #5
Julianus
Member
 
Registered: Nov 2003
Location: Germany
Distribution: Ubuntu 8.04
Posts: 39

Rep: Reputation: 15
The drivers for your card are available at ATI. The ATI Proprietary Linux driver currently supports RADEON 8500 and later, as well as FireGL 8700 and later products.

You don't have to install XFree to run them, you only have to make some small change to use them with xorg.
Here is how to do it:

http://www.fedorafaq.org/#radeon


Enjoy


Julianus
 
Old 10-04-2004, 03:47 AM   #6
bornhj
Member
 
Registered: Sep 2004
Location: Canberra, Australia
Distribution: Fedora Core 3, Ubuntu Hoary, Slack 10.1
Posts: 120

Rep: Reputation: 15
Yeah, theres a couple of patches you have to use...

Although I have a 9200, with the patches installed, it runs really smooth. Definately worth the effort installing 'em.
 
Old 10-04-2004, 04:03 AM   #7
coolzero
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Rep: Reputation: 0
Ok Tanks..

I'll try it tuesday...

Tanks
 
Old 10-05-2004, 02:40 PM   #8
coolzero
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Rep: Reputation: 0
OK.. I've installed the drivers...

How can I know that it's working?

I try to play TuxRacer but in the game i'm not using 3D Accelaration (exactly like when using the default drivers)...

Here is an extract of my xorg.conf file :




# === ATI device section ===

Section "Device"
Identifier "ATI Graphics Adapter"
Driver "fglrx"
# ### generic DRI settings ###
# === disable PnP Monitor ===
#Option "NoDDC"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === misc DRI settings ===
Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
Option "DesktopSetup" "0x00000000"
Option "MonitorLayout" "AUTO, AUTO"
Option "IgnoreEDID" "off"
Option "HSync2" "unspecified"
Option "VRefresh2" "unspecified"
Option "ScreenOverlap" "0"
# === TV-out Management ===
Option "NoTV" "no"
Option "TVStandard" "PAL-B"
Option "TVHSizeAdj" "0"
Option "TVVSizeAdj" "0"
Option "TVHPosAdj" "0"
Option "TVVPosAdj" "0"
Option "TVHStartAdj" "0"
Option "TVColorAdj" "0"
Option "GammaCorrectionI" "0x00000000"
Option "GammaCorrectionII" "0x00000000"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
# === Center Mode (Laptops only) ===
Option "CenterMode" "off"
# === Pseudo Color Visuals (8-bit visuals) ===
Option "PseudoColorVisuals" "off"
# === QBS Management ===
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
# === FSAA Management ===
Option "FSAAEnable" "no"
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
# === Misc Options ===
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "yes"
Option "ForceGenericCPU" "no"
BusID "PCI:1:0:0" # vendor=1002, device=5964
Screen 0
EndSection



Section "Screen"
Identifier "Screen0"
Device "ATI Graphics Adapter"
Monitor "Monitor0"
DefaultDepth 24
#Option "backingstore"

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0 # initial origin if mode is smaller than desktop
# Virtual 1280 1024
EndSubsection
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Compal P554"
DisplaySize 280 210
HorizSync 30.0 - 54.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "ServerLayout"

Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

EndSection


Can you see anything wrong?!??!
 
Old 10-05-2004, 05:27 PM   #9
bornhj
Member
 
Registered: Sep 2004
Location: Canberra, Australia
Distribution: Fedora Core 3, Ubuntu Hoary, Slack 10.1
Posts: 120

Rep: Reputation: 15
Nope, nothing wrong there. Try rebooting your computer. Then, once into KDE/GNOME/whatever, go to the menu, and see if there is an "ATI Control" entry. If so, click it, and read the first tab of the dialog that opens. It will tell you if it is using the mesa driver or the ATI one.
 
Old 10-06-2004, 01:53 AM   #10
coolzero
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Rep: Reputation: 0
Weird...

I don't have a "ATI Control"...

Can I run it from console?
 
Old 10-06-2004, 05:23 PM   #11
coolzero
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Rep: Reputation: 0
]$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.4 Mesa 5.0.2)


Is this correct?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon 9200 downtime Linux - Hardware 1 01-03-2005 09:33 PM
ATI Radeon 9200 SE phr0st Linux - Hardware 3 10-26-2004 03:09 PM
Problems with ATI Radeon 9200 in FC2 jollyroger814 Fedora 1 09-23-2004 06:55 PM
FC2 and Radeon 9200 se jeempc Fedora 4 07-26-2004 05:35 PM
ATI Radeon 9200 SE TV-OUT without ATI Driver? carboncopy Slackware 6 07-11-2004 08:30 AM


All times are GMT -5. The time now is 02:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration