LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 05-23-2013, 12:30 PM   #1
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current, custom kernel, amd64, Beyond LinuxFromScratch
Posts: 130
Blog Entries: 1

Rep: Reputation: Disabled
Fc18: How to disable power management?


I can't figure out how to keep my monitor from shutting off. Is there systemd or udev rule I need to write? I prefer to use a screensaver that is smart enough to leave the monitor on when a window on the active desktop is changing, like when I'm watching a Buster Keaton movie at http://archive.org or doing a lot of copy/paste and other mouse commands. Fool thing seems to turn on the monitor only if there's a key down/up event. My x86_64 workstation is plugged into a UPS that is controlled by apcupsd. Also, there seems to be a upowerd running that I don't want or need. I want nothing invoking hibernation, putting ram or a cpu to sleep and whatever else this invasive "feature" does. If I'm on an overseas call, I'd rather have opengl animations from the screensaver cycling every five minutes that to have something shut off my monitor without my permission. This is not a laptop; stop treating my system as if it were.
 
Old 05-23-2013, 04:19 PM   #2
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 716

Rep: Reputation: 81
Maybe if you put these commands in your X startup script or just type them into a console manually they will avoid your monitor from shutting down (if your screensaver is disabled or configured as well not to shut down your monitor):
Code:
xset s noblank
xset s off
xset -dpms
 
Old 05-27-2013, 09:50 AM   #3
eklavya
Member
 
Registered: Mar 2013
Posts: 590

Rep: Reputation: 131Reputation: 131
You need to stop APM (Advanced Power Management) service called apmd. It can be stopped by calling /etc/init.d/ script as follows:
Quote:
# /etc/init.d/apmd stop
If you don't want this service to return after a reboot type following command and deselect apmd
Quote:
# ntsysv
Or use chkconfig command:
Quote:
#/sbin/chkconfig apmd off
Take a look at this too.
http://docs.fedoraproject.org/en-US/...uide-en-US.pdf
 
Old 05-29-2013, 11:01 AM   #4
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current, custom kernel, amd64, Beyond LinuxFromScratch
Posts: 130
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Thanks for the suggestions. I'll just let xfce-power-manager and upowerd fight it out amongst themselves. Recall it is not a laptop; I have no reason to install apmd, which talks to a laptop's BIOS.

I've moved all service/target files with names like hybernate, suspend and sleep to /lib/systemd/system/never.happen. I haven't looked at dbus or examined initramfs.
One possible strategy is to open a bash xterm, invoke `cat >> /dev/null` and leave a 2-in granite cube (paperweight) on the keyboard, then start videolan with the mouse. Whichever diabolical scheme conspires to make changes to my system without permission, it responds to keyboard events (I usually tap a ctrl key to turn the monitor back on), but not mouse events. The screensaver I use is smart enough to detect changes in an active window, so it never interrupts a video stream. It will present itself five minutes after I pause the stream. Meanwhile, there are niced MPI HPC programs using the cpus and gpus, so I'll rip out anything related to power management whenever I find it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Management not working on embedded MIPS when using /sys/power/state RichardS Programming 1 01-21-2011 08:18 AM
How to Disable Power Management Option of a Lan Card in Fedore/Ubantu Amit Chakraborty Linux - Networking 2 08-23-2010 01:51 AM
How to disable power management and screen saver? jjamesis Linux - Newbie 11 12-19-2006 11:44 AM
Enabling power save/power management/cpu freq scaling features for a Debian system zero79 Debian 0 12-19-2004 02:17 PM
Power Management(sysfs) /sys/power/state mavrick613 Linux - General 0 05-24-2004 04:04 PM


All times are GMT -5. The time now is 11:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration