LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   FC17 gnome 3: problem with typing same character repeatedly (http://www.linuxquestions.org/questions/fedora-35/fc17-gnome-3-problem-with-typing-same-character-repeatedly-4175413796/)

jot 06-28-2012 04:30 AM

FC17 gnome 3: problem with typing same character repeatedly
 
kernel-PAE-3.4.3-1.fc17.i686
gnome-shell-3.4.1-5.fc17.i686
on DELL Dimension E520


Hi,

What can I try to solve the following keyboard problem:

Am able to type anything as fast as I want - as long as I do not hit the same key twice.

Eg. if I try to type "www", the 2nd and following "w" would be blocked and I would just hear a warn tone every time I hit 'w'. However, if I type very slowly, about half a second between every stroke, I face no problems. This is especially annoying for the BACKSPACE key, where I cannot quickly delete, let's say, 3 characters.

Continuously holding a key correctly starts the automatic repetition - no problem there.

Hardware setup:
- standard PS2 keyboard
- PS2 mouse
- PS2-based KVM switch
- combined PS2-to-USB adapter for keyboard and mouse

Further facts:
- no typing problem outside of the GUI (if I switch to text terminal)
- no typing problem on an older Linux box attached to same KVM switch
- no problem with the mouse
- no typing problem on older Linux on same machine previously

Any hints welcome! Thanks

macemoneta 06-28-2012 11:35 PM

Go to System Settings, Universal Access, and make sure 'bounce keys' is turned off.

jot 06-28-2012 11:50 PM

solved!
 
Hi macemoneta

Thank you so much - that was it! Am not sure why it was enabled, must have been me when I tested each and every feature of the interface.

Though, I keep wondering: in what situation would someone want this setting to be enabled?

Cheers!
Jot

macemoneta 06-28-2012 11:57 PM

The universal access settings are to assist those that are physically challenged in some way. Some folks have illnesses like Parkinson's disease which cause tremors, making typing difficult.

jot 06-29-2012 12:04 AM

Oh, I see. Yes, that makes sense.


All times are GMT -5. The time now is 02:22 AM.