LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   FC10 nvidia troubles and other related issues (http://www.linuxquestions.org/questions/fedora-35/fc10-nvidia-troubles-and-other-related-issues-690032/)

bocochoco 12-12-2008 03:57 AM

FC10 nvidia troubles and other related issues
 
I think I have it installed right, but I'm not sure. I'm not a complete noob to linux, but I wouldn't call myself an expert either.

I tried a lot of things, most of which didn't work. First I tried adding the livna and rpm fusion repositories to yum, and installing kmod-nvidia. Fail. next tried akmod-nvida. Fail again. After that, I got annoyed and ignored everything I've read and installed the drivers from the nvidia website, which seems to have worked, though I'm not sure. I don't have the nvidia logo showing up when I boot. Perhaps this has something to do with me having two 7600GT in SLI?

A somewhat related issue that I am having is getting the damn thing to output in my monitors native resolution of 1680x1050. No matter what I try, it does not want to let me set it... I can't figure out why.

If I could get some help, I would be infinitely grateful.

My xorg.conf is below
Code:

# Xorg configuration created by system-config-display

Section "ServerLayout"

#        Screen      1  "Screen1" RightOf "Screen0"
        Identifier    "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath  "/usr/lib64/xorg/modules"
        FontPath    "catalogue:/etc/X11/fontpath.d"
        FontPath    "built-ins"
EndSection

Section "Module"
        Load  "glx"
        Load  "dbe"
        Load  "dri"
        Load  "extmod"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "nv"
        VendorName  "nVidia Corporation"
        BoardName  "G70 [GeForce 7600 GT]"
        BusID      "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    1
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    4
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    8
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    15
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    16
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection

And on a somewhat unrelated note, is there a way to enable Cool n Quiet mode on AMD processors in linux? The cpu fan is loud as hell while the computer is idle.

forrestt 12-12-2008 09:31 PM

Here is my xorg.conf:

Code:

# Xorg configuration created by livna-config-display                                       

Section "ServerLayout"
        Identifier    "Default Layout"
        Screen      0  "Screen0" 0 0 
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection                                     

Section "Files"
        ModulePath  "/usr/lib64/xorg/modules/extensions/nvidia"
        ModulePath  "/usr/lib64/xorg/modules"                 
EndSection                                                     

Section "ServerFlags"
        Option      "AIGLX" "on"
EndSection                     

Section "InputDevice"

    # generated from default
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "Emulate3Buttons" "no"   
        Option      "ZAxisMapping" "4 5"     
EndSection                                   

Section "InputDevice"

# keyboard added by rhpxl
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Unknown"
        ModelName    "Unknown"
        HorizSync    30.0 - 110.0
        VertRefresh  50.0 - 150.0
        Option      "DPMS"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        Option      "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection

Section "Extensions"
        Option      "Composite" "Enable"
EndSection

Try replacing yours with this one (back yours up first):
Code:

% sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf
You can also try just removing your xorg.conf and restarting X. The new version of X doesn't really need the xorg because it probes the hardware if it can't find one.

If that doesn't fix things run 'rpm -qa | grep nvidia' and post the output here.

HTH

Forrest

bocochoco 12-14-2008 02:01 AM

I tried using your xorg.conf, and it didn't work. Also deleting the one that I have now also does not work.

[root@boco ~]# rpm -qa | grep nvidia
[root@boco ~]#

Seems like the driver never installed?

Another issue seems to have popped up. If X is not running, I cant do anything. the screen is impossible to read, garbage is everywhere. I can still type things out and it does what I tell it to do, but I cant see what it does. I can't figure this one out.. it's quite irritating. It is hard for me to explain in words what it looks like, so I took a crappy picture of it.. http://i38.tinypic.com/awont1.jpg

forrestt 12-14-2008 12:18 PM

Try running
Code:

yum install kmod-nvidia
HTH

Forrest

bocochoco 12-14-2008 05:24 PM

Quote:

Originally Posted by forrestt (Post 3375262)
Try running
Code:

yum install kmod-nvidia
HTH

Forrest

That seems to have worked. I tried it before and it just caused problems though... Thanks for helping.

Any idea what is going on when the X server isn't running?

forrestt 12-15-2008 01:42 PM

This has happened to me in the past. I'm guessing it is a bug in the nvidia driver. When it happened to me, my VCs were fine if I booted to single user or run level 3. As soon as I started X and went back to a VC, it would look like that. Only rebooting would get the VCs readable again. I have since upgraded my computer (and thus have a newer Nvidia card, and I don't have this problem anymore.

Forrest

hans21 12-15-2008 05:58 PM

Hello bocochoco,

first of all, please avoid installing drivers from nvidia web site. The drivers form the repository are compiled particularly for Fedora and in my experience they've always had everything one may need. Besides, installing the other driver (the one from the web site), makes it tiresome to maintain (i.e. uninstall), you also can't see in your rpm database since Nvidia doesn't provide rpm binary packages on their website, therefore, only packages with rpm extension appear in rpmdb lookups.

Second, changing resolution in Fedora 10 kinda sucks... The default resolution on my monitor is 1024x768. If I set it to anything higher it works temporarily, but after X server restart, it gets back to old resolution. So, you have to edit xorg.conf file manually and add the screen resolution lines. Basically, only thing you have to change is the Screen section:


Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1152x864" "1024x768" "800x600"
EndSubSection
EndSection


and add everything between "SubSection"... "EndSubSection" lines. If you have some of those lines, just add the ones missing (don't remember what lines file contained before editing it) with resolution appropriate for your monitor.


Best regards.


All times are GMT -5. The time now is 03:37 PM.