LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-07-2004, 09:40 AM   #1
billlee
Member
 
Registered: Jun 2003
Location: East Texas
Distribution: Fedora (10,11)
Posts: 40

Rep: Reputation: 15
FC1 boot hangs on dual boot system


I have a dual boot HP laptop. Came with XP (of course :-) ) and I have installed FC1

Partitioned using PartitionMagic as

/boot 100mb ext3
C: 38gb ntfs
E: 50mb FAT32 (for BootMagic)
/ 37gb ext3
SWAPSPACE 894mb

After much travail with bootMagic, I switched to grub, got it loaded on the MBR and have successfully used it to boot XP.

However, when I attempt to boot FC1, the boot process gets into the stage

"Setting up local disks"

for about 10 seconds and then the system just hangs. It will not respond to the keyboard or mouse, the little rotating graphic on the boot screen stops.....nothing.

I have let it sit for several minutes thinking it my be a timeout problem....nothing.

The only recourse is to turn off the machine and try something else.

Using the FC installation CD, I have entered linux rescue and done a chroot /mnt/sysimage but not sure what to look for or where to go from there. I looked into the /var/log directory to see if there were any messages there and found nothing that would make any sense.

Can someone give me some ideas on what to look for to try and diagnose this problem?

Thanks.

Bill Lee

PS: Cannot use a boot floppy since the laptop has no floppy drive.
 
Old 05-07-2004, 12:08 PM   #2
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Did you modify the partitions with PM after installing linux? Has linux ever run? I think what your saying is that BootMagic couldn’t start grub/linux and grub is having problems, too.

1. If you modified or added partitions after installing linux, the /etc/fstab entries may be pointing to the wrong partitions. Since there are 5 partitions, at least one is a logical partition. If you converted a primary to a logical partition, the partition numbering changed. Under linux rescue, us vi to look at /etc/fstab.

2. Also, if linux never ran, how did you later install grub to the MBR? I am just checking that it was done correctly.

3. During the fedora boot, a system file check gets run periodically that can take 1-20 min to complete, depending on partition size. It looks a lot like what you are describing, but I think the progress indicator keeps turning. The system is unresponsive during the check, but you should see occasional disk (light) activity.
 
Old 05-07-2004, 03:20 PM   #3
billlee
Member
 
Registered: Jun 2003
Location: East Texas
Distribution: Fedora (10,11)
Posts: 40

Original Poster
Rep: Reputation: 15
Sure do appreciate the response!

"Did you modify the partitions with PM after installing linux?" - No.

"Has linux ever run?" - No, not that I am aware of. Only via the "linux rescue", which when you chroot /mnt/sysimage is running the installed system, is it not?

"....BootMagic couldn’t start grub/linux and grub is having problems.." - BootMagic couldn't even find the Linux OS on the partition...or something like that. It would simply hang saying "Preparing machine for..." or a message like that.

"...modified or added partitions after installing linux,..." - I have not changed the partitions that I listed. They were created with PM, and FC1 has been loaded successfully. No changes in the partitions have been made since FC1 was loaded.

Here is the fstab (obtained by using linux rescue and then chroot /mnt/sysimage):

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda7 swap swap defaults 0 0

"....how did you later install grub to the MBR?..." - I am pretty sure I did that either when under "linux rescue" or "chroot /mnt/sysimage". Seemed to work just fine since GRUB now shows up as the boot loader at power up, and it DOES cause XP to boot properly. and it DOES seem to START doing the FC1 boot.

"....During the fedora boot, a system file check....I think the progress indicator keeps turning...should see occasiona ldisk (light) activity" - I have left the system in the hung state for as long as an hour or better. And there is no progress indicator action, and no disk activity indication. No mouse or keyboard response.....simply locked up tight as a drum.

Again, thanks for the response.

Bill Lee
 
Old 05-07-2004, 05:52 PM   #4
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Since the cause of the problem was not obvious to me, I decided to “see what you know” by looking at your past postings and found a lot of information about your problem in

http://www.linuxquestions.org/questi...hreadid=178059

Now I think I know what might be wrong, based upon the advice you were given. I think Grub is pointing to the wrong partition.

But first, is the partition “/boot” doing anything? I assume it got created while trying to follow the old advice. You can probably get rid of it, but wait until you read the rest of my comments.

Based on the fstab entries, I am going to assume that “/boot” and “C:” are primary/physical partitions and that “E:”, “/” and “Swapspace” are logical partitions. If I am wrong, the rest of what I say will be slightly off and do not use the drives that I have shown below.

Start linux rescue and mount the sysimage as root as you did before. From the command line, enter:

/sbin/grub #(this should start grub command line and give you the “grub>” prompt)

------------
Special instructions that you may not need:

If you didn’t get the grub> prompt, then make a Grub Boot Disk by placing a floppy in the drive and typing:

cd /usr/share/grub/i386-redhat
dd if=stage1 of=/dev/fd0 bs=512 count=1
dd if=stage2 of=/dev/fd0 bs=512 seek=1

Then reboot using the drive and continue to follow the instruction (see below). As a side note, it doesn’t hurt to have a grub boot disk around, because it is a quick way to fix grub problems. Why not make one anyway, after you do the grub> stuff below, but before you reboot?
------------

Now, from the grub> prompt, enter:

find /boot/grub/stage1 #(it should return “(hd0,5)”)
root (hd0,5) #(as long as “(hd0,5)” was returned by find)
setup (hd0) #(installs grub stage1 to the MBR)
exit

Linux should now boot from grub. The old advice had you select “/boot” (i.e., (hd0,0)) as the boot partition, whereas “/” (i.e., (hd0,5)) was the actual boot partition. In “grub-speak”, drives and partitions are numbered starting at zero. So (hd0,0) is usually the first primary partition on the first drive (or /dev/hda1 in “linux-speak”). And (hd0,5) is usually the second logical partition (partition six) on the first drive (or /dev/hda6).

I hedge a little (i.e., “usually”) because using PartitonMagic to resize, move, add and delete partitions can trigger some downright strange physical numbering.

----------

If all of that did not work, you are at the point where you should think of doing a clean linux installation. Actually, expect to reinstall fedora a number of times when you are starting out and start trying to do “fancy” things.

To me, a clean installation means deleting the non-NTFS partitions and starting over with PartitionMagic. If you need to reinstall, here are some suggestions.

1. My first comment has to do with partitions:

If you don’t plan to use BootMagic, set up your partitions this way:

NTFS (as primary, but could be logical)
Swap (logical, closer to the head read for faster access)
ext3 (logical)
unformated within the extended partition (as an option)

If you want to try BootMagic again, then set them up this way:

NTFS (as primary, but could be logical)
FAT16 (i.e., FAT as primary, but could be logical)
Swap (logical, closer to the head read for faster access)
ext3 (logical)
unformated within the extended partition (as an option)

2. I have BootMagic running on four systems, so I don’t understand why people have so much trouble with it. It makes multiboot running of WinXP, Win98 and linux on the same system very easy to administer, as long as you understand the Advanced Partition Hiding feature in BM. BM can be a problem child with the newer motherboards with Raid/SATA drives (i.e., I have two of them), but it is still workable. To me, it is much easier to fix BM than to fix grub when things go wrong.

3. If you use BootMagic, “write” grub to the first sector of the linux partition. During a fedora installation, this option is under something like advance boot options. It’s triggered by a check box on one of the manual partition pages during fedora installation. Otherwise write grub to the MBR.


So, let me know how it turns out.

Last edited by WhatsHisName; 05-07-2004 at 07:34 PM.
 
Old 05-07-2004, 10:31 PM   #5
billlee
Member
 
Registered: Jun 2003
Location: East Texas
Distribution: Fedora (10,11)
Posts: 40

Original Poster
Rep: Reputation: 15
Well, a great deal of trying, all with exactly the same results: 10 seconds after the message "setting local disks" is displayed, the system locks up tight. No response to keyboard nor mouse, the progress icon is stopped, no disk activity,.....

Here's what I tried.

First off I use linux rescue to run grub. I did the
find /boot/grub/stage1
and grub came back with an error 15(I think) saying the file could not be found. Interesting, because I could cd into /boot and then into the grub directory, and the stage1 file was there big as life.

So the next step was to repartition everything and reload the FC1. The partitions were something like this:
C: NTFS 38gb containing XP
SWAP: 500mb
/ 38gb ext3 where I was to load FC1

I then went into the FC1 load and when it asked for how to partition, I let it do it's automatic thing. An hour or so later, the load was complete and I attempted to boot once again with the same lock-up results.

I then booted XP and took a look at the partitions and THERE WAS THE /boot PARTITION again! And the SWAP partition moved off to the end of the disk! Apparently the autopartitining sets it up that way.

Well, I still wanted to try it again, so I once again used PartitionMagic to set up the partitions as above:

C: 38gb NTFS holding XP
SWAP 500mb
/ 38gb ext3

Then, once again back to the laoding of FC1. But THIS time, I did not use the automatic partitioning and when I just looked a few moments ago, the partitioning I set with PM still exists. But, as with all of the other attempts 10-12 seconds into the "setting local disks", the boot process stops and the machine is locked up tight.

I have now gone into linux rescue/chroot.... and the fstab is

LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda5swap swap defaults 0 0

Where to go from here?

Thanks for the help.

regards,

Bill Lee
 
Old 05-08-2004, 09:37 PM   #6
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Isn’t installing linux getting easier?

I think you have a good installation and the problem may be during the hardware detection phase, but while it’s on my mind, let me point you to a help page related to the PM formatting followed by linux installation.

----------

During the fedora installation after setting up the partitions with PM, don’t let disk druid format anything. I think it tries to reformat the swap or ext3 (i.e., the column next to the partition is “checked”) and then you have to answer a couple of questions that make you think you are doing something wrong. You know, one of those “are you sure” questions. Look at this link from PowerQuest/Symantec about multiboot installations of an old version of Red Hat.

Installing Red Hat Linux in a Multiple Boot Scenario
http://www.symantec.com/techsupp/primus/id3280.html

When you read the page, remember that it was written for RHL7 and probably PM6, but the underlying concepts are correct for fedora. There are also several helpful linux tips on the Symantec support site under PM self-help.

----------

Again, you may well have a good linux installation, but a configuration problem is stopping you. Sometimes, it’s an X (i.e., GUI) issue, but I don’t think you would get the first screen if you had a serious X problem. It kind of sounds like a hardware configuration issue.

Try to boot again and when the first screen opens (i.e., the one with “setting local disks”), immediately hit the “show details” and see if anything appears on the screen. The first thing that happens after the disk setup is that a utility called kudzu runs to detect new hardware. Think of it as linux plug-and-play.

There have been a lot of posts about kudzu-related problems in the last month. I even got stomped on by it a couple of months ago when I updated the hwdata information, which contains a database of hardware. The usual suggestion with a kudzu problem is to turn off the kudzu service, but that is hard to do when you can’t boot.

Your best option may be to repost a new thread with a title like “Can’t first boot Fedora, kudzu problem?” or “Fedora can’t boot, how do I stop kudzu?” in the Hardware or General forum and hope that someone else overcame the same problem. Be sure to say that it has never successfully booted. A lot of people answer kudzu questions.

In the meantime, if you want to try something kudzu-related, the goal would be to stop kudzu from running at startup. I don’t know how to do that the “correct way” with an unbootable system.

What I am going to suggest is out of my area of expertise, so consider the source. Normally, you boot into run level 5. The options for what might get started in run level 5 are contained in /etc/rc5.d and are named in files starting K##.... or S##.... One is S05kudzu, which is the call for the kudzu service. I don’t know whether just renaming the file is sufficient to disable the service. If it is moved (i.e., copied and removed), it can’t start in run level 5. So if you want to try something, mess with S05kudzu, but like I said, consider the source.

That said, I just ran out of ideas. Maybe something will come to me by Monday.
 
Old 05-08-2004, 09:46 PM   #7
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Forgot something. The grub manual has a troubleshooting section that lists error messages.

Grub Manual
http://www.gnu.org/software/grub/manual/grub.html

From the manual:

“Errors reported by the Stage 2:

...
15 : File not found
This error is returned if the specified file name cannot be found, but everything else (like the disk/partition info) is OK.
..."
 
Old 05-09-2004, 08:21 AM   #8
billlee
Member
 
Registered: Jun 2003
Location: East Texas
Distribution: Fedora (10,11)
Posts: 40

Original Poster
Rep: Reputation: 15
"Isn’t installing linux getting easier?" - yes, but not the kind of experience I was really looking for!! :-)

Thanks for the URLs for added information.

"...and when the first screen opens (i.e., the one with “setting local disks”), immediately hit the “show details” and see if anything appears on the screen. The first thing that happens after the disk setup is that a utility called kudzu runs to detect new hardware..."

I have done this several times and nothing appears. The hang occurs first.

If I recall, kudzu is initiated as part of the rcX.d scripts. Those are started by the rc script. Although I have no way of telling, I do not think the rc script is ever being referenced. But in any case, I disabled it (by simply renaming the "S" link) and tried to boot again. Alas, nothing has changed: still locks up about 10 seconds after displaying the "Setting up local disks" message.

Do you (or anyone) know how to disable the graphical boot display and get me back to the older style where all of the boot messages are spewed to the screen? After the system boots, you can see them with dmesg, but if the system does not boot, they are inaccessible (unless they are also written somewhere. Where?) If I had a screen-full of messages when the system locks up, perhaps I could see where it was in the process.

I have posted another thread over in the Releases forum.

Thanks for your help

Regards,

Bill Lee
 
Old 05-10-2004, 11:25 AM   #9
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Yes, it would be nice to see the entire boot again, but I have never read how to get it back. As an option, you can get to run level 3 (i.e., command line) by modifying the init level in /etc/inittab by changing:

id:5:initdefault:

to

id:3:initdefault:

People claim that you can get to run level 3 at the grub OS selection, but I have never gotten any suggestion to work. You probably already know, but running startx at command line starts the GUI. At least if you change to level 3, you can troubleshoot a little faster, since you seem to be at a higher linux level than I initially thought.

I was going to suggest dmesg at command level, but it is very likely that booting to run level 3 will not trigger the problem, assuming the problem is occurring during the X startup. I assumed at the time that reinstalling fedora would fix you up. Obviously not.

My experience with problems involving booting fedora into X is that they are very hard to resolve. Someone once reminded me that X isn’t linux, or said another way, it’s just an application that runs under linux.

Back to the problem, is there something odd about your hardware? If it is new and top-of-the-line, you may have a hardware component that is either not defined or misdefined in hwdata and is defying configuration under X. That usually manifests itself as a “can’t start x” problem. I noticed that /dev/cdrom did not appear in fstab and that struck me as odd. Posting your hardware might trigger someone else to comment on the problem.

Good luck.
 
Old 05-10-2004, 05:38 PM   #10
billlee
Member
 
Registered: Jun 2003
Location: East Texas
Distribution: Fedora (10,11)
Posts: 40

Original Poster
Rep: Reputation: 15
Thanks for all of your help. I was able to solve the problem.

In order to actually SEE where the hang was occurring, I needed to get rid of the graphical boot display. So, the first thing to do was to turn off the graphical boot screens and return to the old/"normal" boot display where all of the messages are spewed to the screen. To do this, I entered linux rescue and chroot /mnt/sysimage and edited the grub.conf file in /boot/grub. In that file is a command line invoking the kernel with a series of options. I simply removed the "rhgb" option and the graphical boot was gone!

This then allowed me to see just where in the boot process the hang occurred. It was while attempting to initiate the firewire support. Looking around on the net I found where the kernel for FC1 is broken in that area. On order to get past that, I went once more back to the grub.conf file and added an option "nofirewire" to the kernel command line. And: boot successful.

From this it became crystal clear that anything done at the rc script or later (such as switching run levels, etc) was fruitless. But the above did resolve my problem.

Now the fun: I have downloaded and am currently loading Fedora Core 2 Test 3. Will be interesting to see what happens in about an hour or so when it finishes loading and I try to boot once again!

Again: thanks for your help.

Regards,

Bill Lee
 
Old 05-10-2004, 06:34 PM   #11
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
rhgb, huh? That was way too easy!

So, for temporary relief from the major pain of the fedora startup screen when troubleshooting problems, you can also select the “a” option at the grub kernel selection screen and remove “rhgb” from the end of the boot arguments for the current boot.

Sorry, I’ve been watching too much late night TV.

Last edited by WhatsHisName; 05-12-2004 at 12:34 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dual boot, win xp sometimes hangs on boot rmakers Linux - General 8 02-12-2005 12:02 PM
Dual Boot = No Boot (hangs at bios splash screen) nedwardss Debian 4 12-03-2004 05:09 AM
FC1 & WinXP (Dual boot) Alkalined Linux - Newbie 3 10-29-2004 09:48 PM
FC2 post-install hangs on dual boot system Rainer Butsch Fedora - Installation 1 09-11-2004 09:08 PM
Setting up for dual boot FC1 and another distro slackist Linux - Newbie 1 06-02-2004 10:32 AM


All times are GMT -5. The time now is 10:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration