LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   F18 won't boot in GUI by default! (http://www.linuxquestions.org/questions/fedora-35/f18-wont-boot-in-gui-by-default-4175451717/)

PR0F0x37 02-26-2013 12:34 AM

F18 won't boot in GUI by default!
 
Yesterday, while running a yum update my fedora crashed and I had to hard-reboot it. Since then, it goes into text mode by default after startup, and after logging into the terminal, I have to give a 'startx' command manually to display the gui.

I've tried reinstalling gnome-shell and running
Code:

ln -s /lib/systemd/system/graphical.target /etc/systemd/system/default.target
but that didn't help.

How do I make it boot in GUI by default?

Ztcoracat 02-26-2013 02:16 AM

Hi:

This thread might help:
http://www.linuxquestions.org/questi...dition-940690/

Switching to a Graphical Login
http://docs.fedoraproject.org/en-US/...gui-login.html

Fedora Systemd
http://fedoraproject.org/wiki/Systemd

Hope this helps;)

PR0F0x37 02-26-2013 02:51 AM

I tried reinstalling gdb but that didn't help.

The article at http://docs.fedoraproject.org/en-US/...gui-login.html suggests altering the inittab file, but it's not being used anymore (it's been replaced by systemd).

I've also tried the "changing runlevels" method given on
http://fedoraproject.org/wiki/System...lt_runlevel.3F
but that didn't help either.

What could be the issue?

Ztcoracat 02-26-2013 01:09 PM

Quote:

Originally Posted by PR0F0x37 (Post 4899897)
I tried reinstalling gdb but that didn't help.

The article at http://docs.fedoraproject.org/en-US/...gui-login.html suggests altering the inittab file, but it's not being used anymore (it's been replaced by systemd).

I've also tried the "changing runlevels" method given on
http://fedoraproject.org/wiki/System...lt_runlevel.3F
but that didn't help either.

What could be the issue?


Not sure what the issue is- (maybe) corrupt installation files (or) a bug


Besides that the Fedora documentation mentions:
When you install Fedora in 'text mode' you can configure you system to use the graphical interface. It may be in the way you installed it; the options you choose-
http://docs.fedoraproject.org/en-US/...imode-x86.html

Ztcoracat 02-26-2013 01:22 PM

This should help-

Booting into a Graphical Environment

Quote:

Warning: Change only the number of the default runlevel from 3 to 5.

http://docs.fedoraproject.org/en-US/...oting-GUI.html

John VV 02-26-2013 05:14 PM

Quote:

while running a yum update my fedora crashed and I had to hard-reboot it. Since then
read the rpm list in /var/log/yum.log
and reinstall the updates from the text only boot

a crash and hard reboot
caused some updates to NOT be installed and at least one to not be FULLY installed


All times are GMT -5. The time now is 06:56 AM.