LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 06-17-2006, 08:41 PM   #1
AtomicAmish
Member
 
Registered: Dec 2005
Location: East coast, USA
Distribution: Slackware 12.0
Posts: 139

Rep: Reputation: 15
eth0 DHCP time out on boot


New installation of FC5 went fine (nVidia nForce2), except for no internet. Same system ran FC3 one year ago without this problem, and runs SUSE 9.3 now.

dmesg | grep eth and /sbin/ifconfig -a show the ethernet card is detected and packets are being received, but at boot - determining IP info - it times out.

Those two commands are all I know to check. This is the only computer on my home network.

Can someone point me in the right direction, or is this too difficult for a relative newbie like me to solve?
 
Old 06-17-2006, 11:26 PM   #2
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 551
Blog Entries: 1

Rep: Reputation: 45
You might want to assign a static IP address to the ethernet card.
 
Old 06-18-2006, 08:09 AM   #3
AtomicAmish
Member
 
Registered: Dec 2005
Location: East coast, USA
Distribution: Slackware 12.0
Posts: 139

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by xode
You might want to assign a static IP address to the ethernet card.
Thanks for the response, xode.

I suppose I could do that, but because it is DHCP, I would need to do it every time I use the computer, or leave it connected continuously. Now, when I'm not using the computer, I disconnect the cable for security reasons and frequently get a new IP when I reconnect.
 
Old 06-18-2006, 08:31 AM   #4
AtomicAmish
Member
 
Registered: Dec 2005
Location: East coast, USA
Distribution: Slackware 12.0
Posts: 139

Original Poster
Rep: Reputation: 15
I guess I can't use FC.

Slackware and SUSE have no problem with my system, but I had hoped to replace SUSE with FC. I've not yet been able to configure Slackware into a usable OS on my system, but I've bought a subscription and it's just a matter of time and effort.
 
Old 06-18-2006, 10:51 AM   #5
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 551
Blog Entries: 1

Rep: Reputation: 45
Quote:
From AtomicAmish

I suppose I could do that, but because it is DHCP, I would need to do it every time I use the computer, or leave it connected continuously. Now, when I'm not using the computer, I disconnect the cable for security reasons and frequently get a new IP when I reconnect.
??? And just how do you connect to the internet? Specifically, what other pieces of hardware do you have that are involved in your internet connection other than your computer?
 
Old 06-18-2006, 12:22 PM   #6
AtomicAmish
Member
 
Registered: Dec 2005
Location: East coast, USA
Distribution: Slackware 12.0
Posts: 139

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by xode
??? And just how do you connect to the internet? Specifically, what other pieces of hardware do you have that are involved in your internet connection other than your computer?
I have a DSL unit ("modem") which is between the computer and phone connection.

It's an always-on connection, but since I'm not running a server there's no reason to leave it connected when I'm not using it. It's a trick I learned when I was on Windows, and I see no reason to stop it in Linux.

Although I would like to use FC, like I said before, Slackware-based distros and SUSE work fine with this system and I will stay with only them if need be.

I've had this same problem with all Debian-based distros, too - so it's not just FC.
 
Old 06-19-2006, 06:00 AM   #7
decrepit
Member
 
Registered: May 2006
Distribution: Ubuntu10.04, < fedora12
Posts: 347

Rep: Reputation: 34
How many eth cards have you got??? I've had problems with eth0 and eth1 shifting positions.
I have had the occasional problem with DHCP timing out during boot, (I've now set it to not activate at boot) but it's just a matter of manually activating afterwards. Can you do that??
 
Old 06-19-2006, 06:09 AM   #8
baikonur
Member
 
Registered: Oct 2005
Location: germany
Distribution: debian
Posts: 255
Blog Entries: 5

Rep: Reputation: 30
that's also what I've gone through, decrepit.
the box tried to activate DHCP on eth0, but the interface I wanted to
use was eth1. I used a workaround a la ifdown eth0; ifup eth1 or something
like that and it worked.
Then I configured /etc/network/interfaces correctly and that
solved my trouble for good.
 
Old 06-19-2006, 10:06 AM   #9
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 551
Blog Entries: 1

Rep: Reputation: 45
Quote:
From decrepit

I have had the occasional problem with DHCP timing out during boot, (I've now set it to not activate at boot) but it's just a matter of manually activating afterwards. Can you do that??
AtomicAmish could add this to /etc/rc.d/rc.local
 
Old 06-19-2006, 03:03 PM   #10
AtomicAmish
Member
 
Registered: Dec 2005
Location: East coast, USA
Distribution: Slackware 12.0
Posts: 139

Original Poster
Rep: Reputation: 15
Thank you all for your replies. I can get back to this at the end of the week, and will let you know how this works out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting eth0 at boot time ? Antonius Linux - Newbie 1 01-19-2005 07:27 PM
eth0 causes looooong boot time mrsolo Linux - Software 10 11-07-2004 09:29 PM
dhcp failure, eth0 gets no ip address on gentoo livecd boot behind hub Kethinov Linux - Networking 1 01-22-2004 01:17 PM
howto disable eth0 at boot time rydogg Linux - Newbie 2 06-16-2003 09:33 AM
How to not init eth0 at boot time aldaeron Linux - Networking 4 08-07-2002 07:30 PM


All times are GMT -5. The time now is 12:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration