LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 09-21-2007, 07:28 AM   #1
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
Error when run "dhclient wlan0"?


After config wlan0, I used dhclient but error appear:
Quote:
Internet Systems Consortium DHCP Client V3.0.5-RedHat
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
wmaster0: unknown hardware address type 801
/sbin/dhclient-script: configuration for wlan0 not found. Continuing with defaults.
/etc/sysconfig/network-scripts/network-functions: line 78: wlan0: No such file or directory
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:19:d2:6d:f5:b0
Sending on LPF/wlan0/00:19:d2:6d:f5:b0
Sending on Socket/fallback
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 21
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
No DHCPOFFERS received.
Trying recorded lease 192.168.1.118
/sbin/dhclient-script: configuration for wlan0 not found. Continuing with defaults.
/etc/sysconfig/network-scripts/network-functions: line 78: wlan0: No such file or directory
PING 192.168.1.1 (192.168.1.1) from 192.168.1.118 wlan0: 56(84) bytes of data.

--- 192.168.1.1 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2022ms
, pipe 3
No working leases in persistent database - sleeping.
/sbin/dhclient-script: configuration for wlan0 not found. Continuing with defaults.
/etc/sysconfig/network-scripts/network-functions: line 78: wlan0: No such file or directory
How do I config wlan0 in /sbin/dhclient-script?
 
Old 09-21-2007, 07:43 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
ifup wlan0

provided wlan0 exists... what is wlan0 then?

fedora has a dialog for adding and configuring network devices - why don't you use it?
 
Old 09-21-2007, 09:51 PM   #3
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Original Poster
Rep: Reputation: 100Reputation: 100
Quote:
Originally Posted by Simon Bridge View Post
ifup wlan0

provided wlan0 exists... what is wlan0 then?

fedora has a dialog for adding and configuring network devices - why don't you use it?
Ofcouse, I had run:
Code:
/sbin/ifconfig wlan0 up
I knew Fedora 7 has a dialog for config wireless but I like using command line, moreover when I actived wlan0 in dialog I see same error or
Quote:
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Device or resource busy.
Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device wlan0 ; Operation not supported.

Determining IP Information for wlan0 ... failed
ps: I set mode: auto, bit rate: auto

Last edited by quanta; 09-21-2007 at 10:34 PM.
 
Old 09-23-2007, 05:13 AM   #4
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
does ifconfig show a wmaster0 as well as a wlan0?
what is wlan0? What is the wireless card?

possible:
https://bugs.launchpad.net/ubuntu/+s...hal/+bug/62535
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 02:16 PM
"capset: Operation not permitted" error when I run valgrind. rsravi74 Linux - Newbie 1 09-02-2007 06:30 PM
error: "c compiler cannot create executables" when trying to run ./configure fedoraemu Linux - Software 2 04-24-2007 08:43 PM
Run command "dhcpcd wlan0" when connecting with KInternet or at boot baraujo Suse/Novell 1 05-27-2006 07:07 AM
Wireless chip is displayed as "Ath0" instead of "wlan0" with Belkin F5D7000 ceramicsushi Linux - Wireless Networking 4 04-06-2006 12:26 AM


All times are GMT -5. The time now is 07:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration