LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   error trying to install lsb on fedora raspi remis (http://www.linuxquestions.org/questions/fedora-35/error-trying-to-install-lsb-on-fedora-raspi-remis-4175444663/)

frieza 01-08-2013 11:13 AM

error trying to install lsb on fedora raspi remis
 
Code:

su -c 'yum install lsb'
comes back with
Code:

Error: Package: perl-CGI-3.52-218.fc17.noarch (updates)
          Requires: perl(:MODULE_COMPAT_5.14.3)
Error: Package: perl-Locale-Codes-3.24-1.fc17.noarch (updates)
          Requires: perl(:MODULE_COMPAT_5.14.3)
 You could try using --skip-broken to work around the problem

full output
Code:

Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package redhat-lsb.armv5tel 0:4.1-5.fc17 will be installed
--> Processing Dependency: redhat-lsb-printing = 4.1 for package: redhat-lsb-4.1-5.fc17.armv5tel
--> Processing Dependency: redhat-lsb-languages = 4.1 for package: redhat-lsb-4.1-5.fc17.armv5tel
--> Processing Dependency: redhat-lsb-desktop(armv5tel-32) = 4.1 for package: redhat-lsb-4.1-5.fc17.armv5tel
--> Processing Dependency: redhat-lsb-cxx(armv5tel-32) = 4.1 for package: redhat-lsb-4.1-5.fc17.armv5tel
--> Processing Dependency: redhat-lsb-core(armv5tel-32) = 4.1 for package: redhat-lsb-4.1-5.fc17.armv5tel
--> Running transaction check
---> Package redhat-lsb-core.armv5tel 0:4.1-5.fc17 will be installed
--> Processing Dependency: redhat-lsb-submod-security(armv5tel-32) = 4.1 for package: redhat-lsb-core-4.1-5.fc17.armv5tel
--> Processing Dependency: /usr/bin/pax for package: redhat-lsb-core-4.1-5.fc17.armv5tel
--> Processing Dependency: /usr/bin/patch for package: redhat-lsb-core-4.1-5.fc17.armv5tel
--> Processing Dependency: /usr/bin/msgfmt for package: redhat-lsb-core-4.1-5.fc17.armv5tel
--> Processing Dependency: /usr/bin/lpr for package: redhat-lsb-core-4.1-5.fc17.armv5tel
--> Processing Dependency: /usr/bin/lp for package: redhat-lsb-core-4.1-5.fc17.armv5tel
--> Processing Dependency: /usr/bin/gettext for package: redhat-lsb-core-4.1-5.fc17.armv5tel
---> Package redhat-lsb-cxx.armv5tel 0:4.1-5.fc17 will be installed
---> Package redhat-lsb-desktop.armv5tel 0:4.1-5.fc17 will be installed
--> Processing Dependency: redhat-lsb-submod-multimedia(armv5tel-32) = 4.1 for package: redhat-lsb-desktop-4.1-5.fc17.armv5tel
--> Processing Dependency: qt3(armv5tel-32) for package: redhat-lsb-desktop-4.1-5.fc17.armv5tel
--> Processing Dependency: libpng-compat(armv5tel-32) for package: redhat-lsb-desktop-4.1-5.fc17.armv5tel
---> Package redhat-lsb-languages.armv5tel 0:4.1-5.fc17 will be installed
--> Processing Dependency: perl(Test::Simple) for package: redhat-lsb-languages-4.1-5.fc17.armv5tel
--> Processing Dependency: perl(Test::Harness) for package: redhat-lsb-languages-4.1-5.fc17.armv5tel
--> Processing Dependency: perl(Pod::Plainer) for package: redhat-lsb-languages-4.1-5.fc17.armv5tel
--> Processing Dependency: perl(Locale::Codes::Constants) for package: redhat-lsb-languages-4.1-5.fc17.armv5tel
--> Processing Dependency: perl(Locale::Codes) for package: redhat-lsb-languages-4.1-5.fc17.armv5tel
--> Processing Dependency: perl(ExtUtils::MakeMaker) for package: redhat-lsb-languages-4.1-5.fc17.armv5tel
--> Processing Dependency: perl(Class::ISA) for package: redhat-lsb-languages-4.1-5.fc17.armv5tel
--> Processing Dependency: perl(CPAN) for package: redhat-lsb-languages-4.1-5.fc17.armv5tel
--> Processing Dependency: perl(CGI) for package: redhat-lsb-languages-4.1-5.fc17.armv5tel
---> Package redhat-lsb-printing.armv5tel 0:4.1-5.fc17 will be installed
--> Processing Dependency: /usr/bin/gs for package: redhat-lsb-printing-4.1-5.fc17.armv5tel
--> Processing Dependency: /usr/bin/foomatic-rip for package: redhat-lsb-printing-4.1-5.fc17.armv5tel
--> Running transaction check
---> Package cups.armv5tel 1:1.5.4-2.fc17 will be installed
--> Processing Dependency: poppler-utils for package: 1:cups-1.5.4-2.fc17.armv5tel
--> Processing Dependency: ghostscript-cups for package: 1:cups-1.5.4-2.fc17.armv5tel
---> Package foomatic-filters.armv5tel 0:4.0.8-8.fc17 will be installed
---> Package gettext.armv5tel 0:0.18.1.1-14.fc17 will be installed
--> Processing Dependency: libunistring.so.0 for package: gettext-0.18.1.1-14.fc17.armv5tel
--> Processing Dependency: libgettextsrc-0.18.1.so for package: gettext-0.18.1.1-14.fc17.armv5tel
--> Processing Dependency: libgettextlib-0.18.1.so for package: gettext-0.18.1.1-14.fc17.armv5tel
---> Package ghostscript.armv5tel 0:9.05-4.fc17 will be installed
--> Processing Dependency: urw-fonts >= 1.1 for package: ghostscript-9.05-4.fc17.armv5tel
--> Processing Dependency: ghostscript-fonts for package: ghostscript-9.05-4.fc17.armv5tel
---> Package libpng-compat.armv5tel 2:1.5.10-1.fc17 will be installed
---> Package patch.armv5tel 0:2.6.1-12.fc17 will be installed
---> Package pax.armv5tel 0:3.4-13.fc17 will be installed
---> Package perl-CGI.noarch 0:3.52-218.fc17 will be installed
--> Processing Dependency: perl(FCGI) for package: perl-CGI-3.52-218.fc17.noarch
--> Processing Dependency: perl(:MODULE_COMPAT_5.14.3) for package: perl-CGI-3.52-218.fc17.noarch
---> Package perl-CPAN.noarch 0:1.9600.01-215.fc17 will be installed
--> Processing Dependency: perl(HTTP::Tiny) >= 0.005 for package: perl-CPAN-1.9600.01-215.fc17.noarch
--> Processing Dependency: perl(Digest::SHA) for package: perl-CPAN-1.9600.01-215.fc17.noarch
---> Package perl-Class-ISA.noarch 0:0.36-1007.fc17 will be installed
---> Package perl-ExtUtils-MakeMaker.noarch 0:6.62-2.fc17 will be installed
--> Processing Dependency: perl(ExtUtils::Packlist) for package: perl-ExtUtils-MakeMaker-6.62-2.fc17.noarch
--> Processing Dependency: perl(ExtUtils::Manifest) for package: perl-ExtUtils-MakeMaker-6.62-2.fc17.noarch
--> Processing Dependency: perl(ExtUtils::Installed) for package: perl-ExtUtils-MakeMaker-6.62-2.fc17.noarch
--> Processing Dependency: perl(ExtUtils::Install) for package: perl-ExtUtils-MakeMaker-6.62-2.fc17.noarch
---> Package perl-Locale-Codes.noarch 0:3.24-1.fc17 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.14.3) for package: perl-Locale-Codes-3.24-1.fc17.noarch
---> Package perl-Pod-Plainer.noarch 0:1.03-1.fc17 will be installed
---> Package perl-Test-Harness.noarch 0:3.23-215.fc17 will be installed
---> Package perl-Test-Simple.noarch 0:0.98-215.fc17 will be installed
---> Package qt3.armv5tel 0:3.3.8b-41.fc17 will be installed
---> Package redhat-lsb-submod-multimedia.armv5tel 0:4.1-5.fc17 will be installed
---> Package redhat-lsb-submod-security.armv5tel 0:4.1-5.fc17 will be installed
--> Running transaction check
---> Package gettext-libs.armv5tel 0:0.18.1.1-14.fc17 will be installed
---> Package ghostscript-cups.armv5tel 0:9.05-4.fc17 will be installed
---> Package ghostscript-fonts.noarch 0:5.50-28.fc17 will be installed
---> Package libunistring.armv5tel 0:0.9.3-5.fc17 will be installed
---> Package perl-CGI.noarch 0:3.52-218.fc17 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.14.3) for package: perl-CGI-3.52-218.fc17.noarch
---> Package perl-Digest-SHA.armv5tel 1:5.61-215.fc17 will be installed
---> Package perl-ExtUtils-Install.noarch 0:1.56-215.fc17 will be installed
--> Processing Dependency: perl-devel for package: perl-ExtUtils-Install-1.56-215.fc17.noarch
---> Package perl-ExtUtils-Manifest.noarch 0:1.60-1.fc17 will be installed
---> Package perl-FCGI.armv5tel 1:0.74-2.fc17 will be installed
---> Package perl-HTTP-Tiny.noarch 0:0.012-215.fc17 will be installed
---> Package perl-Locale-Codes.noarch 0:3.24-1.fc17 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.14.3) for package: perl-Locale-Codes-3.24-1.fc17.noarch
---> Package poppler-utils.armv5tel 0:0.18.4-3.fc17 will be installed
---> Package urw-fonts.noarch 0:2.4-11.fc17 will be installed
--> Running transaction check
---> Package perl-CGI.noarch 0:3.52-218.fc17 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.14.3) for package: perl-CGI-3.52-218.fc17.noarch
---> Package perl-Locale-Codes.noarch 0:3.24-1.fc17 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.14.3) for package: perl-Locale-Codes-3.24-1.fc17.noarch
---> Package perl-devel.armv5tel 4:5.14.2-215.fc17 will be installed
--> Processing Dependency: systemtap-sdt-devel for package: 4:perl-devel-5.14.2-215.fc17.armv5tel
--> Processing Dependency: perl(ExtUtils::ParseXS) for package: 4:perl-devel-5.14.2-215.fc17.armv5tel
--> Running transaction check
---> Package perl-CGI.noarch 0:3.52-218.fc17 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.14.3) for package: perl-CGI-3.52-218.fc17.noarch
---> Package perl-ExtUtils-ParseXS.noarch 1:2.2210-215.fc17 will be installed
---> Package perl-Locale-Codes.noarch 0:3.24-1.fc17 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.14.3) for package: perl-Locale-Codes-3.24-1.fc17.noarch
---> Package systemtap-sdt-devel.armv5tel 0:2.0-1.fc17 will be installed
--> Finished Dependency Resolution
Error: Package: perl-CGI-3.52-218.fc17.noarch (updates)
          Requires: perl(:MODULE_COMPAT_5.14.3)
Error: Package: perl-Locale-Codes-3.24-1.fc17.noarch (updates)
          Requires: perl(:MODULE_COMPAT_5.14.3)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


wmakowski 01-08-2013 10:28 PM

It looks like perl(:MODULE_COMPAT_5.14.3) is provided by perl-5.14.3-218.fc17.i686. Do you have it installed? No idea why yum doesn't pick it up.

Code:

$ rpm --provides -q perl
perl(:MODULE_COMPAT_5.14.0) 
perl(:MODULE_COMPAT_5.14.1) 
perl(:MODULE_COMPAT_5.14.2) 
perl(:MODULE_COMPAT_5.14.3) 
perl(:WITH_ITHREADS) 
perl(:WITH_LARGEFILES)

If it isn't installed, I would try installing perl and then go for lsb.

frieza 01-09-2013 12:30 AM

Code:

[hopper@Ika Musume ~]$ rpm -q perl
perl-5.14.2-215.fc17.armv5tel


wmakowski 01-09-2013 07:19 AM

Is there a perl-5.14.3 for your architecture? Here is what I have...

[fred@bedrock ~]$ rpm -q perl
perl-5.14.3-218.fc17.i686

I found it with:
Code:

$ yum whatprovides 'perl(:MODULE_COMPAT_5.14.3)'
Loaded plugins: langpacks, presto, refresh-packagekit
rpmfusion-free-updates                                  | 3.3 kB    00:00   
rpmfusion-nonfree-updates                                | 3.3 kB    00:00   
updates/17/i386/metalink                                |  11 kB    00:00   
updates                                                  | 4.7 kB    00:00   
4:perl-5.14.3-218.fc17.i686 : Practical Extraction and Report Language
Repo        : updates
Matched from:
Provides    : perl(:MODULE_COMPAT_5.14.3)
...

I would do a bug report if it isn't there. You would think that would have shown up in QA when they built the lsb package. Another option would be to try and build your own from the source on koji. It might just work!

frieza 01-09-2013 10:08 AM

Code:

[hopper@Ika Musume ~]$ yum whatprovides 'perl(:MODULE_COMPAT_5.14.3)'
Loaded plugins: langpacks, presto, refresh-packagekit
rpmfusion-nonfree                                                        16/16
fedora/filelists_db                                      |  17 MB    04:48   
rasp-pi/filelists_db                                    |  48 kB    00:03   
rasp-pi-debuginfo/filelists_db                          | 2.2 kB    00:00   
rpmfusion-free/filelists_db                              | 184 kB    00:02   
rpmfusion-free-updates/filelists_db                      |  42 kB    00:00   
rpmfusion-nonfree/filelists                              |  27 kB    00:00   
rpmfusion-nonfree-updates/filelists                      |  202 B    00:00   
http://mirror.chpc.utah.edu/pub/fedora-secondary/updates/17/arm/repodata/373e54062963a3a0bc0a5dd05166a864c62894e93a308e7032a86b2bb162e8ba-filelists.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found : http://mirror.chpc.utah.edu/pub/fedora-secondary/updates/17/arm/repodata/373e54062963a3a0bc0a5dd05166a864c62894e93a308e7032a86b2bb162e8ba-filelists.sqlite.bz2
Trying other mirror.
updates/filelists_db                                    | 9.9 MB    02:20   
No Matches found



All times are GMT -5. The time now is 05:14 AM.