LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Error on deleting - Couldn't access trash (http://www.linuxquestions.org/questions/fedora-35/error-on-deleting-couldnt-access-trash-4175455028/)

metcommradio 03-21-2013 01:22 PM

Error on deleting - Couldn't access trash
 
This problem has been on my system for some time now and I hoped it would perhaps be solved automatically after upgrading from F17 to F18 which all went very smoothly.

I can delete files using the more aggresive approach (Ctrl Del) but can't send anything to trash from Dolphin or other KDE applications such as Viewer and Gwenview. The error dialogue says "Error on deleting - Couldn't access trash"

Has anyone had this issue before and found the cause? My system runs very stable and the upgrade to F18 has been very nice, no other issues noted.

It might be some kind of permissions issue because it works ok in admin mode (as root).

OS: Linux 3.8.3-203.fc18.i686.PAE i686
System: Fedora release 18 (Spherical Cow)
KDE: 4.10.1

netnix99 03-21-2013 02:54 PM

Your trash file should be located at /home/username/.Trash - (it's a hidden file), and it's permissions shold be drwx------

HTH

metcommradio 03-22-2013 08:20 AM

Error on deleting - Couldn't access trash
 
Thanks for the assistance, I actually found the Trash at /home/myname/.local/share/Trash and the permissions looked ok. But I checked the "Only owner can rename and delete folder content" and now I can delete to Trash from Dolphin. It seems to not be universal though so I'm thinking that maybe some installed applications have different permissions. For eg. Gwenview works now but not Gthumbs, etc ....

I'll investigate further over the weekend and report back later.


All times are GMT -5. The time now is 08:46 AM.