LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
LinkBack Search this Thread
Old 12-09-2005, 10:45 PM   #1
travellers
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Rep: Reputation: 0
error in configuration of Yum repository. Please help


I have installed FC4 successfully. Then I follow Stanton Finley's installation guide to configure Yum repository. I typed wget ftp to download and install rpmforge-release-0.2-2.2.fc4.rf.i386.rpm. Then I follow the guide to rm *.rpm, then typed: gedit /etc/yum.repos.d/freshrpms.repo, system reponded with error message like this: Xlib: connection to ":0.0" refused by server. Xlib: No protocol specified. (gedit: 3048): Gtk WARNING **: cannot open display:, then I wnt to /etc/yum.repos.d/ directory, I didn't see freshrpms.repo, dries.repo and newrpms.repo. Please tell me waht is going on with this? I followed the installation guide step by step. Is there anything wrong here? Anyone has configured this part successfully, please give me some advice. Thanks for your help. Happy Christmas.
 
Old 12-11-2005, 03:22 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,345

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
well this clearly has nothing to do with yum at all, you simply can't open an X text editor... personally i'd recommend you learnt a de`ent editor like vi. but assuming that 1) you ARE running X, 2) you are running it as a normal user and 3) you are trying to open the file as root, run "xhost +localhost" as your non-root user and try again.
 
Old 12-11-2005, 10:12 PM   #3
travellers
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Original Poster
Rep: Reputation: 0
acid_kewpie:

Thanks for your input. Yes, I have figured out that I didn't login as root correctly. I run gedit as normal user to cause this errors. now I am fine with configuration. Merry Christmas to you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum repository problems kpachopoulos Fedora 2 07-28-2005 07:03 PM
Error: Bad repository file ///etc/yum.repos.d/dag.repo. Skipping dr_zayus69 Linux - Software 1 07-12-2005 11:56 PM
Yum repository quesiton satimis Fedora 25 04-29-2005 11:19 PM
Creating A Yum Repository SepitvaOra Linux - Newbie 1 04-04-2005 06:54 AM
yum repository for redhat 9 csfalcon Linux - Software 1 10-20-2004 11:31 AM


All times are GMT -5. The time now is 09:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration