View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 02-19-2007, 09:40 AM   #1
LQ Newbie
Registered: Feb 2007
Posts: 5

Rep: Reputation: 0
During boot process FC4 hangs after Hal deamon?

Problem when booting FC 4


I am new to linux but am keen to improve my knowledge of this OS. I have a problem and hope someone can assist me.

I recently installed FC 4. Everything was running smoothly. I installed a particular piece of software and it to seemed to be running ok. To allow additional features of this software to run i added additional lines to my environment variables file. After amending the file I also sourced the file, i did this in different shell types, csh, sh and bash, as i was'nt sure which was the correct way to do it.

I thought this was all hunky dory until i switched on my computer today to find that during the boot process but after the line:

Starting up Hal daemon [ok]

The computer hangs.

The files that i edited lie in


I managed to get into the file structure through GRUB, but i could'nt access etc/profile as it said /profile was not a directory, i find this strange.

I am assuming the problem i have is a result of either editing the files or sourcing the this possible? If i am barking up the wrong tree please let me know.

Any possible lines of attack to solve this problem would be most welcome.

Thank you
Old 02-19-2007, 10:59 AM   #2
LQ Newbie
Registered: Feb 2007
Posts: 5

Original Poster
Rep: Reputation: 0
My mistake


In response to my own earlier post. I should have known profile is a file and not a directory. I am going to attempt to edit this file using vi. Fingers crossed, i hope that will solve the problem.

Any responses from other users would be greatly appreciated.

Old 02-19-2007, 11:33 AM   #3
LQ Newbie
Registered: Feb 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Problem solved

Yeah, that worked.

By editing the kernel boot tag, appending "single" to the boot line i was able to get into my file structure.

There i edited the file with the problematic line using vi

After editing the file i sourced it in bash, I dont know if this was necessary.

I guess i should be more careful about how i edit files but i feel a little bit further up the learning curve now.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
My sendmail process hangs on boot up guarriman Fedora 1 11-13-2006 11:07 AM
Dual boot w/FC4/WinXP - hal.dll is corrupt or missing cliffhanger9 General 6 05-24-2006 01:10 PM
LILO hangs during the boot process ntoughe Linux - General 3 11-18-2005 11:44 AM
HAL deamon johnnydangerous Fedora 2 02-08-2005 03:41 AM

All times are GMT -5. The time now is 12:49 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration