LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 08-04-2005, 10:02 PM   #1
davidhk
Member
 
Registered: Jun 2005
Posts: 38

Rep: Reputation: 15
Wink dhcppc0?


I applied a new fixed ip from isp, network status as below

internet--> (fixed ip: 202.x.x.x)isp's modem (it sets a dm zome, 192.168.1.33)-->my machine


-------
After I installed FC3,
-------
Before go to login screen, It prompts:-

Could not look up internet address for dhcppc0. This will prevent GNOME for opeating correctly. It may be possible to correct the problem by adding dhcpp0 to
the file /etc/hosts.

option : login anway OR try again.
----------
I selected " login anyway"
======
Q:
but it never happened to by previou isp. is it related to diff connect by diff isp.
How to overcome?
 
Old 08-04-2005, 11:00 PM   #2
shams
Member
 
Registered: Jan 2004
Posts: 396

Rep: Reputation: 30
add your host to the /etc/hosts
 
Old 08-05-2005, 01:21 AM   #3
davidhk
Member
 
Registered: Jun 2005
Posts: 38

Original Poster
Rep: Reputation: 15
vi /etc/hosts

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
192.168.1.33 myname

-------------
after I edited above file, reboot, still prompt.
 
Old 08-05-2005, 01:59 AM   #4
n0xvb
Member
 
Registered: Sep 2004
Location: 127.0.0.1
Distribution: Slackware 13; openSUSE 11.2
Posts: 255

Rep: Reputation: 32
Actually I would remove the entry for myname and add one for dhcpp0 (or dhcppc0, you've got it both ways):
Code:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
202.x.x.x dhcpc0
You may also need to check your connection settings to set up the default route as well.
 
Old 08-06-2005, 04:48 AM   #5
davidhk
Member
 
Registered: Jun 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by n0xvb
Actually I would remove the entry for myname and add one for dhcpp0 (or dhcppc0, you've got it both ways):
Code:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
202.x.x.x dhcpc0
You may also need to check your connection settings to set up the default route as well.

1) it works and do not prompt any more.
2) how to set up the default route which you mentioned? Tkx.
 
Old 08-06-2005, 05:27 AM   #6
n0xvb
Member
 
Registered: Sep 2004
Location: 127.0.0.1
Distribution: Slackware 13; openSUSE 11.2
Posts: 255

Rep: Reputation: 32
Quote:
Originally posted by davidhk
1) it works and do not prompt any more.
2) how to set up the default route which you mentioned? Tkx.
1) Excellent!

2) What is the name of your interface? (Using NIC, typically is eth0, using dialup usually is ppp0)?
 
Old 08-06-2005, 06:30 AM   #7
davidhk
Member
 
Registered: Jun 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by n0xvb
1) Excellent!

2) What is the name of your interface? (Using NIC, typically is eth0, using dialup usually is ppp0)?
1. Although I am using eth0,please describe both . As I believe some other people are using diff interface, they also want to know the detail.
 
Old 08-06-2005, 10:20 PM   #8
n0xvb
Member
 
Registered: Sep 2004
Location: 127.0.0.1
Distribution: Slackware 13; openSUSE 11.2
Posts: 255

Rep: Reputation: 32
Quote:
Originally posted by davidhk
1. Although I am using eth0,please describe both . As I believe some other people are using diff interface, they also want to know the detail.
OK I can do that, unfortunately, I didn't ask you what your ifconfig returns (specifically what address is assigned to your eth0 interface), this is the number you'll need to use for the default gateway.

First I would check to see if your system already has a default route defined by running the route command with no parameters. If you see an entry marked as the default gateway and it does not match the address assigned to your eth0 interface, then delete it (I'll use 192.168.2.3 in this example):
Code:
route del default gw 192.168.2.3
So in your case, if your eth0 interface was assigned the IP address: 192.168.1.2 then you would set your default gateway with the following command:
Code:
#route add default gw 192.168.1.2
You will need to substitute the actual IP address here, and if it was already set correctly, then you would not need to add it again.

The eth0 interface is a standard ethernet network card in your computer, and the cable connects to your hub/switch/router. The ppp0 interface is used by dialup users (sorry I also didn't ask if you were using a dialup connection -- my bad!). To have the ppp0 interface set itself as a default gateway is different. This would be done in the /etc/ppp/options file by uncommenting the "defaultroute" option.

And to be at least somewhat complete, the routing table (what you see when you run the route command) tells your system which network interface to use when sending network traffic. Each line defines a specific IP address or range or addresses. If your system does not know which interface to use (for example I want to look at www.google.com but I don't have 64.233.167.99 in my routing table) then it will send the traffic over the default route.

Hope that helps!
 
Old 08-07-2005, 11:53 PM   #9
davidhk
Member
 
Registered: Jun 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by n0xvb
OK I can do that, unfortunately, I didn't ask you what your ifconfig returns (specifically what address is assigned to your eth0 interface), this is the number you'll need to use for the default gateway.

First I would check to see if your system already has a default route defined by running the route command with no parameters. If you see an entry marked as the default gateway and it does not match the address assigned to your eth0 interface, then delete it (I'll use 192.168.2.3 in this example):
Code:
route del default gw 192.168.2.3
So in your case, if your eth0 interface was assigned the IP address: 192.168.1.2 then you would set your default gateway with the following command:
Code:
#route add default gw 192.168.1.2
You will need to substitute the actual IP address here, and if it was already set correctly, then you would not need to add it again.

The eth0 interface is a standard ethernet network card in your computer, and the cable connects to your hub/switch/router. The ppp0 interface is used by dialup users (sorry I also didn't ask if you were using a dialup connection -- my bad!). To have the ppp0 interface set itself as a default gateway is different. This would be done in the /etc/ppp/options file by uncommenting the "defaultroute" option.

And to be at least somewhat complete, the routing table (what you see when you run the route command) tells your system which network interface to use when sending network traffic. Each line defines a specific IP address or range or addresses. If your system does not know which interface to use (for example I want to look at www.google.com but I don't have 64.233.167.99 in my routing table) then it will send the traffic over the default route.

Hope that helps!

[root@dhcppc0 ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:13:20:61:81:1B
inet addr:192.168.1.33 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::213:20ff:fe61:811b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:581 errors:0 dropped:0 overruns:0 frame:0
TX packets:498 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:226277 (220.9 KiB) TX bytes:62004 (60.5 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5753 errors:0 dropped:0 overruns:0 frame:0
TX packets:5753 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7552798 (7.2 MiB) TX bytes:7552798 (7.2 MiB)

[root@dhcppc0 ~]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
>>>I tried to del gw 192.168.1.1 & add gw 192.168.1.31, but It can't go out.

--
>>>I checked /etc/ppp/options, there is only "lock", no you mention "defaultroute"?
[root@dhcppc0 ~]# cd /etc/ppp/
[root@dhcppc0 ppp]# ls
chap-secrets ioptions ip-up ipv6-up peers
firewall-masq ip-down ip-up.ipv6to4 options pppoe-server-options
firewall-standalone ip-down.ipv6to4 ipv6-down pap-secrets
[root@dhcppc0 ppp]# cat options
lock
--
Thanks
 
Old 08-11-2005, 11:01 PM   #10
n0xvb
Member
 
Registered: Sep 2004
Location: 127.0.0.1
Distribution: Slackware 13; openSUSE 11.2
Posts: 255

Rep: Reputation: 32
You should not have to change /etc/ppp/options, that is only for dialup using ppp.

Try to issue this command:
Code:
route del default gw 192.168.1.1
and then
Code:
route add default gw 192.168.1.33
This will remove the bogus default gateway and add the correct gateway.
 
Old 08-22-2005, 09:00 AM   #11
sparkie the superdog
LQ Newbie
 
Registered: Aug 2005
Posts: 1

Rep: Reputation: 0
Thanks to the above I could fix the problem too. It works. Thanks
 
Old 08-24-2005, 12:49 AM   #12
n0xvb
Member
 
Registered: Sep 2004
Location: 127.0.0.1
Distribution: Slackware 13; openSUSE 11.2
Posts: 255

Rep: Reputation: 32
Quote:
Originally posted by sparkie the superdog
Thanks to the above I could fix the problem too. It works. Thanks
Cool! Thanks for that!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 12:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration