LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-14-2009, 03:13 AM   #1
ps_sabu
Member
 
Registered: Nov 2006
Location: Kerala, South India
Distribution: Ubuntu 12.10, Ultimate Edition 3.5, OZ Unity 3.0 Black Opal
Posts: 117

Rep: Reputation: 15
Dependancy problem with yum in Fedora 8


Hi,
I am sorry that this post is a bit lengthy. But I have to convey the exact problem.


I have enabled the following repos in Fedora 8

Quote:
[root@localhost sabu]# yum repolist
repo id repo name status
InstallMedia Fedora 8 enabled
fedora Fedora 8 - x86_64 enabled
freshrpms Fedora Core 8 - x86_64 - Freshrpms enabled
livna Livna for Fedora Core 8 - x86_64 - Base enabled
rpmfusion-free RPM Fusion for Fedora 8 - Free enabled
rpmfusion-free-updat RPM Fusion for Fedora 8 - Free - Updates enabled
rpmfusion-nonfree RPM Fusion for Fedora 8 - Nonfree enabled
rpmfusion-nonfree-up RPM Fusion for Fedora 8 - Nonfree - Upda enabled
updates Fedora 8 - x86_64 - Updates enabled
But when I run


Code:
root@localhost sabu]# yum -y install libdvdcss libdvdread libdvdnav libdvdplay mplayer mplayer-gui mplayer-fonts mplayer-libs gstreamer-plugins-bad gstreamer-plugins-ugly
Setting up Install Process
Parsing package install arguments
Package libdvdread - 0.9.7-3.fc8.i386 is already installed.
Package libdvdread - 0.9.7-3.fc8.x86_64 is already installed.
Requested dep: libdvdnav is provided by installed package
Package libdvdplay - 1.0.1-5.fc7.x86_64 is already installed.
No package mplayer-libs available.
Resolving Dependencies
--> Running transaction check
---> Package gstreamer-plugins-ugly.i386 0:0.10.6-6.fc8 set to be updated
--> Processing Dependency: libmpeg2.so.0 for package: gstreamer-plugins-ugly
--> Processing Dependency: libsidplay.so.1 for package: gstreamer-plugins-ugly
--> Processing Dependency: liba52.so.0 for package: gstreamer-plugins-ugly
--> Processing Dependency: libmad.so.0 for package: gstreamer-plugins-ugly
--> Processing Dependency: libid3tag.so.0 for package: gstreamer-plugins-ugly
--> Processing Dependency: libmp3lame.so.0 for package: gstreamer-plugins-ugly
---> Package mplayer-gui.x86_64 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libdvdnavmini.so.4()(64bit) for package: mplayer-gui
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: mplayer-gui
--> Processing Dependency: libdca.so.0()(64bit) for package: mplayer-gui
--> Processing Dependency: libcaca.so.0()(64bit) for package: mplayer-gui
--> Processing Dependency: libxvidcore.so.4()(64bit) for package: mplayer-gui
--> Processing Dependency: libBasicUsageEnvironment.so.0()(64bit) for package: mplayer-gui
--> Processing Dependency: libfaad.so.0()(64bit) for package: mplayer-gui
--> Processing Dependency: libUsageEnvironment.so.0()(64bit) for package: mplayer-gui
--> Processing Dependency: libaa.so.1()(64bit) for package: mplayer-gui
--> Processing Dependency: libliveMedia.so.0()(64bit) for package: mplayer-gui
--> Processing Dependency: libcucul.so.0()(64bit) for package: mplayer-gui
--> Processing Dependency: libgroupsock.so.0()(64bit) for package: mplayer-gui
--> Processing Dependency: libenca.so.0()(64bit) for package: mplayer-gui
---> Package gstreamer-plugins-ugly.x86_64 0:0.10.8-1.fc8 set to be updated
--> Processing Dependency: liba52.so.0()(64bit) for package: gstreamer-plugins-ugly
--> Processing Dependency: libmp3lame.so.0()(64bit) for package: gstreamer-plugins-ugly
--> Processing Dependency: libmad.so.0()(64bit) for package: gstreamer-plugins-ugly
--> Processing Dependency: libamrnb.so.0()(64bit) for package: gstreamer-plugins-ugly
--> Processing Dependency: libid3tag.so.0()(64bit) for package: gstreamer-plugins-ugly
--> Processing Dependency: libmpeg2.so.0()(64bit) for package: gstreamer-plugins-ugly
---> Package gstreamer-plugins-bad.x86_64 0:0.10.5-16.fc8 set to be updated
--> Processing Dependency: libWildMidi.so.0()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libtimidity-0.1.so.0()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libfusion-1.0.so.0()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libcdaudio.so.1()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libfaac.so.0()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libmpeg2encpp-1.9.so.0()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libmjpegutils-1.9.so.0()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libmms.so.0()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libx264.so.60()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libdirectfb-1.0.so.0()(64bit) for package: gstreamer-plugins-bad
--> Processing Dependency: libdirect-1.0.so.0()(64bit) for package: gstreamer-plugins-bad
---> Package gstreamer-plugins-bad.i386 0:0.10.5-16.fc8 set to be updated
--> Processing Dependency: libfusion-1.0.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libcdaudio.so.1 for package: gstreamer-plugins-bad
--> Processing Dependency: libmms.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libtimidity-0.1.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libmjpegutils-1.9.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libfaad.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libxvidcore.so.4 for package: gstreamer-plugins-bad
--> Processing Dependency: libfaac.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libx264.so.60 for package: gstreamer-plugins-bad
--> Processing Dependency: libdirect-1.0.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for package: gstreamer-plugins-bad
--> Processing Dependency: libsndfile.so.1 for package: gstreamer-plugins-bad
--> Processing Dependency: libdca.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libWildMidi.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libmpeg2encpp-1.9.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libdirectfb-1.0.so.0 for package: gstreamer-plugins-bad
---> Package mplayer.i386 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libBasicUsageEnvironment.so.0 for package: mplayer
--> Processing Dependency: libcucul.so.0 for package: mplayer
--> Processing Dependency: libenca.so.0 for package: mplayer
--> Processing Dependency: libpulse.so.0(PULSE_0) for package: mplayer
--> Processing Dependency: libaa.so.1 for package: mplayer
--> Processing Dependency: libliveMedia.so.0 for package: mplayer
--> Processing Dependency: libUsageEnvironment.so.0 for package: mplayer
--> Processing Dependency: libdv.so.4 for package: mplayer
--> Processing Dependency: liblzo2.so.2 for package: mplayer
--> Processing Dependency: libgroupsock.so.0 for package: mplayer
--> Processing Dependency: libcaca.so.0 for package: mplayer
--> Processing Dependency: liblirc_client.so.0 for package: mplayer
---> Package libdvdcss.x86_64 0:1.2.9-4.lvn6 set to be updated
---> Package mplayer.x86_64 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libdvdnavmini.so.4()(64bit) for package: mplayer
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: mplayer
--> Running transaction check
---> Package live555.x86_64 0:0-0.20.2008.07.25.fc8 set to be updated
---> Package lame.x86_64 0:3.97-1.fc7 set to be updated
---> Package mplayer.x86_64 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libdvdnavmini.so.4()(64bit) for package: mplayer
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: mplayer
---> Package lame-libs.i386 0:3.98.2-2.fc8 set to be updated
---> Package a52dec.i386 0:0.7.4-13.fc8 set to be updated
---> Package amrnb.x86_64 0:0.0.1-2.fc7 set to be updated
---> Package mplayer-gui.x86_64 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libdvdnavmini.so.4()(64bit) for package: mplayer-gui
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: mplayer-gui
---> Package libdca.x86_64 0:0.0.5-3.fc8 set to be updated
---> Package mjpegtools.x86_64 0:1.9.0-0.5.rc2.fc8 set to be updated
--> Processing Dependency: libquicktime.so.0()(64bit) for package: mjpegtools
--> Processing Dependency: libSDL_gfx.so.0()(64bit) for package: mjpegtools
---> Package libmad.x86_64 0:0.15.1b-8.fc8 set to be updated
---> Package libmad.i386 0:0.15.1b-8.fc8 set to be updated
---> Package faad2.x86_64 0:2.5-2.fc7 set to be updated
---> Package libmms.x86_64 0:0.4-3.fc8 set to be updated
---> Package live555.i386 0:0-0.20.2008.07.25.fc8 set to be updated
---> Package directfb.x86_64 0:1.0.0-3.fc8 set to be updated
---> Package aalib.x86_64 0:1.4.0-0.13.rc5.fc8 set to be updated
---> Package enca.i386 0:1.9-3.fc6 set to be updated
---> Package xvidcore.i386 0:1.1.3-4.fc8 set to be updated
---> Package x264-libs.x86_64 0:0.0.0-0.15.20080613.fc8 set to be updated
---> Package xvidcore.x86_64 0:1.1.3-4.fc8 set to be updated
---> Package libmms.i386 0:0.4-3.fc8 set to be updated
---> Package libsidplay.i386 0:1.36.57-14 set to be updated
---> Package faac.x86_64 0:1.25-7.fc8 set to be updated
--> Processing Dependency: libmp4v2.so.0()(64bit) for package: faac
---> Package aalib.i386 0:1.4.0-0.13.rc5.fc8 set to be updated
---> Package enca.x86_64 0:1.9-3.fc6 set to be updated
---> Package libtimidity.i386 0:0.1.0-4.fc8 set to be updated
--> Processing Dependency: timidity++-patches for package: libtimidity
---> Package wildmidi-libs.i386 0:0.2.2-3.fc8 set to be updated
---> Package libcdaudio.x86_64 0:0.99.12p2-8.fc7 set to be updated
---> Package libid3tag.i386 0:0.15.1b-4.fc8 set to be updated
---> Package mjpegtools-libs.i386 0:1.9.0-0.6.rc3.fc8 set to be updated
--> Processing Dependency: libquicktime.so.0 for package: mjpegtools-libs
---> Package libtimidity.x86_64 0:0.1.0-4.fc8 set to be updated
---> Package faad2-libs.i386 1:2.6.1-6.fc8 set to be updated
---> Package libcaca.i386 0:0.99-0.3.beta11.fc8 set to be updated
--> Processing Dependency: libglut.so.3 for package: libcaca
---> Package libdca.i386 0:0.0.5-3.fc8 set to be updated
---> Package x264-libs.i386 0:0.0.0-0.15.20080613.fc8 set to be updated
---> Package a52dec.x86_64 0:0.7.4-13.fc8 set to be updated
---> Package libid3tag.x86_64 0:0.15.1b-4.fc8 set to be updated
---> Package libsndfile.i386 0:1.0.17-2.fc8 set to be updated
---> Package libmpeg2.x86_64 0:0.5.1-3.fc8 set to be updated
---> Package directfb.i386 0:1.0.0-3.fc8 set to be updated
---> Package libmpeg2.i386 0:0.5.1-3.fc8 set to be updated
---> Package lzo.i386 0:2.02-3.fc8 set to be updated
---> Package lirc.i386 0:0.8.2-2.fc8 set to be updated
---> Package wildmidi-libs.x86_64 0:0.2.2-3.fc8 set to be updated
---> Package libcdaudio.i386 0:0.99.12p2-8.fc7 set to be updated
---> Package mplayer.i386 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libpulse.so.0(PULSE_0) for package: mplayer
---> Package faac.i386 0:1.25-7.fc8 set to be updated
--> Processing Dependency: libmp4v2.so.0 for package: faac
---> Package libcaca.x86_64 0:0.99-0.3.beta11.fc8 set to be updated
---> Package libdv.i386 0:1.0.0-3.fc8 set to be updated
--> Running transaction check
---> Package mplayer.x86_64 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libdvdnavmini.so.4()(64bit) for package: mplayer
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: mplayer
---> Package libmp4v2.x86_64 0:1.5.0.1-5.fc8 set to be updated
---> Package mplayer-gui.x86_64 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libdvdnavmini.so.4()(64bit) for package: mplayer-gui
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: mplayer-gui
---> Package freeglut.i386 0:2.4.0-11.fc8 set to be updated
---> Package libmp4v2.i386 0:1.5.0.1-5.fc8 set to be updated
---> Package libquicktime.i386 0:1.0.3-3.fc8 set to be updated
--> Processing Dependency: libswscale.so.0 for package: libquicktime
--> Processing Dependency: libavcodec.so.51 for package: libquicktime
---> Package timidity++-patches.x86_64 0:2.13.2-4.fc8 set to be updated
---> Package libquicktime.x86_64 0:1.0.3-3.fc8 set to be updated
--> Processing Dependency: libswscale.so.0()(64bit) for package: libquicktime
--> Processing Dependency: libavcodec.so.51()(64bit) for package: libquicktime
---> Package mplayer.i386 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libpulse.so.0(PULSE_0) for package: mplayer
---> Package SDL_gfx.x86_64 0:2.0.16-4.fc8 set to be updated
--> Running transaction check
---> Package mplayer.x86_64 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libdvdnavmini.so.4()(64bit) for package: mplayer
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: mplayer
---> Package mplayer-gui.x86_64 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libdvdnavmini.so.4()(64bit) for package: mplayer-gui
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: mplayer-gui
---> Package ffmpeg-libs.x86_64 0:0.4.9-0.48.20080908.fc8 set to be updated
--> Processing Dependency: libdc1394.so.22()(64bit) for package: ffmpeg-libs
---> Package mplayer.i386 0:1.0-0.97.20080818svn.fc8.1 set to be updated
--> Processing Dependency: libpulse.so.0(PULSE_0) for package: mplayer
---> Package ffmpeg-libs.i386 0:0.4.9-0.48.20080908.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: libpulse.so.0(PULSE_0) is needed by package mplayer
Error: Missing Dependency: libpulse.so.0(PULSE_0)(64bit) is needed by package mplayer-gui
Error: Missing Dependency: libpulse.so.0(PULSE_0)(64bit) is needed by package mplayer
Error: Missing Dependency: libdvdnavmini.so.4()(64bit) is needed by package mplayer
Error: Missing Dependency: libdc1394.so.22()(64bit) is needed by package ffmpeg-libs
Error: Missing Dependency: libdvdnavmini.so.4()(64bit) is needed by package mplayer-gui


As u see I am unable to install mplayer. What may the problem. Please Help !!!!!! Does this mean that RPMFUSION repo not fully functional yet. Why is YUM not installing all dependancies automatically ???

Last edited by unSpawn; 02-15-2009 at 06:30 AM. Reason: //Misc mod edit: "code" tag easier readable.
 
Old 02-14-2009, 01:16 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,985

Rep: Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611
No, that's a problem after Fedora 8 got unsupported a
month ago. All official Fedora repo's were closed down,
anyway for updates.

May be you can find some missing libraries here

1) The 1,983 packages from the install DVD
http://download.fedora.redhat.com/pu...6/os/Packages/

2) All the other 12,000 "Everything"
http://download.fedora.redhat.com/pu...6/os/Packages/
....
 
Old 02-15-2009, 01:19 AM   #3
ps_sabu
Member
 
Registered: Nov 2006
Location: Kerala, South India
Distribution: Ubuntu 12.10, Ultimate Edition 3.5, OZ Unity 3.0 Black Opal
Posts: 117

Original Poster
Rep: Reputation: 15
Thumbs up

Hi,
Well I thought Fedora 8 would get unsupported only when Fedora 11 is released. This policy of fedora to withdraw support to a release so quickly is really annoying. What do you think ???

Anyway i would check out the links supplied by you. Thanks for the reply...
 
Old 02-15-2009, 03:31 AM   #4
Maligree
Member
 
Registered: Mar 2008
Distribution: Gentoo, CentOS, Fedora, Arch
Posts: 231
Blog Entries: 1

Rep: Reputation: 42
Quote:
The Fedora Project maintains any given release X until one month after the release of X+2.
(from http://fedoraproject.org/wiki/LifeCycle)

Quote:
This policy of fedora to withdraw support to a release so quickly is really annoying. What do you think ???
No, not really. But you can always switch to a rolling release distro and see if that suits you better.
 
Old 02-15-2009, 05:51 AM   #5
ps_sabu
Member
 
Registered: Nov 2006
Location: Kerala, South India
Distribution: Ubuntu 12.10, Ultimate Edition 3.5, OZ Unity 3.0 Black Opal
Posts: 117

Original Poster
Rep: Reputation: 15
This a recent policy change ???? I think earlier versions were supported a bit longer. Happy to be informed. Thanks everybody.

I checked out the links posted earlier by knudfl . Do you think adding the above links to the baseurl entry of fedora repo file in /etc/yum.repos.d would help me downloading the packages through yum ????

Last edited by ps_sabu; 02-15-2009 at 05:52 AM.
 
Old 02-15-2009, 06:33 AM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,492
Blog Entries: 54

Rep: Reputation: 2906Reputation: 2906Reputation: 2906Reputation: 2906Reputation: 2906Reputation: 2906Reputation: 2906Reputation: 2906Reputation: 2906Reputation: 2906Reputation: 2906
Quote:
Originally Posted by ps_sabu View Post
Do you think adding the above links to the baseurl entry of fedora repo file in /etc/yum.repos.d would help me downloading the packages through yum ????
Since you chose to stay with Fedora, what you should do is search the Fedora site (or Wiki) for a doc explaining how to upgrade to F9 to F10. That might solve things a "better" way.
 
Old 02-15-2009, 07:06 AM   #7
Maligree
Member
 
Registered: Mar 2008
Distribution: Gentoo, CentOS, Fedora, Arch
Posts: 231
Blog Entries: 1

Rep: Reputation: 42
Quote:
This a recent policy change ???? I think earlier versions were supported a bit longer. Happy to be informed. Thanks everybody.
Nope, it's been that way since Core 1. See here.
 
Old 02-15-2009, 04:53 PM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,985

Rep: Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611
Quote:
Do you think adding the above links to the baseurl
entry of fedora repo file in /etc/yum.repos.d ....
It might very well be the same as your current repo "fedora".
 
Old 02-24-2009, 01:33 PM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,985

Rep: Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611Reputation: 2611
Almost forgot, I have this in Fedora 8 ( 9 and 10 too )

'rpmfusion.org' repository > > lots of multimedia
http://rpmfusion.org/Configuration

Please see post # 5 in this thread
http://www.linuxquestions.org/questi...-libxm-705086/
.....

Last edited by knudfl; 02-24-2009 at 01:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Fedora 9/yum problem Munsey Linux - General 6 08-22-2008 11:25 PM
yum dependancy issue ghostmac Linux - Software 1 08-12-2006 07:17 AM
FC4: "yum update libcddb" fails -- missing dependancy problem: MattCrypto Fedora 2 07-28-2005 06:47 PM
yum update and SpamAssassin dependancy vara Red Hat 1 05-17-2005 09:55 PM
YUM - - Can't install! Dependancy problem on RH9? irlkersten Red Hat 7 05-07-2005 08:34 PM


All times are GMT -5. The time now is 05:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration