LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 04-21-2005, 06:50 AM   #1
akalliat
LQ Newbie
 
Registered: Apr 2005
Distribution: FC3
Posts: 2

Rep: Reputation: 0
DELL monitor desktop does not occupy the entire screen


Hi!,

I have installed Fedora Core 3 on my DELL dimension 8300 recently and the installation went through fine. I also installed the latest drivers for my nvidia graphics card as well. I updated the BIOS to A07. However i am unable to get my desktop to occupy the entire monitor screen. It shows up as a square in the centre. I have tried to adjust the xorg.conf (both horizontalysync and verticalrefresh rates) file as per a number of threads with no success. Any help on this will be highly appreciated. Thanks a lot in advance.

akalliat
 
Old 04-21-2005, 09:10 AM   #2
akalliat
LQ Newbie
 
Registered: Apr 2005
Distribution: FC3
Posts: 2

Original Poster
Rep: Reputation: 0
attaching my xorg.conf file...

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell E772p"
DisplaySize 300 230
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 04-22-2005, 06:20 AM   #3
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,398

Rep: Reputation: 55
go into Application menu (redhat) /system setting/Display/Hardware tab
and select configure monitor type and then highlight LCD panel 1024x768, ok, and see what that does . Check and see if your adapter card is set to
Nvidia card.
Fedora 3 has it's own Nvidia driver.
I have a Dell Inspiron 8600 and it works perfect on mine with Nvidia a
card.
Did you load the Nividia driver or are you using Fedora's driver, if so you need to
change the setting in Xorg.conf 'Device' to nv instead of nvidia , 'nv' is fedora's driver
and 'nvidia' is Nvidia.com driver

Jim

Last edited by mickeyboa; 04-22-2005 at 06:26 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does my data occupy 3x as much space after being copied? didi156 Linux - General 8 03-29-2005 10:26 PM
Monitor Problems - horizontal lines across entire screen Daddio Linux - Hardware 5 02-10-2005 05:34 PM
q: enlightenment dual monitor: one Desktop for each monitor ? steefje Linux - Software 2 02-07-2005 07:27 AM
Dell Monitor Issue MattFishburn Linux - Laptop and Netbook 4 01-27-2004 07:31 AM
Takeover entire RH8 local desktop Raytje Linux - Software 4 04-11-2003 10:19 AM


All times are GMT -5. The time now is 04:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration