LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-23-2006, 08:14 PM   #1
richlawson
LQ Newbie
 
Registered: Jun 2003
Posts: 22

Rep: Reputation: 15
configure: error: C compiler cannot create executables


Hi,

Getting the following error trying to compile NZBGET:

'checking for C compiler default output... configure: error: C compiler cannot create executables'

I've been through numerous threads posted on here for this but don't seem to be getting anywhere. config.log shows the following error:

gcc: installation problem, cannot exec 'cc1': No such file or directory

cc1 is present it lives here: /usr/libexec/gcc/i386-redhat-linux/4.0.0/cc1

any ideas how to fix this?
 
Old 02-23-2006, 09:03 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
First of all, check where you are trying to compile the program. Do you have execution rights in that partition. A globally writable partition may be mounted with the "noexec" option, which is a good thing.
If you saved the tarball in your home directory then the answer is yes.

Second, check the output of: gcc -v
look for "libexecdir=" and see if it matches.

Last edited by jschiwal; 02-23-2006 at 09:04 PM.
 
Old 02-23-2006, 09:45 PM   #3
richlawson
LQ Newbie
 
Registered: Jun 2003
Posts: 22

Original Poster
Rep: Reputation: 15
thanks for the reply jschiwal.

The tarball was extracted to my home dir so yes I have write permissions. The output of gcc -v is as follows, there is no mention of "libexecdir="? I take it this should be set? How do you set this if it needs to be? I removed and reinstalled gcc via yum but it made no difference.

[rich@mellow-yellow ~]$ gcc -v
Using built-in specs.
Target: i386-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-libgcj-multifile --enable-languages=c,c++,objc,java,f95,ada --enable-java-awt=gtk --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --host=i386-redhat-linux
Thread model: posix
gcc version 4.0.2 20051125 (Red Hat 4.0.2-8)
 
Old 02-24-2006, 05:29 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Have you ben able to successfully compile a package before? Is this the currect gcc version for your distro? The package should have been build with the --libexedir= value already, unless your value would be the default and so building gcc with this "./configure" option would be redundant. Check the location of the "cc1" program using the rpm from your install disk. rpm -q --filesbypkg <full/path/name/to/the/gcc/rpm/use/auto/completion/gcc-<version>.rpm> | grep cc1 or examine the package in kpackage.
<edit>
I'm sorry, on my system, this file is provided by the cpp package.
<edit/>

Try looking at the output of "cpp -v" also.

Last edited by jschiwal; 02-25-2006 at 12:22 AM.
 
Old 03-07-2006, 04:15 PM   #5
dicou
Member
 
Registered: Apr 2004
Location: Paris
Posts: 44

Rep: Reputation: 15
hey,
i had the same problem,
i did that :

apt-get install build-essential

And it works,
no more problems ;-)
 
Old 03-19-2006, 10:40 AM   #6
NewToasted
LQ Newbie
 
Registered: Mar 2006
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by dicou
hey,
i had the same problem,
i did that :

apt-get install build-essential

And it works,
no more problems ;-)

I registered here just to say - Thank you a lot! I was starting to rip my hair out when trying to install Apache because of this error, but you tip solved it all!
 
Old 03-19-2006, 06:01 PM   #7
dicou
Member
 
Registered: Apr 2004
Location: Paris
Posts: 44

Rep: Reputation: 15
No problem man ;-)
 
Old 02-22-2012, 08:04 AM   #8
yashdesai7
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Rep: Reputation: Disabled
Question Same Problem

Hello every one..
I am trying to configure libetpan but I am getting the same problem.. configure error: C compiler cannot create executables.. pls help me..
I m using Fedora 16 .. gcc an g++ both installed in /usr/local/ccache..
it is not solved by doing apt-get install build=essential.. Showing no such commands apt-get

please help me..
Thanks in advance..

Last edited by yashdesai7; 02-22-2012 at 08:06 AM.
 
Old 02-22-2012, 08:18 AM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,119

Rep: Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639
Post #8 , @ yashdesai7 : Welcome to LQ.

There is no "apt" anything in Fedora. The Fedora tool is 'yum'.
Please read 'man yum'.

To install a compiler and the dependencies, that make gcc usable,
please do 1) su ; 2) yum install gcc-c++

... And installing libetpan : yum install libetpan

.

Last edited by knudfl; 02-22-2012 at 08:29 AM.
 
Old 02-22-2012, 10:10 AM   #10
makyo
Member
 
Registered: Aug 2006
Location: Saint Paul, MN, USA
Distribution: {Free,Open}BSD, CentOS, Debian, Fedora, Solaris, SuSE
Posts: 719

Rep: Reputation: 72
Hi.

It may be useful in Fedora to look over the contents of a group:
Code:
yum groupinfo "Development Tools"
in case you need additional tools, and perhaps man yum

Best wishes ... cheers, makyo
 
Old 02-22-2012, 10:25 AM   #11
yashdesai7
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Rep: Reputation: Disabled
Question

I came to know about apt after I posted.. do I need to install libetpan as a Root.. ??
I need to install it as a Local user..
I am able to configure libetpan but I am unable to Install it.. Is there any problem with dependencies??
 
Old 02-22-2012, 12:44 PM   #12
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,119

Rep: Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639Reputation: 2639
#11.

OK, you can just download a Fedora 16 package for your architecture,
32bits ...
http://archives.fedoraproject.org/pu....fc16.i686.rpm
> libetpan-1.1-1.fc16.i686.rpm

Or 64bits ...
http://archives.fedoraproject.org/pu...c16.x86_64.rpm
> libetpan-1.1-1.fc16.x86_64.rpm

Unpack with : rpm2cpio <package> | cpio -idmv

Copy the library "libetpan.so.16.0.0" to /home/<name>/lib/
.. and : ln -s libetpan.so.16.0.0 libetpan.so.16


P.S. :
You will not be able to build the library yourself without a working compiler.

PPS : This command will reply with your architecture : uname -m

.
 
Old 02-22-2012, 11:21 PM   #13
yashdesai7
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Rep: Reputation: Disabled
Question

it t

Last edited by yashdesai7; 02-22-2012 at 11:36 PM.
 
Old 02-22-2012, 11:35 PM   #14
yashdesai7
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Rep: Reputation: Disabled
Question

knudfl,

now I even not able to configure libetpan.. It gave me same configure error..
I have configured & Installed openssl and CyrusSASL which are dependencies of libetpan...
please guide me..
 
Old 02-22-2012, 11:45 PM   #15
John VV
Guru
 
Registered: Aug 2005
Posts: 13,231

Rep: Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774
you might want to start a new thread
seeing as this is NOT the "same problem" from 6 YEARS AGO
the last post was in 2006

for libetpan on fedora there is NO need to build anything
run
Code:
su -
yum search libetpan

/* then from that list install*/

yum install libetpan
yum will take care of things like ssl
but seeing as it looks like you replaced what was already installed ,ssl is installed by default.
things might not work right
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure: error: C++ compiler cannot create executables dicou Linux - Newbie 15 12-22-2012 02:00 PM
configure: error: C compiler cannot create executables watashiwaotaku7 Linux - General 7 10-22-2009 10:40 AM
configure: error: C compiler cannot create executables The00Dustin Linux - Software 2 01-11-2006 03:33 PM
configure error - C compiler cannot create executables MrLobster Linux - Software 1 12-24-2005 01:13 AM
configure: error: C compiler cannot create executables strimp099 Linux - Software 2 07-11-2005 08:23 PM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration