LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-27-2008, 02:38 PM   #1
da_marius
Member
 
Registered: Dec 2005
Location: Bucharest, Romania
Distribution: Ubuntu 10.04
Posts: 38

Rep: Reputation: 15
Compiz Fusion and Fedora 8 (again)


I'm trying to start compiz on a Fedora 8 on KDE
compiz --replace
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
[damarius@localhost ~]$ metacity --replace &
[1] 3073


Here is the xorg.conf output:

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1280x1024"
HorizSync 31.5 - 81.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x960"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


----------------
i'm guessing it's the driver's fault.
So what driver should I install?
I tried
yum install xorg-x11-drv-nvidia-96xx
but it says it conflicts with xorg-x11-drv-nvidia
I'm using GeForce 4 mx 440
 
Old 02-27-2008, 04:40 PM   #2
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
Are you trying to run it as root, or are you running the x-server as root?
 
Old 02-27-2008, 11:17 PM   #3
da_marius
Member
 
Registered: Dec 2005
Location: Bucharest, Romania
Distribution: Ubuntu 10.04
Posts: 38

Original Poster
Rep: Reputation: 15
I'm trying to start compiz as a normal user
It appears that the X server is run as root.
 
Old 02-28-2008, 05:57 PM   #4
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
Did you start it as root?
You shouldn't do that.
Start it as user and at least that error should go away.
 
Old 02-28-2008, 06:01 PM   #5
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
What if you just add compiz to System > Preferences > Sessions ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 8 and compiz fusion.... sblantipodi Fedora 13 02-24-2008 11:02 AM
cursor problem with compiz-fusion and stellarium in Fedora 7 Iltbreg Fedora 2 01-23-2008 09:42 AM
How to compile and install compiz-fusion from git on Fedora 7 axelfc Fedora 1 10-29-2007 03:10 AM
Can't manage to start compiz fusion in fedora 7 Iltbreg Fedora 9 09-15-2007 09:09 PM
Question about Compiz Fusion on Fedora Core 7 jamesrouse Linux - Desktop 2 08-19-2007 04:15 PM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration