LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Compiz Fusion and Fedora 8 (again) (http://www.linuxquestions.org/questions/fedora-35/compiz-fusion-and-fedora-8-again-624290/)

da_marius 02-27-2008 02:38 PM

Compiz Fusion and Fedora 8 (again)
 
I'm trying to start compiz on a Fedora 8 on KDE
compiz --replace
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
[damarius@localhost ~]$ metacity --replace &
[1] 3073


Here is the xorg.conf output:

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1280x1024"
HorizSync 31.5 - 81.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x960"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


----------------
i'm guessing it's the driver's fault.
So what driver should I install?
I tried
yum install xorg-x11-drv-nvidia-96xx
but it says it conflicts with xorg-x11-drv-nvidia
I'm using GeForce 4 mx 440

oskar 02-27-2008 04:40 PM

Are you trying to run it as root, or are you running the x-server as root?

da_marius 02-27-2008 11:17 PM

I'm trying to start compiz as a normal user
It appears that the X server is run as root.

oskar 02-28-2008 05:57 PM

Did you start it as root?
You shouldn't do that.
Start it as user and at least that error should go away.

jay73 02-28-2008 06:01 PM

What if you just add compiz to System > Preferences > Sessions ?


All times are GMT -5. The time now is 08:26 AM.