LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Compiz 0.7.8 (Fedora core 10) --replace # Fatal: glXCreateContext failed (http://www.linuxquestions.org/questions/fedora-35/compiz-0-7-8-fedora-core-10-replace-fatal-glxcreatecontext-failed-686923/)

R03L 11-28-2008 03:14 PM

Compiz 0.7.8 (Fedora core 10) --replace # Fatal: glXCreateContext failed
 
compiz --replace
compiz (core) - Fatal: glXCreateContext failed
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Can anybody help me!

R03L 11-28-2008 03:23 PM

xorg.conf
 
maybe this will help.

Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder63)  Tue Nov  4 14:08:09 PST 2008

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "Module"
    Load          "dbe"
    Load          "extmod"
    Load          "type1"
    Load          "freetype"
    Load          "glx"
EndSection

Section "ServerFlags"
    Option        "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbLayout" "us_intl"
    Option        "XkbModel" "pc105"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Samsung"
    HorizSync      30.0 - 70.0
    VertRefresh    50.0 - 160.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 7600 GT"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "0"
    Option        "TwinViewXineramaInfoOrder" "CRT-0"
    Option        "metamodes" "1280x1024 +0+0"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection


Tylerious 12-10-2008 01:15 AM

I have the same problem with basically the same xorg.conf and GeForce 6100.

I am running the nvidia drivers, but compiz does not work.

peeths003 12-10-2008 03:58 AM

Hey .. I am using Fedora 10 x86_64 .. its working for me correctly ....

i guess you might have already installed compizconfig-settings-manager ,

Just try installing the "fusion-icon" and then try running compiz using fusion icon,

let me know .....

Thanks
Peeths ...

Tylerious 12-10-2008 11:53 AM

I had the same problem using the nvidia driver. I resolved it by adding the following to my /etc/X11/xorg.conf:

Code:

Section "Files"
        ModulePath  "/usr/lib64/xorg/modules/extensions/nvidia"
        ModulePath  "/usr/lib64/xorg/modules"
EndSection

Or, for 32 bit,

Code:

Section "Files"
        ModulePath  "/usr/lib/xorg/modules/extensions/nvidia"
        ModulePath  "/usr/lib/xorg/modules"
EndSection


peeths003 12-11-2008 02:05 AM

For 32 bit


Quote:

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules/drivers"
ModulePath "/usr/lib/xorg/modules"
EndSection




For 64 bit


Quote:

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules/drivers"
ModulePath "/usr/lib64/xorg/modules"
EndSection

xpertkn 06-25-2009 08:01 PM

Cool beans! Setting ModulePath fixes the glx issue. I can use cairo-dock and glxgears now. but compiz still can't be enabled.


All times are GMT -5. The time now is 10:10 PM.