LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 09-02-2004, 08:56 AM   #1
strobart
LQ Newbie
 
Registered: Sep 2004
Location: London
Posts: 16

Rep: Reputation: 0
Changing default login on Fedora Core 2??


Hi,

I've recently installed Fedora Core 2 on my Dell Latitude D600. It went on extremely easily and so far (touch wood) I have no serious problems (other than my very basic understanding of linux but I'm working on it...!).

One little thing that is bugging me is that I prefer the KDE to the GNOME desktop: to my mind things are more intuitively set out and it seems to be more easily customisable. The problem is that my login "default" is to Gnome so in order to use KDE I have to change the session each time I log in.

I am CERTAIN there is a way to set KDE to default but I'm damned if I can find it!!

Can anyone point me in the right direction.

Many thank in advance.
 
Old 09-02-2004, 08:58 AM   #2
seabass55
Member
 
Registered: Jan 2003
Location: 127.0.0.1
Distribution: Fedora&Gentoo
Posts: 207

Rep: Reputation: 30
This will change it for all users on the system...but edit

/etc/sysconfig/desktop

and make it KDE
 
Old 09-02-2004, 09:32 AM   #3
strobart
LQ Newbie
 
Registered: Sep 2004
Location: London
Posts: 16

Original Poster
Rep: Reputation: 0
Thanks,

I knew it would be something embarrassingly easy! That worked a treat (it's my personal computer so the fact that it changes the settigns for all users is of no importance).

Do you know how to change the logout options so I can shutdown/restart? At the moment it is logout or cancel only?

Cheers,

Euan
 
Old 09-02-2004, 04:31 PM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Edit:

/etc/sysconfig/desktop

and make sure you have the displaymanager setting as :

DISPLAYMANAGER="KDE"
 
Old 09-02-2004, 06:35 PM   #5
bru
Member
 
Registered: Sep 2003
Location: South Carolina
Distribution: Ubuntu, CentOS, BT4, Debian
Posts: 132

Rep: Reputation: 15
To shutdown you need to have the permissions to do so, but brain not working this early in the mornning, check your user manager, and add your self to what ever group needed. I think "shutdown" is the name of the group you need to be in.
 
Old 09-02-2004, 10:38 PM   #6
Slyder42
Member
 
Registered: Jun 2004
Location: Wheaton, IL
Distribution: trying to get FC4 to work
Posts: 46

Rep: Reputation: 15
To make it even more embarassingly easy and without doing coding... there is the thing called "Switchdesk"

2 ways to install Switchdesk.

1. yum install switchdesk as root

2. Use the Synaptic Package Manager and choose to install switchdesk and switchdesk-gui. Say yes to the dependencies it needs, click apply and wait.

Switchdesk appeared in Preferences > Desktop Switching Utility.

If you haven't gotten synaptic... you should.. it will make your life MUCH simpler as a newbie and start to learn how to extract tarballs and use yum and apt.

Have fun.
 
Old 09-02-2004, 11:03 PM   #7
seabass55
Member
 
Registered: Jan 2003
Location: 127.0.0.1
Distribution: Fedora&Gentoo
Posts: 207

Rep: Reputation: 30
Or as a noobie you could learn to do it "the long way"....little gui tools and wizards aren't always going to be there.
 
Old 09-03-2004, 05:18 AM   #8
strobart
LQ Newbie
 
Registered: Sep 2004
Location: London
Posts: 16

Original Poster
Rep: Reputation: 0
Great,

I have now done it the long and the short way (switchdesk certainly is easy!) and learned a bit about apt and yum along the way. Thanks.

However, I haven't been able to get Synaptic? I use "apt-get install synaptic" but came back saying it wasn't found?

Cheers
 
Old 09-03-2004, 06:19 AM   #9
strobart
LQ Newbie
 
Registered: Sep 2004
Location: London
Posts: 16

Original Poster
Rep: Reputation: 0
OK, I'll answer my own question in case anyone reading this has had the same newbie problem....

As everyone probably already knows "seek and ye shall find"....

Synaptic for fedora core 2 can be found at

http://tettnang.freshrpms.net/rpm.html?id=573

I installed it with rpm by rpm -Uvh synaptic-0.52-1.1.fc2.fr.i386.rpm

This worked no problem at all.

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems changing the default login prompt... wmqman Linux - General 3 09-01-2005 01:30 PM
Changing the default file type icons in gnome on fedora C3 Sm1ler Linux - General 3 04-22-2005 10:43 AM
changing the default desktop in login screen Niflheim Linux - Newbie 3 03-27-2005 07:57 AM
Fedora Core 2- Default Login? FedoraFan Fedora 9 09-29-2004 09:19 AM
changing my default shell after login? Quartzophobia Linux - General 1 02-11-2004 11:36 AM


All times are GMT -5. The time now is 07:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration