LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   can't use yum or preupgrade (http://www.linuxquestions.org/questions/fedora-35/cant-use-yum-or-preupgrade-923346/)

MPPhoto 01-11-2012 08:15 PM

can't use yum or preupgrade
 
[root@MPressPhotoDT edwin]# preupgrade-cli
Traceback (most recent call last):
File "/usr/share/preupgrade/preupgrade-cli.py", line 34, in <module>
from cli import *
File "/usr/share/yum-cli/cli.py", line 29, in <module>
import rpm
File "/usr/lib64/python2.7/site-packages/rpm/__init__.py", line 9, in <module>
from rpm._rpm import *
ImportError: /usr/lib64/librpm.so.2: file too short
[root@MPressPhotoDT edwin]# preupgrade-cli
Traceback (most recent call last):
File "/usr/share/preupgrade/preupgrade-cli.py", line 34, in <module>
from cli import *
File "/usr/share/yum-cli/cli.py", line 29, in <module>
import rpm
File "/usr/lib64/python2.7/site-packages/rpm/__init__.py", line 9, in <module>
from rpm._rpm import *
ImportError: /usr/lib64/librpm.so.2: file too short
[root@MPressPhotoDT edwin]# rm -f /var/lib/rpm/__db*
[root@MPressPhotoDT edwin]# rpm –rebuilddb
rpm: error while loading shared libraries: /usr/lib64/librpm.so.2: file too short
[root@MPressPhotoDT edwin]# yum clean all
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

/usr/lib64/librpm.so.2: file too short

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.7.1 (r271:86832, Apr 12 2011, 16:15:16)
[GCC 4.6.0 20110331 (Red Hat 4.6.0-2)]

If you cannot solve this problem yourself, please go to
the yum faq at:
http://yum.baseurl.org/wiki/Faq

coolsg5636 01-11-2012 10:06 PM

What exactly are you trying to do here?

Are you trying to upgrade fedora from one major release to another ? e.g. Fedora 15 to 16

MPPhoto 01-12-2012 12:22 PM

Trying to upgrade to F16 from to F15

John VV 01-12-2012 05:17 PM

??? upgrade form 16 to the older 15 ????

or is that a typo ?

If 15 to 16
it looks like you change the version of python
yum REQUIRES the SPECIFIC version that is in the fedora updates repo

however seeing as SO MANY things have changed in 16 a fresh clean install is recomended

reformat to ext4 and install 16 on a clean drive .


for every fedora upgrade PREPARE for a new clean install
try the preuprgaed ( it is getting better) but expect to do a clean install .

tux-junkie 01-13-2012 11:19 AM

I had the same problem. I had to use a new disc and do a fresh install.

coolsg5636 01-13-2012 12:19 PM

Even If you are trying to downgrade your operating system for some reason(which has to be pretty good) , you should go for a fresh install as suggested by John.

MPPhoto 01-17-2012 01:46 PM

Trying to upgrade to F16 from to F15[/QUOTE]

I decided to order f16 x64 disc.
thank u

MPPhoto 01-17-2012 01:49 PM

I decided to get a F16 x64 disc


All times are GMT -5. The time now is 10:00 AM.