LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Can't switch to TTY or run level 3 from run level 5 (http://www.linuxquestions.org/questions/fedora-35/cant-switch-to-tty-or-run-level-3-from-run-level-5-a-725443/)

reemfz 05-12-2009 09:34 AM

Can't switch to TTY or run level 3 from run level 5
 
Hi Guys,
here is my scenario:

I am running F10 x86_64 with Nvidia Quadro FX 3400.
I installed the drivers and it worked just fine. No errors generated according to Nvidia log files.
However, while in run level 5 when I try to switch to run level 3 by typing "telinit 3" or "init 3" the X server goes down and I get a blank screen. Same thing happens when I try to switch to a different tty session by <ctrl>+<alt>+F2 (or any F key for that matter).
I also noticed that when I shut down my system I can't see any more the screen where services are shutting down and their status ([OK] or [failed]).

Would appreciate your help on solving this issue.

John VV 05-17-2009 12:35 PM

how did you install the nvidia driver?
did you use yum OR did you install the nvidia.run driver ?
have you ran the nvidia tool in " /applications / System tools " ?

reemfz 05-18-2009 10:25 AM

I downloaded the drivers from Nvidia website.
x86_64-180.51.pkg2.run

The installation was very smooth, no errors or crushes.

I ran the nvidia tools but didn't change anything since everything just works. except when I try to switch to a different console or runlevel (X dies and I need to reboot the system).
I found out that if I disable composite extension in my xorg.conf and reboot or restart X, everything gets back to normal. Meaning I can switch to other consoles or runlevels.
So I am pretty sure it has something to do with the composite extension (i.e Detktop effect).

I also read in the Nvidia forum that someone changed the kernel module parameter in the nvidia drivers called NVREG_USEVBIOS from 1 to 0 and it resolved the problem.
1. I am not sure I want to fool around with the drivers.
2. I don't know how to change the parameters.

Could that be a bug in the drivers? is there an option I need to enable/disable in the nvidia tool?

Besides the fact that if X crushes I am screwed, I really enjoy the drivers' performance.

any help on resolving the issue is greatly appreciated.

cyrilng 06-01-2009 08:06 AM

i have the same problem on kubuntu jaunty


All times are GMT -5. The time now is 08:36 PM.