LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 01-05-2007, 06:18 AM   #1
S.V.
LQ Newbie
 
Registered: Dec 2006
Location: Bengaluru, India
Distribution: Mandriva, Mint, Slackware
Posts: 28

Rep: Reputation: 15
Cannot start GUI in FC6


Hi all,
I have a low memory- 256MB DDR400 and I had to install FC6 in text mode. The installation went smothly but for some reason FC6 logs me into text mode by default. If I type 'startx' from the terminal the screen goes dark with |Hz ?| box moving like it does when the monitor's data cable is not connected. If I press Ctrl+Z it shows some msgs among which I found one line strange. It says 'Screen 0 is not capable of DRI' What does this mean? How can this problem be solved?
 
Old 01-05-2007, 06:23 AM   #2
brianthegreat
Member
 
Registered: Oct 2005
Posts: 518

Rep: Reputation: 32
You need to configure X but of course I forget the command.

What type of video card do you have?

You should not had to install Fedora in text mode considering that you only have 256 megs of ram. Actually that is enough ram to run the GUI installer. During the text install there should have been a section that allowed for X to be configured and tested but a reinstall is not needed.
 
Old 01-05-2007, 07:21 AM   #3
S.V.
LQ Newbie
 
Registered: Dec 2006
Location: Bengaluru, India
Distribution: Mandriva, Mint, Slackware
Posts: 28

Original Poster
Rep: Reputation: 15
No Brian, the installer automatically went into text-install mode saying I don't have enough memory, though I had opted for graphical installation. Also as I saw there was nothing related to X configuration in entire text-install process.

Regarding ur enquiry about the video card, I don't have a seperate graphics card. Its the in-built one in the Asus K8V-VM Ultra motherboard. Thats VIA chipsets- K8M890 and VT8237A.
 
Old 01-05-2007, 01:31 PM   #4
praveen_2003
Member
 
Registered: Apr 2003
Location: india
Posts: 144

Rep: Reputation: 15
try alterig the /etc/X11/xorg.conf file... u mite succeed..
 
Old 01-05-2007, 06:26 PM   #5
cezar_sl
LQ Newbie
 
Registered: Jan 2007
Posts: 6

Rep: Reputation: 0
i have the same problem
i installed in graphical mode and it worked fine then after restart i get the same box
it appears after it tries to process udev

can someone give detailed instructions because I'm only good with Linux when i works :P
 
Old 01-05-2007, 06:35 PM   #6
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 51
@ S.V. If it reads 'Screen 0 is not capable of DRI' it means hardware acceleration is not available. DRI=Direct Rendering.
Edit your /etc/X11/xorg.conf and comment out 'options "dri"' line. Again this is a general information, better if you post your xorg.conf along with your hardware details(video chip) so we can help you.

Last edited by Hitboxx; 01-05-2007 at 06:36 PM.
 
Old 01-05-2007, 06:41 PM   #7
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 51
Also give the output of '#/sbin/lspci'
 
Old 01-07-2007, 10:03 AM   #8
S.V.
LQ Newbie
 
Registered: Dec 2006
Location: Bengaluru, India
Distribution: Mandriva, Mint, Slackware
Posts: 28

Original Poster
Rep: Reputation: 15
After 'startx' command the screen goes blank as I have stated above. The following is the msg I get after pressing Ctrl+Alt+F1.
Code:
(==)Logfile: "/var/log/Xorg.0.log", Time Sun Jan 7 13:25:25 2007
(==)Using config file: "/etc/X11/xorg.conf"
(EE) AIGLX: Screen0 is not DRI capable
localuser:root being added to access control list
SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/2617
**(eggcups:2685):WARNING**: IPP request failed with status 1030

**(eggcups:2685):WARNING**: IPP request failed with status 1030
error getting update info: Cannot find avalid baseurl for repo:core
You cannot run beagle as root. Beagle is designed to run from your own user account. If you want to create multiuser or system-wide indexes, use the beagle-build-index tool.

You can override this setting using the beagle-config or beagle-settings tools.
The following is my /etc/X11/xorg.conf file:
Code:
# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier "Default Layout"
	Screen 0 "Screen0" 0 0
	Input device "Keyboard0" "Corekeyboard"
EndSection

Section "Input Device"
	Identifier "Keyboard0"
	Driver "kbd"
	Option "XkbModel" "pc105"
	Option "XkbLayout" "us"
EndSection

Section "Device"
	Identifier "Videocard0"
	Driver "vesa"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device "Videocard0"
	DefaultDepth 24
	SubSection "Display"
		Viewport 0 0 
		Depth 24
	EndSubSection
EndSection
Note again that I don't have seperate graphics card. I'm using onboard VIA chipset(K8M890 and 8237A). My memory is 256MB DDR400 of which only 192MB is available. 64MB is for VGA frame buffer.

I tried something on my own:
1. changed 'vesa' to 'via'
2. changed depth to 16
3. Is Videocard0 PCI 1st slot? I changed it to 'Integrated VGA'
4. In bios Primary Graphics Adapter was PCIE VGA. tried changing it to Integrated VGA.
Needless to say nothing worked.
I'd taken a backup of the file and restored it for the moment.

I don't wnt funky 3D-4D wobble-gobble stuff if AIGLX and DRI are related to it. Just a simple working desktop so that I get productive immediately.
 
Old 01-08-2007, 09:36 AM   #9
S.V.
LQ Newbie
 
Registered: Dec 2006
Location: Bengaluru, India
Distribution: Mandriva, Mint, Slackware
Posts: 28

Original Poster
Rep: Reputation: 15
Problem solved

Hi all,
Thanks for ur attempt to solve my problem. One of my friends asked me to try the following command.
Code:
system-config-display
And immediately I was greeted with GUI. I had to choose my monitor and display adapter. Ofcourse my hardware wasnot detected by was given an option to set them to 'Generic'. And my GUI is up and running.

Hope this post will help someone else.

Thanxs again.
SV.
 
Old 02-15-2007, 05:45 AM   #10
rajuvk
LQ Newbie
 
Registered: Feb 2007
Location: Kerala, India
Distribution: FC10, Ubuntu 8.04
Posts: 14

Rep: Reputation: 1
My system also have the same motherboard. When I tried to install FC6, I cannot get the X server running. However the installation was in GUI mode. I tried selecting "Generec" display adapter, without any result. Any suggestions ?

Raju
 
Old 02-15-2007, 09:10 AM   #11
S.V.
LQ Newbie
 
Registered: Dec 2006
Location: Bengaluru, India
Distribution: Mandriva, Mint, Slackware
Posts: 28

Original Poster
Rep: Reputation: 15
Did u try 'system-config-display' command?
It usually solves the problem. Else post the error message(s).
 
Old 03-12-2007, 04:42 PM   #12
mikirere
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Hi,

I have the same problem with red hat
and it gives me the following msgs when i ran system-config-display

Trying with card "VMWare"
cannot start xserver with card0

any ideas?

Thanks

Quote:
Originally Posted by S.V.
Did u try 'system-config-display' command?
It usually solves the problem. Else post the error message(s).
 
Old 03-24-2007, 12:04 AM   #13
swathi1
LQ Newbie
 
Registered: Mar 2007
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by S.V.
Hi all,
I have a low memory- 256MB DDR400 and I had to install FC6 in text mode. The installation went smothly but for some reason FC6 logs me into text mode by default. If I type 'startx' from the terminal the screen goes dark with |Hz ?| box moving like it does when the monitor's data cable is not connected. If I press Ctrl+Z it shows some msgs among which I found one line strange. It says 'Screen 0 is not capable of DRI' What does this mean? How can this problem be solved?

Hii all

This is swathi..A new user...
I have installed Fedora6 ..But the installation was done in Text Mode..It dint give me any option..It said couldnt start GUI and switching back to text mode...
Then After reading the forums I tried
startx
output: "couldnt start Xserver in card 0
Couldn start X server in old config trying out New
then Again couldnt strat thats it"""

My /etc/X11/xorg.conf file says

section "server layout"
Identifier "Default layout"
screen 0 "Screen 0" 0 0
Input Device "Keyboard 0" "core keyboard"
ens section

section "Input device"
Identifier "Keyboard 0"
driver "kbd"
end section

section "Device"
Identifier "Video card 0"
driver "i810"
end

Its similar to what you have placed..please help me
How can i help this...
Regards
Swathi
 
Old 04-11-2007, 01:05 PM   #14
kariukidw
LQ Newbie
 
Registered: Oct 2006
Posts: 15

Rep: Reputation: 0
FC6 Display problem....its getting more problematic guys

Hi People,

seems this problem with FC6 giving an 'signal out of range' error on first boot is really common, does anyone know why this happens?

Let me take the problem a level higher.....I installed FC6 on my PC and got the same error, i managed to sort it by using the system-config-display utility and everything was fine. I just did the same installation for a friend and got the same blank screen, so when i tried the system-config-display utility, it returns an error libuser.so.1 is missing. I tried navigating to the /usr/bin/userhelper file where the libuser.so.1 usually is but the file was missing, anyone know how else to bring X up apart from using system-config ?


Here is the xorg.conf file of the named system;

# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
Input device "Keyboard0" "Corekeyboard"
EndSection

Section "Input Device"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection


The system runs a VIA graphics card, 512MB RAM, 2.26 GHz Intel celeron.


Anyone who can help?
 
Old 04-16-2007, 09:02 AM   #15
S.V.
LQ Newbie
 
Registered: Dec 2006
Location: Bengaluru, India
Distribution: Mandriva, Mint, Slackware
Posts: 28

Original Poster
Rep: Reputation: 15
Hi all,
the reason why we are getting blank screen with |Hz ?| is because our monitor is getting higher frequencies than it can handle. I am talking of the H-Sync and V-Sync rates for the monitor(Atleast this was the case with my FreeBSD installation). This information is usually available in the monitor's manual.

But forgive me, I donot know the exact file which has to be edited or the command that can do this job. In FreeBSD, its the 'xorgconfig' command. If anyone knows similar command or editable file please reply.
 
  


Reply

Tags
fedora, gui


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X does not start on FC6 prabhatsoni Linux - Software 6 12-20-2006 12:14 PM
FC6: X11 doesn't start on Dell D620 Nathaniel Firet Fedora - Installation 4 12-08-2006 09:13 PM
Fail to start FC6 satimis Fedora 1 12-07-2006 01:20 AM
FC6, after x264 update, mplayer won't start gnjunior Fedora 5 11-04-2006 04:58 PM
GUI doesn't start Faceless42001 Slackware 3 08-16-2004 12:43 PM


All times are GMT -5. The time now is 08:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration