LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 04-21-2008, 06:08 PM   #1
Makeba79
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Rep: Reputation: 0
Cool Fedora8 & 9beta : Cannot logon as root in runlevel5


I created a Fedora 8 installation DVD from a downloaded file, and installed it on my new laptop. It works great, except there is some security feature that won't allow you to log in as root from the GUI.
I've tried initializing my PC in runlevel3 and logging in as root, then issuing the startx command, and I've also tried the init 5 command to start runlevel5, but it stops all the services I started while logged in as root at runlevel3 before going into the GUI.

Each time start in runlevel5 or startx from runlevel3, I get a warning message saying

"This session is running as a privileged user.

Running a session as a privileged user should be avoided for security reasons. If possible, you should log in as a normal user.

[Continue] [Quit]
"


Of course, I always click continue, but from runlevel5, it logs me off and kicks me back out to the logon screen. In runlevel 3, it errors out and xwindows shuts down, kicking me back out to the command prompt with this error:
Fatal server error:
Caught signal 11. Server aborting

(EE) intel(0): write to /sys/class/backlight/acpi_video1/brightness for backlight control failed: Invalid argument
could not attach to desktop process
gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server
:0.0
ICE default IO error handler doing an exit(),pid=3377, errno=0
xinit: connection to X server lost.

waiting for X server to shut down XIO: fatal IO error 3 (Interrupted system call) on X server ":0.0"
after 1599 requests (1592 known processed) with 1 events remaining.


Can anyone please help me figure out how to turn off this security feature so that I can log into the GUI as root? By default, my user accounts cannot access the commands I need to practice in the terminal, even if I su as root.
(I had worked around this by using runlevel 5 and logging in as a user, then quick switching by pressing Ctrl+Alt+F3 to go to runlevel 3 and log in as root, but for some reason this stopped working too.)

Last edited by Makeba79; 04-21-2008 at 06:25 PM. Reason: more distro-specific title
 
Old 04-21-2008, 06:42 PM   #2
blacky_5251
Member
 
Registered: Oct 2004
Location: Adelaide Hills, South Australia
Distribution: RHEL 4&5, Fedora 10, CentOS 5.4, IPCop
Posts: 569

Rep: Reputation: 55
When the FC8 GUI login screen is displayed, you see a list of regular users that you can click on and then enter the password. Root is not in that list, BUT, you should still be able to enter "root" into the username field instead of clicking on a user in the list. Then enter the root password.
 
Old 04-21-2008, 06:50 PM   #3
Makeba79
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by blacky_5251 View Post
When the FC8 GUI login screen is displayed, you see a list of regular users that you can click on and then enter the password. Root is not in that list, BUT, you should still be able to enter "root" into the username field instead of clicking on a user in the list. Then enter the root password.
That's how I first noticed this error, Ian.
I click "Other" and log in as "root" then I get a warning message box saying:

"This session is running as a privileged user.

Running a session as a privileged user should be avoided for security reasons. If possible, you should log in as a normal user.

[Continue] [Quit]
"


Of course, I always click continue, but from runlevel5, it logs me off and kicks me back out to the logon screen.
 
Old 04-22-2008, 02:58 AM   #4
blacky_5251
Member
 
Registered: Oct 2004
Location: Adelaide Hills, South Australia
Distribution: RHEL 4&5, Fedora 10, CentOS 5.4, IPCop
Posts: 569

Rep: Reputation: 55
OK - sorry I didn't read your post properly the first time.

There is no security feature that you turn on or off to stop the root user from logging in on the console in runlevel 5. I can happily log in to my FC8 box as root at the GUI console.

When you ctrl-alt-f3 you are accessing tty3, in the same way you can access tty1 through to tty6 by pressing ctrl-alt-and the corresponding function key. This gives you 6 pseudo terminals that you can login to on the console. Ctrl-alt-F7 will return you to X (GUI). These are all available in runlevel 5, but in runlevel 3 the GUI screen on ctrl-alt-f7 isn't there (obviously).

The question is, why can't root login using the GUI console. If the error you've reported is only occurring for the root user, that is quite odd. I would start by reconfiguring X by renaming the file /etc/X11/xorg.conf to something else and restarting X (either by rebooting or changing from runlevel 5 to 3 and back to 5 using init 5; init 3; init 5.

Start with simple/vanilla/plain settings and see if it works OK for you. If it does, then start customising it to your specific video card and monitor(s).
 
Old 04-22-2008, 12:29 PM   #5
Makeba79
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by blacky_5251 View Post
OK - sorry I didn't read your post properly the first time.

There is no security feature that you turn on or off to stop the root user from logging in on the console in runlevel 5. I can happily log in to my FC8 box as root at the GUI console.

When you ctrl-alt-f3 you are accessing tty3, in the same way you can access tty1 through to tty6 by pressing ctrl-alt-and the corresponding function key. This gives you 6 pseudo terminals that you can login to on the console. Ctrl-alt-F7 will return you to X (GUI). These are all available in runlevel 5, but in runlevel 3 the GUI screen on ctrl-alt-f7 isn't there (obviously).

The question is, why can't root login using the GUI console. If the error you've reported is only occurring for the root user, that is quite odd. I would start by reconfiguring X by renaming the file /etc/X11/xorg.conf to something else and restarting X (either by rebooting or changing from runlevel 5 to 3 and back to 5 using init 5; init 3; init 5.

Start with simple/vanilla/plain settings and see if it works OK for you. If it does, then start customising it to your specific video card and monitor(s).

Now that you mention it, I was able to log in as root in the GUI in Fedora 8 before I installed the updates. After I installed the initial 400+ updates, my PC listed a new kernel under runlevel3. (Fedora release 8.90(Rawhide) Kernel 2.6.24.1-28.fc9 on an i686) is what it is now. It was only after that installation (my Grub boot splashscreen shows 2 Fedora kernels) that I began to have root login errors from the GUI, regardless of the kernel I boot from.... is anyone familiar with this kernel?

~Makeba

Last edited by Makeba79; 04-22-2008 at 12:30 PM.
 
Old 04-23-2008, 09:12 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 13,477

Rep: Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802
from the boot menu you should not be seeing the 2 kernels unless you hit < enter> or some button
at system start up the splash shows up and counts down 3,2,1
then grub boots up
then rhgb starts up in quite mode
then the login , with the users on the left ( if that is set)

just do a Normal boot( don't touch anything ) and login as root
 
Old 04-24-2008, 12:21 AM   #7
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
You have made you install into a half breed. You apparently had the development repos turned on. Thus you install (apparently) a great deal of F9. The 8.9 (or any above 8.0) designation indicates a beta of the F9. The easiest, fastest, safest, way out is to do a clean reinstall. Make sure you do not have the development repos turned on when you update.
 
  


Reply

Tags
errors, fedora, logon, root


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo Root Issue. Cannot SU or logon to Root Battousai Linux - Distributions 8 11-14-2006 06:54 PM
logon at console for root only DarReNz Solaris / OpenSolaris 2 05-29-2006 02:39 PM
Can't logon to root on Kde 3.4 galliar Suse/Novell 3 04-09-2005 11:19 AM
Runlevel5 services failing after updating to 2.6.4 c4_4ya Linux - General 2 03-24-2004 04:39 PM
How do i change from Runlevel5 to Runlevel3? FunkFlex Linux - General 9 04-16-2002 01:39 PM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration