LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-11-2007, 05:37 AM   #1
Zombie13
Member
 
Registered: Nov 2003
Posts: 70

Rep: Reputation: 15
Can no longer connect to tunnelled VNC server.


Hi,

I have been successfully tunnelling a VNC session to my FC6 box for a few weeks. However, it now seems to be broken. The error I am getting from VNC Viewer on my client (WinXP) machine is "Server closed connection unexpectedly". I have port 5900 open on the FC6 firewall, and have even tried disabling the firewall, which doesn't help.

The FC6 box is set to listen on port 443 for ssh, as I am connecting from work where the number of ports open to me is limited. This is still working perfectly using PuTTY. I have not changed the tunnelling settings on PuTTY at all, so I ruling PuTTY out as a problem.

What I have changed though, is the IP settings on my local network where the FC6 box is based. I've gone from a static IP network to DHCP. This means that my router has gone from 192.168.0.1 to 192.168.1.1, and the FC6 box from 192.168.0.124 to 192.168.1.2. The FC6 box always has the IP 192.168.1.2, as I've set this as "fixed" in the DHCP server on the router.

What I'm basically asking is... could someone help me troubleshoot why I'm getting the "connection closed" error. I'm thinking it has to be connected the IP address change, but apart from that I don't know where to look.

Thanks for any help you guys can give me!
 
Old 10-11-2007, 02:35 PM   #2
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
have you tried to telnet to the FC6 box on the VNC port to verify it is open?

telnet IPTOYOURHOME 5900

if that fails try,
telnet IPTOYOURHOME 5901
 
Old 10-12-2007, 03:38 AM   #3
Zombie13
Member
 
Registered: Nov 2003
Posts: 70

Original Poster
Rep: Reputation: 15
Thanks for the reply.

I've tried what you said, but from the FC6 box itself ("telnet localhost 5900" & "telnet localhost 5901"). I don't see how doing this from any other machine outside my local network would help, as I'm tunneling the VNC connection through ssh on port 443, not just using a plain VNC connection through port 5900 (or 5901) through my router.

Code:
Trying ::1...
telnet: socket: Address family not supported by protocol
telnet: Unable to connect to remote host: Illegal seek
The only changes I have made to this box is the IP address change, and a "yum upgrade" now and again. I'm still convinced it's something to with either of those things, as this was working perfectly before that and nothing at the client end has changed.

Any more help on this would be greatly appreciated, as I'm a bit limited by being stuck to the command line at the moment.

Cheers!
 
Old 10-12-2007, 04:19 PM   #4
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
What I meant for you to do is from the FC6 box, open a terminal window and type "telnet localhost 5900" without the quotes.
See if that port is open and that the daemon is responding on that port.

Next, have you stopped/started the vncserver on the FC6 box?
 
Old 10-16-2007, 03:25 AM   #5
Zombie13
Member
 
Registered: Nov 2003
Posts: 70

Original Poster
Rep: Reputation: 15
That's exactly what I did... "telnet localhost 5900" (without quotes) on the FC6 box. The error message is posted above.

VNC is running. I use "x11vnc -usepw -display :0" to start the server, which appears to be listening on port 5900 as expected...

Code:
The VNC desktop is:      mymachine.mydomain.com:0
PORT=5900
Code:
[zombie13@mymachine ~]$ ps -ef | grep vnc
zombie13     20286 20285  0 08:21 pts/2    00:00:00 x11vnc -usepw -display :0
zombie13     20303 20004  0 08:21 pts/1    00:00:00 grep vnc
[zombie13@mymachine ~]$
Thanks again!

Last edited by Zombie13; 10-16-2007 at 03:27 AM.
 
Old 10-16-2007, 10:05 AM   #6
Zombie13
Member
 
Registered: Nov 2003
Posts: 70

Original Poster
Rep: Reputation: 15
I fixed it! While working on something else, I noticed an important line missing from /etc/hosts. I have no idea how I managed to delete that and not notice, but VNC is now working again.

Quote:
127.0.0.1 localhost.localdomain localhost
A bit embarrassing, really...
 
Old 10-16-2007, 10:33 PM   #7
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
lol I was next going to suggest making sure you didn't have a firewall enabled and then to check /etc/hosts. good to hear it's fixed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VNC Failed to connect to server cthomas Suse/Novell 9 10-14-2006 07:59 AM
windows vnc client and linux vnc server problem tungaw2001 Linux - Software 8 06-17-2006 01:06 AM
can't connect to VNC server started by xinetd andymadigan Linux - Networking 4 02-21-2006 05:18 PM
VPN Tunnelled, but no connection dunmarie Linux - Networking 1 10-21-2003 05:40 AM
unable to connect to server thru vnc... marvc Linux - Software 0 05-25-2003 07:24 PM


All times are GMT -5. The time now is 07:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration