Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 05-12-2009, 10:34 AM   #1
LQ Newbie
Registered: Mar 2009
Posts: 12

Rep: Reputation: 0
Can't switch to TTY or run level 3 from run level 5

Hi Guys,
here is my scenario:

I am running F10 x86_64 with Nvidia Quadro FX 3400.
I installed the drivers and it worked just fine. No errors generated according to Nvidia log files.
However, while in run level 5 when I try to switch to run level 3 by typing "telinit 3" or "init 3" the X server goes down and I get a blank screen. Same thing happens when I try to switch to a different tty session by <ctrl>+<alt>+F2 (or any F key for that matter).
I also noticed that when I shut down my system I can't see any more the screen where services are shutting down and their status ([OK] or [failed]).

Would appreciate your help on solving this issue.
Old 05-17-2009, 01:35 PM   #2
John VV
LQ Muse
Registered: Aug 2005
Posts: 15,636

Rep: Reputation: Disabled
how did you install the nvidia driver?
did you use yum OR did you install the driver ?
have you ran the nvidia tool in " /applications / System tools " ?
Old 05-18-2009, 11:25 AM   #3
LQ Newbie
Registered: Mar 2009
Posts: 12

Original Poster
Rep: Reputation: 0
I downloaded the drivers from Nvidia website.

The installation was very smooth, no errors or crushes.

I ran the nvidia tools but didn't change anything since everything just works. except when I try to switch to a different console or runlevel (X dies and I need to reboot the system).
I found out that if I disable composite extension in my xorg.conf and reboot or restart X, everything gets back to normal. Meaning I can switch to other consoles or runlevels.
So I am pretty sure it has something to do with the composite extension (i.e Detktop effect).

I also read in the Nvidia forum that someone changed the kernel module parameter in the nvidia drivers called NVREG_USEVBIOS from 1 to 0 and it resolved the problem.
1. I am not sure I want to fool around with the drivers.
2. I don't know how to change the parameters.

Could that be a bug in the drivers? is there an option I need to enable/disable in the nvidia tool?

Besides the fact that if X crushes I am screwed, I really enjoy the drivers' performance.

any help on resolving the issue is greatly appreciated.
Old 06-01-2009, 09:06 AM   #4
LQ Newbie
Registered: Oct 2007
Distribution: debian lenny
Posts: 24

Rep: Reputation: 15
i have the same problem on kubuntu jaunty


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
set your default run level so you will boot to a default run level - vga console Adam555 Linux - Newbie 1 01-21-2008 05:55 PM
emacs in run level 3 then switch to X (level 7) then back to level 3 dsoliver Slackware 3 09-01-2006 04:31 AM
Run Level 3 webwolf70 Mandriva 5 01-17-2005 11:41 PM
Run level Joey.Dale Linux - General 4 06-18-2003 05:59 PM
run level isajera Linux - Software 2 06-22-2001 08:20 AM

All times are GMT -5. The time now is 11:12 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration