LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 01-06-2005, 11:11 PM   #1
bearwood
Member
 
Registered: Nov 2004
Location: Lat 16S
Distribution: Mandrake
Posts: 36

Rep: Reputation: 15
Can't listen to Audio CD's


With the help of some other on another forum I have managed to get Audio Cd's playing in Grip but can not get them playing in Xmms or KsCD (unless I run KsCD as root), KsCD crashes when I try to play a song, it comes up with the tracks and Artist info. Xmms will play MP3's ok, if I look at the Option|preferences|CD Audio Player config and click on Check Drive it says:The ?dev.. is ok, there are 18 tracks etc and the /media/... is ok, so it can see the CD ok. How do I make it play?
 
Old 01-07-2005, 01:28 AM   #2
dubya
Member
 
Registered: Mar 2004
Location: Kitchener, Ontario, Canada
Posts: 386

Rep: Reputation: 30
Go to options, then preferences then under the Audio I/O Plugins tab, select CD audio player. Hit configure, then under play mode, select digital audio extraction. That's how I do it. Hope this helped.
 
Old 01-08-2005, 03:28 AM   #3
bearwood
Member
 
Registered: Nov 2004
Location: Lat 16S
Distribution: Mandrake
Posts: 36

Original Poster
Rep: Reputation: 15
Already tried that, oh well I think it must be something in my sound setup as MythTv has no sound either.
 
Old 01-08-2005, 02:27 PM   #4
dubya
Member
 
Registered: Mar 2004
Location: Kitchener, Ontario, Canada
Posts: 386

Rep: Reputation: 30
What happens when you try to play a CD after you've done the above? Do you have proper permissions set on the drive?
 
Old 01-08-2005, 04:52 PM   #5
Nighthawk4
Member
 
Registered: Jan 2005
Location: UK
Distribution: PCLinuxOS
Posts: 37

Rep: Reputation: 15
I had this problem in Fedora 3.

I found that if I run Gnome-cd directly (i.e automatically when I insert an Audio CD), it fails to play.

However, if I close that, open a Terminal window, SU to Root and then run Gnome-cd as Root, it plays.

Is there a way to make Gnome-cd run as Root directly please anyone, like a shell script to SU and then exec Gnome-cd perhaps?

Incidentally, when trying to get the CD-writer to work, I used chmod to change the permissions on the CD reader and Writers to 666. This fixed the CD Writing but Gnome-cd will still not play the Audio CDs.

Any ideas please?
 
Old 01-08-2005, 10:59 PM   #6
JFresh
LQ Newbie
 
Registered: Jan 2005
Posts: 9

Rep: Reputation: 0
I had this problem too. I updated udev, which took care of me having to constantly change the permissions on the CD drive for playing audio. After updating udev, I haven't had to change permissions (chmod).
Code:
yum update udev
Read here:
http://fedora.redhat.com/docs/udev/
 
Old 01-15-2005, 07:04 PM   #7
bearwood
Member
 
Registered: Nov 2004
Location: Lat 16S
Distribution: Mandrake
Posts: 36

Original Poster
Rep: Reputation: 15
I am really confused now. In KDE I turned off aRts and that seemed to fix alot of problems. In Gnome I can now play a CD using the CD player from the Sound&Multimedia menu. Grip is working fine. Xmms plays CD's if I show it where the CD is (ie like selecting MP3's) but will not automatically play a CD. I haven't tried K3b recently but I suspect I have to run that as su. I have managed to get sound running in Mythtv ok.
My biggest issue now is getting the Gnome mixer to stop defaulting all its settings when Gnome starts up.
udev is up to date. Permissions don't seem to be the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot listen to audio in slackware..Help!!! lenson Linux - Newbie 9 08-21-2005 02:00 AM
Using digital extraction to listen to audio CD's? Sledge Fedora 0 06-26-2004 02:36 PM
How to listen to streaming audio in KDE? jmirles Libranet 2 12-26-2003 11:46 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 07:52 AM
Trouble playing commercial audio cd's. MP3 cd's ok. barryww1956 Linux - General 7 12-17-2001 07:42 PM


All times are GMT -5. The time now is 01:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration