LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-13-2006, 06:52 PM   #1
144419855310001
Member
 
Registered: Apr 2006
Distribution: ubuntu 7.04
Posts: 219

Rep: Reputation: 30
Can't get SWAT to work


I'm running Fedora Core 5 x86_64.

I just installed the rpm for swat and have been trying to follow the installation notes in the man page, but with no success.

Firstly, it said to
Quote:
add swat 901/tcp
to /etc/services
which I did, but then the instructions were to add
Quote:
swat stream tcp nowait.400 root /usr/local/samba/sbin/swat swat
to /etc/inetd.conf
Now I could not find "ineitd.conf" anywhere on my system. I did come across "xineitd.conf", so I tried adding that line to the bottom of that file instead.

However, when I navigate to http://127.0.0.1:901/, I just get a "page not found" error.

I tried
Quote:
chkconfig swat on
which I came across in another thread, but this just lead to a different error when I tried to access swat:
Quote:
The connection was reset
The connection to the server was reset while the page was loading.
I'm a bit stuck. Can anyone help me?
Thanks
 
Old 11-13-2006, 07:02 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
xinetd has a different syntax from inetd. You can't just add the inetd line to it. This page describes the proper way to set it up:

http://docsrv.sco.com:507/en/samba_help/swat.8.html

BTW, It's likely that the distro has already set the proper entry up for you and you just have to edit the last line to say "no" instead of "yes".

Last edited by David the H.; 11-13-2006 at 07:08 PM.
 
Old 11-14-2006, 11:54 AM   #3
144419855310001
Member
 
Registered: Apr 2006
Distribution: ubuntu 7.04
Posts: 219

Original Poster
Rep: Reputation: 30
I tried the xinetd installation notes (the man page in the fc5 rpm must be rather outdated, did not have this section).

However, I checked /etc/xinetd.d/swat, and couldn't see anything wrong...

Quote:
service swat
{
disable = yes
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = root
server = /usr/sbin/swat
log_on_failure += USERID
}
I don't understand. Usage should be as simple as "/usr/sbin/swat" and "firefox http://127.0.0.1:901/".
Switching iptables and firestarter services off makes no difference.

What else could be wrong?

Last edited by 144419855310001; 11-14-2006 at 11:56 AM.
 
Old 11-14-2006, 06:30 PM   #4
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
You still have "disable = yes" in the configuration. You need to change that to "no" and restart the service before it will work.
 
Old 11-15-2006, 08:30 AM   #5
144419855310001
Member
 
Registered: Apr 2006
Distribution: ubuntu 7.04
Posts: 219

Original Poster
Rep: Reputation: 30
Whoops. sorry.

Was about 1 am when I wrote that

[EDIT]: For everyone else out there using fedora, I just found this neat feature in system-config-services: If you click the "On Demand Services" tab you can edit all the xinetd services, such as swat, without needing to manually edit files. Swat of course must be checked to enable it.

Last edited by 144419855310001; 11-15-2006 at 11:33 AM.
 
Old 11-15-2006, 11:32 AM   #6
144419855310001
Member
 
Registered: Apr 2006
Distribution: ubuntu 7.04
Posts: 219

Original Poster
Rep: Reputation: 30
Hmmm, no wait

I'm still having problems. I edited /etc/xinetd.d/swat to "disable = no" but though swat is running I still can't access it...

I just thought to check the swat log /var/log/samba/swat.log, and this is all there was:
Quote:
[2006/11/15 17:57:53, 0] printing/print_cups.c:cups_cache_reload(85)
Unable to connect to CUPS server localhost - Connection refused
[2006/11/15 17:59:22, 0] printing/print_cups.c:cups_cache_reload(85)
Unable to connect to CUPS server localhost - Connection refused
[2006/11/15 18:01:43, 0] printing/print_cups.c:cups_cache_reload(85)
Unable to connect to CUPS server localhost - Connection refused
Not entirely surprising seeing as I have cups switched off.

Now trying "service xinetd reload" as I just read somewhere gets me that
Quote:
The connection to the server was reset while the page was loading.
page again...

Last edited by 144419855310001; 11-15-2006 at 12:13 PM.
 
Old 11-16-2006, 06:13 AM   #7
decrepit
Member
 
Registered: May 2006
Distribution: Ubuntu10.04, < fedora12
Posts: 347

Rep: Reputation: 34
Have you checked iptables again, now you've fixed the other problem?
 
Old 11-16-2006, 03:05 PM   #8
144419855310001
Member
 
Registered: Apr 2006
Distribution: ubuntu 7.04
Posts: 219

Original Poster
Rep: Reputation: 30
Well, here is the list of commands I use:

Quote:
su
/sbin/chkconfig swat on
/sbin/service xinetd restart
/sbin/service firestarter stop
/sbin/service iptables stop
/sbin/service --status-all
/usr/sbin/swat /*then, leaving swat running, and in a different terminal window:*/
firefox http://localhost:901/
--->Error: "The connection to the server was reset while the page was loading."
I tried Eiphany, but that just refused to connect at all (though it did not report a "connection refused" as it would for other blocked ports).

I also noticed that I get this firefox message whether or not Swat is actually running!!
Alternatively, if I do not "chkconfig swat on/manually edit /etc/xinetd.d/swat "disable" to "no", then I just get a "connection refused" like I would for any blocked port.


Here is service --status-all; would this be relevant?
Quote:
acpid (pid 2080) is running...
anacron is stopped
atd (pid 2150) is running...
auditd (pid 1792) is running...
Configured Mount Points:
------------------------

Active Mount Points:
--------------------
Avahi daemon is not running
Avahi DNS daemon is not running
Checking for service avgd: avgscan is not running
hcid is stopped
sdpd is stopped
capi not installed - No such file or directory (2)
cpuspeed dead but subsys locked
crond (pid 2108) is running...
cupsd is stopped
cups-config-daemon is stopped
dhcdbd ( 2211 ) listening on :1.1 [ OK ]
Device not specified in /etc/sysconfig/diskdump
Firestarter is stopped
gkrellmd is stopped
gpm (pid 2099) is running...
hald (pid 2167) is running...
Usage: /etc/init.d/hidd {start|stop|restart|reload|condrestart}
hpiod is stopped
hpssd is stopped
JAVA_EXECUTABLE or HSQLDB_JAR_PATH in '/etc/sysconfig/hsqldb' is set to a non-file.
httpd is stopped
icecast is stopped
Firewall is stopped.
irattach is stopped
irqbalance is stopped
not implemented
lircmd is stopped
lircd is stopped
lisa is stopped
mdmpd is stopped
dbus-daemon (pid 2427 2023) is running...
number of zones: 6
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/1000
tcp clients: 0/100
server is up and running
Server address not specified in /etc/sysconfig/netdump
netplugd is stopped
Configured devices:
lo eth0
Currently active devices:

NetworkManager (pid 2247) is running...
NetworkManagerDispatcher (pid 2256) is running...
rpc.mountd is stopped
nfsd is stopped
rpc.rquotad is stopped
rpc.statd is stopped
nscd is stopped
ntpd is stopped
portmap is stopped
privoxy is stopped
Process accounting is disabled.
qemu binary format handlers are not registered.
rdisc is stopped
restorecond is stopped
rpc.idmapd is stopped
saslauthd is stopped
sendmail is stopped
WARNING: Shorewall startup is disabled. To enable startup, set STARTUP_ENABLED=Yes in /etc/shorewall/shorewall.conf
Shorewall-3.2.1 Status at ashcroft254 - Thu Nov 16 21:21:27 GMT 2006

Shorewall is stopped
State:Unknown

smartd (pid 2071) is running...
smbd (pid 5099 5094) is running...
nmbd (pid 5097) is running...
spamd is stopped
sshd is stopped
syslogd (pid 2011) is running...
klogd (pid 2014) is running...
Xvnc is stopped
Webmin is stopped
wifiroamd is stopped
winbindd is stopped
wpa_supplicant is stopped
xfs (pid 2141) is running...
xinetd (pid 2847) is running...
ypbind is stopped
Nightly yum update is disabled.
Thank you again

Last edited by 144419855310001; 11-16-2006 at 03:08 PM.
 
Old 11-18-2006, 03:52 AM   #9
decrepit
Member
 
Registered: May 2006
Distribution: Ubuntu10.04, < fedora12
Posts: 347

Rep: Reputation: 34
Sorry looks like you're better at this than me, but I've checked my core1 and core3 books, that have swat instructions in them, unfortunately they don't shed any light on your problem. What you've done agrees with what they say.
I've managed to get by without swat, using the RH Samba server configuration gui.
 
Old 11-20-2006, 06:12 PM   #10
144419855310001
Member
 
Registered: Apr 2006
Distribution: ubuntu 7.04
Posts: 219

Original Poster
Rep: Reputation: 30
Yeah.

I actually managed to get it working quite straightforwardly on a Fedora Core 6 i386 machine, so I guess the rather unique problems on my FC5 x86_64 must be the result of some fiddling I've done at some point or other.

Would be nice if I knew how to fix it, as some guru once said, there is always a way to fix things on linux (supposedly!). But then I guess you can't have everything... If nobody knows, and it hasn't affected anyone else, then I'm not going to spend the next 4 weeks wrapping my head around it!

But thanks for your time...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How does /sbin/chkconfig swat on work ? ramki Linux - Networking 12 12-26-2002 11:56 AM
I can't get SWAT to work! granny Linux - Newbie 10 12-11-2002 12:28 PM
SWAT in RH 7.3 xgtr Linux - Newbie 1 05-31-2002 09:51 PM
SWAT does not work when calling localhost:901 themorph Linux - Networking 2 03-06-2002 11:04 PM
getting swat / samba to work with RH7.1 workstation install cliffyman Linux - Newbie 3 11-13-2001 11:25 AM


All times are GMT -5. The time now is 11:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration