LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 01-25-2004, 02:12 PM   #1
kalvnhobbz
LQ Newbie
 
Registered: Dec 2003
Posts: 13

Rep: Reputation: 0
Can't compile nvidia nforce drivers in AT kernel


Quote:
First, allow me to curse Nvidia for their stupid drivers that
cannot be included in the default source tree >:^[ It seems
that all of the problems I have had with this new nForce board
are purely related to getting the stupid drivers to work...

Anyway, I'm attemping to follow Jarod's guide for doing a MythTV
install on Fedora Core. I am at stage 7 of the guide, right after
I installed the new AT kernel and rebooted. As per the guide, I
am trying to rebuild the Nvidia drivers against the new kernel
and no matter which build method I try (using the rpmbuild that
worked earlier in the guide or just trying to build the tarball
by hand) I keep getting unresolved symbols.

Things to note:

Since the network on the box in question is not working, I'm
transcribing all this info by hand, thus there may be a typo or
two.

The rpmbuild --rebuild from step #5 worked fine (using the stock
Fedora kernel).

I could not do the apt-get for the kernel in step #7, so I
downloaded the latest RPM and installed the source and kernel
via RPM -Uvh.

Kernel: kernel-BOOT-2.4.22-1.2163.nptl_32.rhfc1.at.i386.rpm
Source: kernel-source-2.4.22-1.2163.nptl_32.rhfc1.at.i386.rpm
Nvidia: nvidia_nforce_10_0261src.rpm (from nvidia's site)

Example error from the "rpmbuild --rebuild nvidia_nforce_10_0261src.rpm":
depmod: *** Unresolved symbols in /lib/modules/2.4.22-1.2163.nptl_32.rhfc1.atBOOT/kernel/drivers/net/nvnet.o

I get the same error from a manual build when I do a make install.

Anyway, this is a virgin install that has followed Jarod's guide
except for the rpm-instead-of-apt-get I mentioned above. Hopefully
that's enough info, but if I can provide something else, just let
me know.

Does anyone know what's going on here? Anything other than the
fact that the Nvidia driver install process sucks, that is ;^)

Thanks!
Mike
This describes exactly the same problem I'm having installing the ethernet nForce drivers for my SN41G2 - i did use apt-get, and i've tried older AT kernel versions as well and no luck. Any ideas?
 
Old 01-26-2004, 03:44 AM   #2
GraemeK
Member
 
Registered: Aug 2003
Location: Essex, UK
Distribution: Windoze 2000, Fedora Core 3
Posts: 325

Rep: Reputation: 30
i got the same errors also. i gave up and justed a 3com card instead and left the nforce nic for windoze.

G
 
Old 01-26-2004, 08:44 AM   #3
kalvnhobbz
LQ Newbie
 
Registered: Dec 2003
Posts: 13

Original Poster
Rep: Reputation: 0
i'm not sure what i did, but i switched back to booting the AT kernel and for some reason the NIC worked. this is after trying rpmbuild and rpm several times already....

course now i have the problem of getting the line-in working on the sn41g2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVidia Nforce drivers and Mandrake 9.2 64 bit dmcanally Linux - Hardware 1 06-30-2004 07:05 PM
nVidia nForce Drivers Trust Slackware 3 03-22-2004 06:19 PM
nvidia drivers and new compile of kernel c0rderr0y Linux - Newbie 8 02-22-2004 08:39 PM
Nvidia nForce Ethernet Drivers boardinglaxplr Linux - Networking 2 02-10-2004 07:01 AM
nVidia nForce drivers baldurkn Linux - Newbie 24 07-24-2003 11:13 AM


All times are GMT -5. The time now is 04:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration