LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 06-23-2005, 02:47 PM   #1
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Can't change greater screen: FC4 & KDE


When I run gdmsetup, or edit gdm.conf by hand, and then reboot (or switch user) my login screen remains the plain, standard, login screen.

This isn't, by any means, a "show stopper," but it seems strange.

Here's my current gdm.conf:
Code:
$ cat /etc/X11/gdm/gdm.conf | grep -v ^# | grep -v ^$
[daemon]
AutomaticLoginEnable=false
AutomaticLogin=peter
TimedLoginEnable=true
TimedLogin=peter
TimedLoginDelay=5
Greeter=/usr/bin/gdmlogin
DefaultPath=/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin
RootPath=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin
User=gdm
Group=gdm
LogDir=/var/log/gdm
PidFile=/var/run/gdm.pid
PostLoginScriptDir=/etc/X11/gdm/PostLogin/
PreSessionScriptDir=/etc/X11/gdm/PreSession/
PostSessionScriptDir=/etc/X11/gdm/PostSession/
DisplayInitDir=/etc/X11/gdm/Init
XKeepsCrashing=/etc/X11/gdm/XKeepsCrashing
RebootCommand=/sbin/reboot;/sbin/shutdown -r now;/usr/sbin/shutdown -r now;/usr/bin/reboot
HaltCommand=/sbin/poweroff;/sbin/shutdown -h now;/usr/sbin/shutdown -h now;/usr/bin/poweroff
ServAuthDir=/var/gdm
BaseXsession=/etc/X11/xdm/Xsession
DefaultSession=default.desktop
UserAuthDir=
UserAuthFBDir=/tmp
UserAuthFile=.Xauthority
StandardXServer=/usr/X11R6/bin/X
Xnest=/usr/X11R6/bin/Xnest -audit 0 -name Xnest
DisplayLastLogin=true
SoundProgram=/usr/bin/play
[security]
AllowRoot=true
AllowRemoteRoot=false
AllowRemoteAutoLogin=true
RelaxPermissions=0
CheckDirOwner=true
RetryDelay=5
DisallowTCP=true
[xdmcp]
Enable=false
[gui]
GtkTheme=Clearlooks
AllowGtkThemeChange=true
GtkThemesToAllow=all
MaxIconWidth=128
MaxIconHeight=128
[greeter]
TitleBar=true
ConfigAvailable=true
Browser=true
MinimalUID=500
Logo=/usr/share/pixmaps/gdm.png
Welcome=%n: Only authorized use permitted
RemoteWelcome=%n: Ony authorized use permitted.
BackgroundType=1
BackgroundImage=/home/peter/Pictures/Country Road in Autumn, Nashville, Indiana.bmp
BackgroundColor=#20305a
BackgroundRemoteOnlyColor=false
ShowGnomeFailsafeSession=false
ShowLastSession=true
Use24Clock=true
GraphicalTheme=happygnome-list
GraphicalThemeDir=/usr/share/gdm/themes/
SoundOnLoginFile=/usr/share/sounds/KDE_Window_Open.ogg
[chooser]
HostImageDir=/usr/share/hosts/
Hosts=
Broadcast=true
Multicast=false
[debug]
Enable=false
[servers]
0=Standard
[server-Standard]
name=Standard server
command=/usr/X11R6/bin/X -audit 0
flexible=true
[server-Terminal]
name=Terminal server
command=/usr/X11R6/bin/X -audit 0 -terminate
flexible=false
handled=false
[server-Chooser]
name=Chooser server
command=/usr/X11R6/bin/X -audit 0
flexible=false
chooser=true
Anyone have any idea why it seems to be being ignored?

(I'm fairly sure this is not relevant, but, FYI, I have patched my kernel to include the latest nVidia driver, the NTFS support, and the ALSA support.)
 
Old 06-24-2005, 10:46 AM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Original Poster
Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Lightbulb Opps!

My bad!

I have kdm set as my display manager, not gdm, and kdm does not support automatic login.

Sorry. Now all I need to do is figure out where to change it. (Probably in /usr/share or /etc -- I'll look around.)
 
Old 06-24-2005, 12:55 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Original Poster
Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
OK, what I had was
Code:
$ cat /etc/sysconfig/desktop~
DESKTOP="GNOME"
DISPLAYMANAGER=KDE
and what I wanted was
Code:
$ cat /etc/sysconfig/desktop
DESKTOP="KDE"
DISPLAYMANAGER=GNOME
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I changed video settings & rebooted, now I cant change it back - black screen ?? wayneh Linux - Newbie 8 12-12-2006 04:35 PM
How can I change the screen resolution for KDE? ozymandias Linux - Newbie 13 11-11-2005 07:15 AM
How to change the KDE splash screen image LinuxSeeker Linux - General 2 02-13-2004 03:01 PM
Can't change screen resolution RH9/KDE thoand Linux - Newbie 3 11-14-2003 05:21 AM
How to change the screen resolution in Red Hat 7.1 KDE env/ vbp1 Linux - General 2 10-11-2001 06:04 AM


All times are GMT -5. The time now is 11:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration