LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-11-2008, 03:05 PM   #1
copeasetic
LQ Newbie
 
Registered: May 2006
Posts: 4

Rep: Reputation: 0
Can't enable desktop effects on F8 2.6.24.3-12.fc8


I stupidly updated my kernel and now I can't get Desktop Effects to start... Again.. This alway seems to happen when I load a new kernel... This time I have been unable to restore Desktop Effects....

Any guidance is greatly appreciated.

-Thx

My xorg.conf file:

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "on"
Option "Clone" "off"
Option "AIGLX" "true"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1680x1050"
HorizSync 31.5 - 65.5
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
Option "XAANoOffscreenPixmaps" "true"
Option "AllowGLXWithComposite" "true"
Option "TripleBuffer" "true"
Option "RenderAccel" "true"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation GeForce 8600 GTS"
Option "AddARGBGLXVisuals" "True"
Option "XAANoOffscreenPixmaps" "true"
Option "AllowGLXWithComposite" "true"
Option "TripleBuffer" "true"
Option "RenderAccel" "true"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Option "AddARGBGLXVisuals" "true"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1680x1050"
Option "AddARGBGLXVisuals" "true"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
EndSection
 
Old 03-11-2008, 03:45 PM   #2
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 871
Blog Entries: 9

Rep: Reputation: 103Reputation: 103
Hi,

I suggest you recompile the drivers for your video card. (reinstall the drivers, manually if possible). Telling us which distro you use would help.

Serafean
 
Old 03-11-2008, 04:12 PM   #3
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
can,t enable desktop effects on F8.2.6.24.3-12FC

just a guess you are using Fedora 8 ?
Before updating was 3D enabled ?

What is the driver in hardware section


all the best
 
Old 03-12-2008, 05:16 AM   #4
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 393

Rep: Reputation: 47
Go back to the previous kernel or disable Compiz and wait for an update.
 
Old 03-12-2008, 07:23 AM   #5
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
I don't know why it wouldn't work anymore, it does for me. How exactly was Compiz set up? Did you add it to your System > Prefs > Personal > Sessions? And then System > Look And Feel > Desktop Effects?
 
Old 03-12-2008, 12:22 PM   #6
Phoxis
Member
 
Registered: Feb 2008
Location: India, Kolkata
Distribution: Fedora 16
Posts: 59

Rep: Reputation: 16
you need to update the video drivers which works with the new kernel edition.
Check the livna packages.
 
Old 03-16-2008, 09:43 PM   #7
Rongeur
LQ Newbie
 
Registered: Jan 2008
Location: San Jose, CA US
Distribution: Fedora 8
Posts: 1

Rep: Reputation: 0
New kernel fix this problem for me

Having experienced same problem as "copeasetic", I was prepared to dedicate some time today to find a fix, and what do you know? The updated kernel "2.6.24.3-34.fc8" fixed the problem with no intervention on my part.

I'm curious, copeasetic; did it fix itself for you as well?

I can't get over how well this distro is working for me.

_____________
Rongeur,
Dell Latitude D430
Fedora 8 (and absolutely loving it!)
 
Old 03-24-2008, 05:00 PM   #8
copeasetic
LQ Newbie
 
Registered: May 2006
Posts: 4

Original Poster
Rep: Reputation: 0
No success in re-enabling desktop effects...

I have tried working on this issue on an off now for the last week with no luck. To answer some of the previous posters questions:

I am running Fedora 8
I installed the updated kernel (2.6.24.3-34.fc8) with no effect.
I have reinstalled my video drivers
I have removed and reinstalled Gnome
I have removed and reinstalled compiz-gnome

Can anyone tell me where I can find log data on the "failure to enable Desktop Effects"? I have checked both messages.log and Xorg.log and neither return an error from me to work back from. All I get is the error pop up window.

Can someone point me to a guide as to what I need in order to get Desktop Effects installed correctly? I would really like to confirm my system is configured correctly.

Also, would it help for me to post my xorg.conf file for further review?

Thanks in advance for the help!
 
Old 03-25-2008, 04:26 AM   #9
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Add "compiz" to System > Preferences > Personal > Sessions. Log out, then System > Prefs > Look & Feel > Desktop Effects. You may also want to install CompizConfig to control your settings.
 
Old 03-26-2008, 03:00 PM   #10
copeasetic
LQ Newbie
 
Registered: May 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Still no help

I have added compiz to my sessions, rebooted and attempted to enable desktop effects.

I am still dead in the water. There has to be something wrong with my display settings....
 
Old 03-26-2008, 03:21 PM   #11
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
Download and install this RPM in order to be able to use the livna repository:

http://rpm.livna.org/livna-release-8.rpm

Then run, "yum install kmod-nvidia" and when that is done, "yum -y update", and then reboot.

HTH

Forrest

p.s. That should also fix it for any future kernel upgrades.

Last edited by forrestt; 03-26-2008 at 03:22 PM.
 
Old 03-28-2008, 02:22 PM   #12
copeasetic
LQ Newbie
 
Registered: May 2006
Posts: 4

Original Poster
Rep: Reputation: 0
I already run the kmod-nvidia driver for F8 and still no help. I am going to install and compile the nvidia drivers and see if that has any effect.
 
Old 03-31-2008, 04:39 AM   #13
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 393

Rep: Reputation: 47
Instead of playing with Desktop Effects hit ALT/F2 and run fusion-icon. Right click the blue icon in the top panel and choose Compiz as window manager.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to enable Desktop Effects tasnim Linux - Desktop 2 02-23-2008 01:46 PM
FC8 and Desktop Effects ComputerErik Fedora 1 01-01-2008 06:37 PM
cannot enable desktop-effects !! Pango853 Linux - Desktop 10 12-24-2007 08:47 AM
cannot enable desktop effects narcispy Ubuntu 4 06-20-2007 10:27 AM
I canīt enable desktop effects skullhunterph Fedora 3 04-01-2007 06:30 PM


All times are GMT -5. The time now is 10:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration