LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-30-2012, 01:06 PM   #1
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,400

Rep: Reputation: 55
Can't display half of Pictures in /home/user


F17 /KDE-4.9.2-1

I did a fresh install from F10 to F17 ,but I kept the old User directory in the /home partition.

I did delete the old .kde /user/directory from the F10 install.

I can view most of the jpg or png pictures in /home/user directory, but there is a number of jpg or png that I can't view, I get this error message:

"Failed Loading Meta information, failed"

This problem is all over a Google search ,but no solutions on correcting the problem.
 
Old 10-30-2012, 01:28 PM   #2
shefla
Member
 
Registered: Oct 2012
Location: France
Distribution: Archlinux
Posts: 35

Rep: Reputation: 5
Which software are you using to display picture ?
If you launch the program from a terminal, do you see error messages in the terminal ?
Have you tried other softwares ?
Have you tried to convert it in TIFF for example ?

This post may help.
https://bugs.kde.org/show_bug.cgi?id=289819
 
Old 10-30-2012, 05:37 PM   #3
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,400

Original Poster
Rep: Reputation: 55
No matter what app I use to open pictures, I get the same result.

I checked the KDE bug report, but I don't know what all this means below.

Git commit dd7fd362d23e2f2f29a052a988f825aaf6cf102a by Aurélien Gâteau.
Committed on 26/03/2012 at 23:03.
Pushed by gateau into branch 'KDE/4.8'.

Use file extension as a hint for QImageReader
Fixes decoding PNG in weird situations.
FIXED-IN: 2.8.2

M +21 -2 lib/document/loadingdocumentimpl.cpp
M +2 -0 tests/auto/documenttest.cpp
A +- -- tests/data/289819_does_not_load.png

http://commits.kde.org/gwenview dd7fd362d23e2f2f29a052a988f825aaf6cf102a
 
Old 10-30-2012, 08:10 PM   #4
shefla
Member
 
Registered: Oct 2012
Location: France
Distribution: Archlinux
Posts: 35

Rep: Reputation: 5
If it is not working regardless of the tool used, your pictures may have been corrupted.
That's why I asked you to try to convert a buggy picture from jpg to tiff. You can also try other formats ; let say BMP or GIF.
I can be done with ImageMagick package:
> convert src.jpg dst.tiff

Quote:
Originally Posted by mickeyboa View Post
I checked the KDE bug report, but I don't know what all this means below.

Git commit dd7fd362d23e2f2f29a052a988f825aaf6cf102a by Aurélien Gâteau.
Committed on 26/03/2012 at 23:03.
Pushed by gateau into branch 'KDE/4.8'.

Use file extension as a hint for QImageReader
Fixes decoding PNG in weird situations.
FIXED-IN: 2.8.2

M +21 -2 lib/document/loadingdocumentimpl.cpp
M +2 -0 tests/auto/documenttest.cpp
A +- -- tests/data/289819_does_not_load.png
This give details regarding the fix they did in source files. It has been applied on 26/03/2012 in the 4.8 version of KDE.

It seems problems posted in forum found on Google are linked to the picture size.
What is the minimum and the maximum size in MB and in pixels of working pictures ?
What is the minimum and the maximum size in MB and in pixels of non-working pictures ?

As a workaround, have you tried to open it from a web browser like Firefox ?
 
Old 10-31-2012, 04:46 PM   #5
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,400

Original Poster
Rep: Reputation: 55
Firefox could not open the Pictures either.

Running convert I get a error message:

[Tom@localhost ~]$ convert me.jpg bob.tif
convert: delegate failed `"html2ps" -U -o "%o" "%i"' @ error/delegate.c/InvokeDelegate/1058.
convert: no decode delegate for this image format `/tmp/magick-IQ6ATHm9' @ error/constitute.c/ReadImage/566.
convert: missing an image filename `bob.tif' @ error/convert.c/ConvertImageCommand/3016.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sitewide pictures cannot display in China edenCC LQ Suggestions & Feedback 1 06-13-2010 06:36 AM
Konqueror can't display JPG pictures. mickeyboa Fedora 5 10-26-2008 06:03 AM
kopete display pictures. brianhall Linux - General 1 06-23-2006 07:09 AM
GKrellM, How do i Display Pictures in it? predator.hawk Slackware 8 09-01-2004 12:06 PM
Konqueror does not display .gif pictures frelihm Linux - Software 2 07-15-2004 09:28 AM


All times are GMT -5. The time now is 01:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration