LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 02-09-2007, 12:55 PM   #1
belliott4488
Member
 
Registered: Oct 2003
Location: Ellicott City, MD, US
Distribution: Fedora 11
Posts: 67

Rep: Reputation: 15
can't build BitTorrent client; Python dependencies?


I downloaded BitTorrent-5.0.5-1-Python2.4.noarch.rpm and attempted to install it, but got the following:

[root@localhost bitTorrent]# rpm -iv BitTorrent-5.0.5-1-Python2.4.noarch.rpm
error: Failed dependencies:
python-crypto >= 2.0 is needed by BitTorrent-5.0.5-1.noarch
python-psyco is needed by BitTorrent-5.0.5-1.noarch
python-twisted >= 2.0 is needed by BitTorrent-5.0.5-1.noarch
python-zopeinterface is needed by BitTorrent-5.0.5-1.noarch
wxPython >= 2.6 is needed by BitTorrent-5.0.5-1.noarch
[root@localhost bitTorrent]# python -V
Python 2.5

(The last two lines were to check my Python version.)

I had tried this earlier with the "stock" FC4 installation of Python, i.e. v2.4, but got the same results as above.

I don't know anything about Python's packages or dependencies - can anyone give me a clue of what I might need in order to build this client?

Thanks,
Bruce
 
Old 02-09-2007, 01:10 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,755
Blog Entries: 1

Rep: Reputation: 238Reputation: 238Reputation: 238
You don't have a problem with Python. You need wxPython > 2.6. wxPython is a different package. The latest is 2.8 something. You can get prebuilt binaries at SourceForge.

https://sourceforge.net/project/show...group_id=10718
 
Old 02-10-2007, 12:16 AM   #3
belliott4488
Member
 
Registered: Oct 2003
Location: Ellicott City, MD, US
Distribution: Fedora 11
Posts: 67

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Arow
You don't have a problem with Python. You need wxPython > 2.6. wxPython is a different package. The latest is 2.8 something. You can get prebuilt binaries at SourceForge.

https://sourceforge.net/project/show...group_id=10718
thanks. I downloaded the FC4 rpms wxPython2.8-gtk2-ansi-2.8.1.1-fc4_py2.4.i386.rpm and wxPython-common-gtk2-ansi-2.8.1.1-fc4_py2.4.i386.rpm, as well as for demos and docs. I hope these are the right ones (there were also files with "unicode" instead of "ansi", but I guessed these were what I wanted).

I can't get the demos to work, though ... I'm not sure I'm setting paths and so forth correctly.

When I try to install the BitTorrent client now, however, I now get this:

[root@localhost bitTorrent]# rpm -iv BitTorrent-5.0.5-1-Python2.4.noarch.rpm
error: Failed dependencies:
python-crypto >= 2.0 is needed by BitTorrent-5.0.5-1.noarch
python-psyco is needed by BitTorrent-5.0.5-1.noarch
python-twisted >= 2.0 is needed by BitTorrent-5.0.5-1.noarch
python-zopeinterface is needed by BitTorrent-5.0.5-1.noarch

i.e., no more complaints about the wxPython dependency. I guess now I need to search for these other things? Are they modules?
 
Old 02-10-2007, 12:43 AM   #4
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Have you ever tried using yum for your installations? Dries' repository has a noarch version. This would fix all your dependencies
 
Old 02-10-2007, 09:05 AM   #5
belliott4488
Member
 
Registered: Oct 2003
Location: Ellicott City, MD, US
Distribution: Fedora 11
Posts: 67

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by billymayday
Have you ever tried using yum for your installations? Dries' repository has a noarch version. This would fix all your dependencies
I forgot about yum ... in fact, I've never used it. Time to learn, I'd say.

(I've been using apt to get updates from the CCRMA site, but they're specific to pro audio. I figured I'd use yum for more general updates, if the need arose, in order to avoid potential inconsistencies between repositories. I don't know if this is necessary, or even wise, but I did run into trouble a couple of years ago, mixing updates from different repositories.)
 
Old 02-10-2007, 09:49 AM   #6
belliott4488
Member
 
Registered: Oct 2003
Location: Ellicott City, MD, US
Distribution: Fedora 11
Posts: 67

Original Poster
Rep: Reputation: 15
yum (was a problem installing bittorrent client)

Oh, for goodness' sake ... I can't believe I'm always forgetting about yum when I start moaning about how confusing it is to build and install software in FC. I just did 'yum install bittorrent' and 'yum install bittorrent-gui' and they both worked like a charm.

I've really got to remember this the next time around!!

thanks for the help - Bruce
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Python and Bittorrent jorisb Linux - Software 1 10-02-2004 04:21 PM
python and bittorrent dependencies jkassemi Linux - Software 2 05-09-2004 04:39 PM
BitTorrent 3.4.1a dependencies xilace Linux - Newbie 1 04-04-2004 07:42 AM
bittorrent without python.(azureus??) arunshivanandan Linux - Software 7 11-01-2003 11:05 AM
bittorrent and python mercutio Linux - Software 7 09-01-2003 07:06 PM


All times are GMT -5. The time now is 07:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration