LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 11-28-2004, 02:54 PM   #1
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,400

Rep: Reputation: 55
Building Mplayer W/alsa from src.rpm


FC3/KDE3.3
Installed mplayer with alsa.
I built from a mplayer-1.0pre5-2.src.rpm file with alsa and had no errors.
I installed the Rpm's from /usr/src/redhat/RPMS directory, but
what do I do with the files below , where do they go ?
I have mplayer working by using mplayerplug-in from Firefox
but I have no sound in mplayer.
Sound 'test' from Systems Setting gives you sound.
Also when starting Mplayer from /menu/Sound & Video/ Mplayer , it attemps to
run , but shuts down immediately.

Thanks
Jim

/usr/src/redhat/BUILD/MPlayer-1.0pre5/libmpdemux/ai_alsa.c
/usr/src/redhat/BUILD/MPlayer-1.0pre5/libmpdemux/ai_alsa1x.c
/usr/src/redhat/BUILD/MPlayer-1.0pre5/libao2/ao_alsa.c
/usr/src/redhat/BUILD/MPlayer-1.0pre5/libao2/ao_alsa5.c
/usr/src/redhat/BUILD/MPlayer-1.0pre5/libao2/ao_alsa9.c
/usr/src/redhat/BUILD/MPlayer-1.0pre5/libao2/ao_alsa1x.c
/usr/bin/alsalisp
---------------------------------------------------------------------------------------------------------------------------

This is the error I get when tryingto run 'gmplayer'
from command line.

~]$ gmplayer
MPlayer 1.0pre5-RPM-3.4.2 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 2134 MHz (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/kay/.mplayer/config
[cfg] read config file: /home/kay/.mplayer/gui.conf
Reading config file /home/kay/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/kay/.mplayer/codecs.conf: Can't open '/home/kay/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 73 audio & 180 video codecs
font: can't open file: /home/kay/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startupscripts.
Using usleep() timing
Can't open input config file /home/kay/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
SKIN dir 1: '/home/kay/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'
[skin] file ( /usr/share/mplayer/Skin/default/skin ) not found.
Skin not found (default).
 
Old 11-29-2004, 10:19 AM   #2
maxut
Senior Member
 
Registered: May 2003
Location: istanbul
Distribution: debian - redhat - others
Posts: 1,188

Rep: Reputation: 50
it says cannot find default skin. have u installed mplayer-skins mplayer-fonts ?
 
Old 12-20-2004, 08:44 PM   #3
alake
LQ Newbie
 
Registered: Apr 2004
Location: Loomis, CA
Distribution: Fedora Core 3
Posts: 2

Rep: Reputation: 0
I downloaded the i386 rpm and installed it. I had the same result. Then, it crashed and gave me the message that I should recompile the source with debug info and forward it to the authors. I was about to download the source (when I could find the same version) when I came across this post. I don't know what the final solution is, other than to wait for a new version...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Building RPM via src.Rpm ivanatora Linux - Newbie 2 02-20-2006 05:29 PM
building .src.rpm -> unknown option gletare Fedora 2 11-05-2005 05:44 PM
Building evolution-data-server-1.0.2-7.src.rpm louisb Linux - Enterprise 1 07-02-2005 05:45 PM
Building evolution-data-server-1.0.2-7.src.rpm louisb Linux - General 1 06-22-2005 09:21 AM
mplayer .src.rpm installing problems Harp00 Linux - Newbie 0 09-25-2003 04:29 PM


All times are GMT -5. The time now is 11:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration