LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 06-29-2005, 06:58 AM   #1
hansi umayangan
Member
 
Registered: Aug 2004
Distribution: AS3
Posts: 81

Rep: Reputation: 15
Boot fail


I have installed fc3. On the first run just after “configuring kernel parameters” system got stuck


starting undev: [ok]
initializing hardware... storage network audio done [ok]
configuring kernel parameters:
 
Old 07-02-2005, 07:24 AM   #2
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
I'm going out on a limb with this one, but can you change the runlevel to 1 in your grub.conf before it boots.

PS: if you had any more information, it would really help
 
Old 07-28-2005, 04:46 PM   #3
Woessey
LQ Newbie
 
Registered: Sep 2004
Location: Bowling Green, Ohio
Distribution: Redhat 7.2
Posts: 8

Rep: Reputation: 0
I'm having the same problem.

What other information do you need?
 
Old 07-29-2005, 02:35 AM   #4
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
Did you try changing the runlevel Woessey or is that what you are asking how to do?
 
Old 07-29-2005, 05:58 AM   #5
BadDoggie987
LQ Newbie
 
Registered: Jul 2005
Distribution: FC4, FreeBSD, OpenWRT
Posts: 3

Rep: Reputation: 0
I have the same error thanks to my 'efforts' last night!

Hansi, Woessey - Did the you add anything new like I did, or did it just happen on the first boot after the install?

My story.. I have been running FC3 for a few weeks (far from perfectly) and then yesterday decided to try to get it working better. Obviously, I made a mistake somewhere!

This is what I did -
1. Install the ATI Rage 200 driver (8.14.13) for X.Org 6.8, and run flxrconfig utility for said driver.
2. Install yum updates to the following packages (the ones I can remember)
- alsa-utils
- alsa-lib
- up2date
..that's all I can remember. There was also a couple of the more general libraries, but I'm at work now, not home and don't have notes here.

Interestingly, I can hit Ctrl-C when the systems appears to stop at "configuring kernel parameters" and it enters runlevel 5. From there, the boot continues (or tries to) but can't 'touch' a couple of files (kudzu and syslog from memory) because the file system has loaded read-only. After that it halts again whilst trying to start the system logging daemon.

I will try to bring the system up in single-user mode (that's runlevel 1, right?) when I get home tonight, and see what I can find out from there. Not really sure what I'm looking for, but my first stop will be demsg, then var/log/messages (after I check that the kernel is still configured to log there).

Any other hints would be appreciated!

Last edited by BadDoggie987; 07-29-2005 at 05:59 AM.
 
Old 07-29-2005, 02:44 PM   #6
Woessey
LQ Newbie
 
Registered: Sep 2004
Location: Bowling Green, Ohio
Distribution: Redhat 7.2
Posts: 8

Rep: Reputation: 0
I don't know how to change the run level. If you think that will work, let me know how to change it.
 
Old 07-30-2005, 06:20 AM   #7
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
if you use grub as your bootloader, you should be able to edit the boot commands and add either a 1

Mine works when I have
kernel /bzImage-2.6.12-mm1-rc3   1   vga=0x317



Quote:
Quote from http://www.sensiblesoftware.com/arti...Runlevels.html
You can also change the runlevel at boot time. If your system uses
LILO as the boot manager, you can append the runlevel to the boot
command :
LILO: linux 3 or
LILO: linux 5

If your system uses GRUB, you can change the boot runlevel by
pressing the `e' key to edit the boot configuration. append the
runlevel to the end of the boot command as shown:
kernel /vmlinuz ro root=/dev/hda1 5

Last edited by musicman_ace; 07-30-2005 at 06:23 AM.
 
Old 08-01-2005, 08:54 AM   #8
Woessey
LQ Newbie
 
Registered: Sep 2004
Location: Bowling Green, Ohio
Distribution: Redhat 7.2
Posts: 8

Rep: Reputation: 0
I still don't understand how to do this stuff. I am extremely new to Linux. I know absolutely nothing about any of the commands. If you are going to tell me what to do, you need to tell me exactly what to type and when to type it. I'm sorry that I am this dumb about everything. I'm just trying to learn everything I can.
 
Old 08-01-2005, 10:15 AM   #9
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
Do you know if you are using grub or lilo as your bootloader?
I imagine it is grub.
 
Old 08-01-2005, 11:20 AM   #10
Woessey
LQ Newbie
 
Registered: Sep 2004
Location: Bowling Green, Ohio
Distribution: Redhat 7.2
Posts: 8

Rep: Reputation: 0
I am about 75% sure that it is grub. I remember seeing that while I was loading and I don't think that I have ever heard of lilo.
 
Old 08-01-2005, 08:41 PM   #11
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
When you are at the boot prompt screen,

press e which allows you to edit to boot parameters.
Add the number 1 after the kernel parameter, which looks like bzImage-2.6.##

So it would look like kernel /bzImage-2.6.12-mm1-rc3   1   vga=0x317
 
Old 08-03-2005, 08:43 AM   #12
Woessey
LQ Newbie
 
Registered: Sep 2004
Location: Bowling Green, Ohio
Distribution: Redhat 7.2
Posts: 8

Rep: Reputation: 0
I don't think that I have a boot prompt. Everything happens on its own until it freezes at the "Configuring kernel parameters."

Is there a way to force a boot prompt to come up?

Again, I have no idea about anything in Linux.
 
Old 08-03-2005, 03:39 PM   #13
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
My guess is fedora has a button you can press to get the boot screen, but I dropped redhat/fedora a long time ago before bootscreen were used.
 
Old 08-04-2005, 12:45 PM   #14
Woessey
LQ Newbie
 
Registered: Sep 2004
Location: Bowling Green, Ohio
Distribution: Redhat 7.2
Posts: 8

Rep: Reputation: 0
Thanks for all of the help and trying to fix my problem. I still can't get it to work so I am going to install Redhat 7.2 or Redhat 9. We'll see how that works for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot fail yongsp General 2 03-04-2005 03:55 AM
fail to boot. Please Help! thks meme Linux - General 0 08-09-2004 06:47 PM
Slackware 10.0 boot fail on an old PC ovid Slackware - Installation 6 07-19-2004 08:44 PM
Urgent Help Fail to boot satimis Red Hat 2 12-04-2003 05:06 PM
lo and eth0 fail on boot dsiguy Linux - Hardware 2 03-14-2003 01:46 PM


All times are GMT -5. The time now is 07:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration