LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 01-24-2007, 10:19 PM   #1
LarryDoliver
Member
 
Registered: Mar 2003
Posts: 126

Rep: Reputation: 17
beryl or glxinfo kills the display...


I'm attempting to get beryl running on my work machine - it works like a charm on my home box, and it was trivial to setup...


But at work, beryl-manager seems to be hanging the display (under KDE, the beryl icon bounces once then the screen freezes and only CTRL+ALT+BACKSPACE gets any attention from Xorg. Odd thing is that the same thing happens with glxinfo from the commandline - as soon as I hit $glxinfo (enter) the screen stops responding, about 2 seconds later I see a blip on the screen (goes dark for a fraction of a sec, then comes back) and then nothing.

Here's what I've got (on the broken machine):

Code:
$ /sbin/lspci | grep -i vga
05:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7800 GT] (rev a1)

$ rpm -qa|grep glx
glx-utils-6.5.1-8.fc6

$ rpm -qa|grep kernel
kernel-2.6.19-1.2895.fc6
kernel-devel-2.6.19-1.2895.fc6
kernel-2.6.18-1.2798.fc6

$ rpm -qa|grep nvidia
kmod-nvidia-1.0.9746-1.2.6.19_1.2895.fc6
xorg-x11-drv-nvidia-1.0.9746-7.lvn6

$ uname -a
Linux [hostname] 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10 19:28:18 EST 2007 i686 athlon i386 GNU/Linux

$ cat /var/log/Xorg.0.log|grep LoadModule
(II) LoadModule: "bitmap"
(II) LoadModule: "pcidata"
(II) LoadModule: "glx"
(II) LoadModule: "dbe"
(II) LoadModule: "extmod"
(II) LoadModule: "nvidia"
(II) LoadModule: "kbd"
(II) LoadModule: "mouse"
(II) LoadModule: "fb"
(II) LoadModule: "wfb"
(II) LoadModule: "ramdac"
The only thing that is different about the two machines is that the working machine has a 7600 GS, and is reporting dri & drm in the LoadMondules sections.

Any clever ideas?

Thanks, Larry
 
Old 01-26-2007, 07:54 AM   #2
nomb
Member
 
Registered: Jan 2006
Distribution: Debian Testing
Posts: 675

Rep: Reputation: 58
After your screen locks up post your dmesg file and the full xorg.0.log file. You can just do commands like:

dmesg > dmesg.txt
cp xorg.0.conf xorg.log

Also since the computer is still going obviously since you can get it back, put glxinfo into a file so we can see what that says.

glxinfo > glxinfo.{whatever}

That will give us a place to start atleast.

I'm not an nvidia guy altho I'm thinking of trying on of their cards but I can atleast step throught the logs for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
glxinfo/glxgears can't open display jrtayloriv Linux - Newbie 2 08-06-2009 12:43 PM
Display washed out with Beryl on Intel G965 chipset montylee Linux - Newbie 11 01-10-2007 06:41 AM
All glxinfo things say slow Oxagast Linux - Hardware 2 07-09-2006 12:20 AM
Glxinfo hangs / crashes BuckRogers01 Linux - Software 1 03-11-2006 05:58 AM
glxinfo not on my computer? brynjarh Linux - Newbie 1 07-13-2004 02:39 AM


All times are GMT -5. The time now is 04:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration