LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 08-05-2010, 03:13 AM   #1
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,355

Rep: Reputation: 42
ATD hangs on boot


Hi, can someone please tell me where the start up script is?

After doing a reinstall, and then upgrading, I have a problem: as the boot script comes to ATD, it hangs. Someone suggested doing an interactive start ---- and it worked! Just say no to ATD, and boot goes well. Of course, I don't really want to do that each time. How do I remove it? That is, get it out of the init.d or rc.d boot procedure.

After reading man chkconfig I did: chkconfig atd off Was that the right thing to do?

Last edited by Pedroski; 08-05-2010 at 05:48 AM.
 
Old 08-05-2010, 06:38 AM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,313

Rep: Reputation: 139Reputation: 139
Quote:
After reading man chkconfig I did: chkconfig atd off Was that the right thing to do?
That will disable atd from starting at boot and should cure the problem. However, atd is the "at daemon" and you may want to use the "at" command which allows you to run commands at a time in the future specified by you. With atd disabled, you won't be able to use the at command.
 
Old 08-05-2010, 06:47 AM   #3
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,355

Original Poster
Rep: Reputation: 42
Thanks. There must be a bug in atd. I wouldn't know how to use at, so for me it won't matter! As long as my computer boots! Maybe on an update, the bug will be gone! One lives in hope!

I'd like to switch off some other nonessentials: can you recommend anything?
 
Old 08-05-2010, 09:28 PM   #4
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,355

Original Poster
Rep: Reputation: 42
Just a note on this: Problem half fixed!

I have two kernels to choose from: 2.6.32.16-150.fc12.i686 and 2.6.31.5-127.fc12.i686

If I boot with the newest kernel, I don't get to login. I disabled atd on boot, but then the boot process hangs at 'starting crond' Only switching off the power helps. BUT, if I boot with the slightly older kernel, and atd off, boot proceeds normally.

I don't know what crond does, or if switching it off will cause problems. Do I need it?
 
Old 08-06-2010, 06:03 AM   #5
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
YES, YOU DO, for maintainable.

Then just stay with older kernel, set it to be default kernel and leave it for now, until new kernel comes out.

Last edited by DrLove73; 08-06-2010 at 06:04 AM.
 
  


Reply

Tags
fixed, half


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atd Deamon lifelong Linux - Software 2 02-26-2007 06:42 AM
disable crond, atd introuble Slackware 5 01-23-2006 08:06 AM
ATD daemon pete1234 Linux - General 3 12-13-2005 10:48 AM
atd stopped working beaming_linux Linux - Software 7 03-25-2005 07:54 AM
atd is messed up knandyal Linux - General 1 06-28-2002 04:18 PM


All times are GMT -5. The time now is 07:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration