LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 10-24-2008, 07:51 PM   #1
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Question ATA2 error messages during boot (non-fatal). How to fix?


I add a new Hitachi drive to my laptop as a second drive, and I've got a couple problems with it, neither fatal, but I've not been able to figure out any resolution.

First: My hardware

HP dv9708us
ADM Turion 64-bit dual processor
3Gb RAM
Fujitsu 160 Gb SATA drive (sda)
Hitatchi 320 Gb SATA drive (sdb)
nVidia sound and video
Atheros wireless G (ATH_PCI driver - ATH5 still fails on this hardware)

Now, my (non-fatal) problems. (Both, I think, from the same root cause.)

1) GRUB can't boot from the Hitachi drive. It times out trying to read the drive.

2) When I boot Fedora 9 on sdb from sda, I get the following errors:
Code:
$ dmesg | grep ata2
ata2: SATA max UDMA/133 abar m8192@0xf6484000 port 0xf6484180 irq 23
ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)              
ata2.00: ATA-8: Hitachi HTS543232L9A300, FB4OC40C, max UDMA/133     
ata2.00: 625142448 sectors, multi 16: LBA48 NCQ (depth 0/32)        
ata2.00: configured for UDMA/133                                    
ata2.00: exception Emask 0x10 SAct 0x0 SErr 0x180000 action 0x6 frozen
ata2.00: irq_stat 0x08000000, interface fatal error                   
ata2: SError: { 10B8B Dispar }                                        
ata2.00: cmd c8/00:08:e1:20:06/00:00:00:00:00/e0 tag 0 dma 4096 in    
ata2.00: status: { DRDY }                                             
ata2: hard resetting link                                                       
ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)                          
ata2.00: configured for UDMA/133                                                
ata2: EH complete                                                               
ata2.00: exception Emask 0x10 SAct 0x0 SErr 0x180000 action 0x6 frozen          
ata2.00: irq_stat 0x08000000, interface fatal error                             
ata2: SError: { 10B8B Dispar }                                                  
ata2.00: cmd c8/00:08:e1:20:06/00:00:00:00:00/e0 tag 0 dma 4096 in              
ata2.00: status: { DRDY }                                                       
ata2: hard resetting link                                                       
ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)                          
ata2.00: configured for UDMA/133                                                
ata2: EH complete
ata2.00: exception Emask 0x10 SAct 0x0 SErr 0x180000 action 0x6 frozen
ata2.00: irq_stat 0x08000000, interface fatal error
ata2: SError: { 10B8B Dispar }
ata2.00: cmd c8/00:08:e1:20:06/00:00:00:00:00/e0 tag 0 dma 4096 in
ata2.00: status: { DRDY }
ata2: hard resetting link
ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata2.00: configured for UDMA/133
ata2: EH complete
ata2: limiting SATA link speed to 1.5 Gbps
ata2.00: exception Emask 0x10 SAct 0x0 SErr 0x180000 action 0x6 frozen
ata2.00: irq_stat 0x08000001, interface fatal error
ata2: SError: { 10B8B Dispar }
ata2.00: cmd c8/00:08:e1:20:06/00:00:00:00:00/e0 tag 0 dma 4096 in
ata2.00: status: { DRDY }
ata2: hard resetting link
ata2: SATA link up <unknown> (SStatus 103 SControl 310)
ata2.00: failed to read native max address (err_mask=0x100)
ata2.00: HPA support seems broken, skipping HPA handling
ata2.00: revalidation failed (errno=-5)
ata2: failed to recover some devices, retrying in 5 secs
ata2: hard resetting link
ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata2.00: configured for UDMA/133
ata2: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x1 t4
ata2: irq_stat 0x08000000, interface fatal error
ata2.00: configured for UDMA/133
ata2: EH complete
Then the system runs with no further problems. (In fact, I'm using it to start this thread.)

Any suggestions welcomed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.6.24.3-12 ata2.00 failed to identify (io error, err_mask=0x4) jzimm0007@msn.com Linux - Kernel 2 03-21-2008 12:34 AM
gnupg compile fatal error - how do I fix it? rkmason Linux - Software 3 06-07-2007 02:26 AM
ata2 slow respond at boot lucaluca Linux - General 1 01-09-2007 08:36 PM
MPlayer -vo Fatal Error - Easy FIX?? Nadinesky Linux - Software 2 08-23-2005 04:56 PM
Fatal Error how do i fix it Kompressor Linux - Newbie 1 08-02-2002 01:07 AM


All times are GMT -5. The time now is 12:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration