LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-25-2004, 01:09 PM   #1
acer_peri
Member
 
Registered: Nov 2003
Location: Beijing, China
Distribution: Tettnang
Posts: 38

Rep: Reputation: 15
Another two input method problem.


1. Can't input comma, full stop, colon, etc. with FC2's built in Chinese input methods.
but inputting chinese characters, english letters and symbol it has no problem.

2. with GNOME, it's ok. but when starting with KDE, an item named "autorun" is in the panel, and the input method works abnormally, it displays several items(I guess is about input method) in the panel, and frozes, which make system run slowly, and when I try to close those ones, another ones comes out, which will not disappear at last.

Last edited by acer_peri; 05-25-2004 at 01:12 PM.
 
Old 05-25-2004, 02:59 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Go to System settings --> Keyboard

Set the language you want, and try again.
 
Old 05-25-2004, 04:11 PM   #3
acer_peri
Member
 
Registered: Nov 2003
Location: Beijing, China
Distribution: Tettnang
Posts: 38

Original Poster
Rep: Reputation: 15
first, there's no Chinese
and I replace with US International, Japan, British, but the symbol can't input, too.
 
Old 05-25-2004, 04:15 PM   #4
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
But other caracters print out fine?

Seems like your keyboard model is not correct. Tell me, does < and > work.

If not, check your XF86Config file. It is located in /etc/X11 directory.

One more thing before you look into XF86Config. Count the keys on your keyboard. Yes, count them. Without the special function keys.

Check the Keyboard Section in the XF86Config file, to see if the number of keys matches the number of keys on your keyboard.
 
Old 05-26-2004, 02:22 AM   #5
acer_peri
Member
 
Registered: Nov 2003
Location: Beijing, China
Distribution: Tettnang
Posts: 38

Original Poster
Rep: Reputation: 15
< > don't work. a point to note, that Chinese symol is different from western ones, in that it holds 2 western character's spaces.
etc/X11/xorg.conf

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "___569e"
DisplaySize 280 210
HorizSync 30.0 - 69.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 05-26-2004, 10:18 AM   #6
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Quote:
Originally posted by acer_peri
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection
As you see, your keyboard is set to a pc keybard with 105 keys (pc105). Did you count your keys?
 
Old 06-18-2004, 01:06 PM   #7
awtoc123
Member
 
Registered: Apr 2002
Location: China
Distribution: Suse 10
Posts: 225

Rep: Reputation: 30
Hi acer_peri I have exactly the same problems lots if IM opens in the task bar, and you can not close them, now for some unknown reason the Chinese input system have totally vanished, and there is no Chinese ( simplified ) input system any more, so I did a new fresh re-install, and it workind again, but now it is gone again, I was told that yo can use the new Fedora Core 2 state of the art input system, still light years BEHIND that of Windows 2000 or XP, this new state of the art works like this, you open abiword and right click in the document area and then you choose Input method, and then Internet/intranet input method, even that can be sort of used, but again the full stop or comma or other signs are not there, and it can only be used in abiword or evolution,, now if you want to search something in Chinese you are stuck as none of the browsers support this new ( light years BEHIND Windows ) input method.
Now it is a shame that linux is so POOR with Chinese input, that just to use Chinese you still need a Windows machine. Very POOR, in fact there is no linux distro with a good Chinese Input. Two years ago a Chinese company Dynasoft YCBX made state of the art Chinese input system only for redhat 7.3 and KDE 3.0 that worked as good as any of the Windows input, but sadly they don't make it any more.
So Linux Fedora come on now China will soon be the Worlds biggest Computer market, and Linux totally ignore this fact, so Uncel Gates will sadly still win in China.
 
Old 06-18-2004, 03:04 PM   #8
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
Another two input method problem.

Hi,

Unfortunately for Uncle Bill at least 95% of the Windows software in China is made by Uncle Blackbeard!

I haven't tried FC2 yet, I'm still tinkering heavily with FC1, sad to hear that the chinese input is buggy...hope someone can fix that...

I agree with you, the IMEs for Win2000 and XP are superior to anything Open Source can offer, however, 1) open source is in a constant state of development, we will get there one day, and 2) have you seen the size of the extra hard disk space Asian support in Windows/Office requires? Ouch!

To marghorp & acer_peri, looking at the keyboard layouts will not help, Japanese, Korean & Chinese require separate input server software in order to process the thousands of multi-byte characters that make up these languages. In fact, I think having the US keyboard layout is probably a good thing when entering Pinyin input!

To acer_peri, I don't know much about the default input system of Fedora, I shall try and learn a bit about it this weekend (as the weather is really crappy here in Melbourne today) and see what we can come up with...in the meantime, have you tried "going around" the default input system and using something like "scim"?

sorry I can't help any more than that at the present point in time...

cheers,

jdw
 
Old 06-18-2004, 11:58 PM   #9
awtoc123
Member
 
Registered: Apr 2002
Location: China
Distribution: Suse 10
Posts: 225

Rep: Reputation: 30
Hi JDW I'm just starting to explore SCIM it look very promissing, but you need the Windows fonts, and that is where I have problems I don't have a Windows machine, only in the office so I have to burn a CD with the fonts.

The size of the hard dist space to support Asian fonts is no longer a problem as now a days most hard disks are 120GB or at least 80GB that was a problem before, but not now.

The only Linux Distro with a sort of OK Chinese input is Redhat Enterprises, and even that is far behind that of W2K or XP, Mandrake still have problems, I started this forum with MDK9.2 and still no good.

" Unfortunately for Uncle Bill at least 95% of the Windows software in China is made by Uncle Blackbeard! " it is more like 99% even big companies are using the 80 cent = 5 RMB software, so if you look at this way then Windows are as cheap as Linux, if you want a Linux you have to either download you self and that cost more than 80 Cents, or you can also buy from the same place as Windows for the same price, all Uncel Bills software cost 80 Cents Pr. CD so you can buy MS Office for $1.60 that is cheape enogh, so why don't Uncel Bill do something about this ? Just think China is now on of the biggest computer markets in the or soon will be, and every user ( 99% ) is using Pirated software. So I say " Help Microsoft to combat Piracy switch to Linux "

It is no longer the case that Windows are expensive if you compare with Redhat WS then Redhat at $176.00 ( Basic ) and Windows have the same price and Redhat WS Standard cost $299.00, but for the stability and much better performance we stay with redhat ws.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to use Chinese input method? backpacker Linux - Software 2 01-26-2007 11:13 AM
input method doesn't work sometimes NeoAnderson Debian 0 10-01-2005 07:57 AM
Input method selection satimis Fedora 0 07-13-2005 11:16 AM
something wrong after install new input method... pikachu69 Fedora 0 01-03-2005 12:19 PM
Information on Input Method framework suveern Linux - General 0 11-22-2004 04:12 PM


All times are GMT -5. The time now is 03:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration