LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   annoying messages from passwordless rsh (http://www.linuxquestions.org/questions/fedora-35/annoying-messages-from-passwordless-rsh-349384/)

kevingpo 08-02-2005 06:41 PM

annoying messages from passwordless rsh
 
This is my passwordless SSH connection:


Connection to localhost closed.
[kc40@slave ~]$ ssh localhost date
Wed Aug 3 00:36:08 BST 2005
[kc40@slave ~]$ ssh localhost
Last login: Wed Aug 3 00:35:52 2005 from slave
[kc40@slave ~]$


It's good!
However, this is my passwordless RSH connection:


[kc40@slave ~]$ rsh localhost date
connect to address 127.0.0.1: Connection refused
Trying krb4 rsh...
connect to address 127.0.0.1: Connection refused
trying normal rsh (/usr/bin/rsh)
Wed Aug 3 00:36:29 BST 2005
[kc40@slave ~]$ rsh localhost
connect to address 127.0.0.1: Connection refused
Trying krb4 rlogin...
connect to address 127.0.0.1: Connection refused
trying normal rlogin (/usr/bin/rlogin)
Last login: Wed Aug 3 00:36:13 from slave
[kc40@slave ~]$


Does anyone know how to make rsh stop doing whatever it's doing that it's getting connection refused twice? I have edited the /etc/xinetd.d/rsh and /etc/xinetd.d/rlogin files, setting 'disable' to 'no'. Help most appreciated!

Matir 08-02-2005 08:05 PM

Are you working in a Kerberos environment? It seems to be trying kerberos-ized versions of the rsh and rlogin programs before moving on to the normal versions.

kevingpo 08-02-2005 09:16 PM

Well, it's normal Fedora Core 3. Probably Kerberos environment. How to switch off?

kevingpo 08-03-2005 05:36 AM

I just like to tell everybody that at last I found out why my rsh was using
Kerbos5 resulting in annoying messages (when am trying to get a clean passwordless rsh). As I analysed from the list:

Connection refused
Trying krb4
Connection refused
Trying normal

The first being a kerberos 5, then a version 4 try before finally a normal
being successful. I thought there must be more than one version of rsh installed. So I typed 'locate rsh'. I try the first on the list. I typed '/usr/bin/rsh localhost' and that worked fine. Then typed 'which rsh'. To my surprise it says '/usr/kerberos/bin/rsh'. I then
looked at my $PATH and see that that's the first folder that's being pathed. So I removed it. Problem solved.

Matir 08-03-2005 09:44 AM

Interesting. Glad you shared your solution. On both threads. ;)

kevingpo 08-10-2005 05:00 PM

yeah, kinda weird


All times are GMT -5. The time now is 07:20 AM.