LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-16-2009, 11:54 PM   #1
keika
LQ Newbie
 
Registered: Feb 2009
Posts: 24

Rep: Reputation: 15
an error when rpming


hi,everybody!
I got the following error when I type rpm -ivh mozilla-0.9.5-0.i386.rpm
error: Failed dependencies:
mozilla conflicts with eclipse-swt-1:3.4.1-5.fc10.i386

what can I do?
uninstall eclipse-swt-1:3.4.1-5.fc10.i386 ??
but how?
 
Old 02-17-2009, 12:25 AM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,698

Rep: Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687
why the heck do you want to install that old version "mozilla-0.9.5" ( i am using SeaMonkey 1.1.14)
the current name of the program is "seamonkey" .
Mozilla changed it's name when firefox came out ( firefox is now version 3 )
Code:
yum install seamonkey
and DO NOT use rpm to install software unless you have too., use yum .
 
Old 02-17-2009, 01:02 AM   #3
keika
LQ Newbie
 
Registered: Feb 2009
Posts: 24

Original Poster
Rep: Reputation: 15
yes,John,you are right.I should use yum to insatll software.
but my problem didn't get resolved after yum install seamonkey
thanks anyway!

my real problem is that I got the "No gecko found" when I build the Galeon.

Any ideas?
 
Old 02-17-2009, 01:51 AM   #4
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 61
This has to do with -devel packages probably.

Yves.
 
Old 02-17-2009, 02:01 AM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 12,698

Rep: Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687
well i use the mozilla tar.bz2 and have the installer install it in a non-standard place
but i find that i also need to install " compact-libstdc++33 " to get libstdc++.05.so

what repos do you have running .You can find out with this
Code:
yum repolist
you might want to look through and read a few help/ guides
http://www.dnmouse.org/
http://www.mjmwired.net/resources/mjm-fedora-f10.html

Quote:
my real problem is that I got the "No gecko found" when I build the Galeon.
Have you read the two files in the source folder " README " and " INSTALL "
for a list of dependencies
most of them can be installed by doing this
Code:
yum groupinstall "Development Tools" "Development Libraries" "GNOME Software Development"
WANNING a very big download

Last edited by John VV; 02-17-2009 at 02:07 AM.
 
Old 02-17-2009, 03:15 AM   #6
keika
LQ Newbie
 
Registered: Feb 2009
Posts: 24

Original Poster
Rep: Reputation: 15
hi theYinYeti
after I type rpm -ivh mozilla-devel-0.9.5-0.i386.rpm
here is the error I got:
error: Failed dependencies:
mozilla = 0.9.5-0 is needed by mozilla-devel-33:0.9.5-0.i386
libIDL-0.6.so.0 is needed by mozilla-devel-33:0.9.5-0.i386

I don't why?
 
Old 02-17-2009, 03:20 AM   #7
keika
LQ Newbie
 
Registered: Feb 2009
Posts: 24

Original Poster
Rep: Reputation: 15
hi,John
thanks for your hint.
After I read the INSTALL in the source folder I know that Galeon depends on Mozilla.
so I have do download the Mozilla first and build and then install.

I am trying......
I'll update here when i get any progress.
 
Old 02-17-2009, 03:36 AM   #8
keika
LQ Newbie
 
Registered: Feb 2009
Posts: 24

Original Poster
Rep: Reputation: 15
hi.John
I just downloaded the lastest version mozilla-i686-pc-linux-gnu-1.8a6.tar.gz (2005)
it's too old,but newest version for mozilla.I don't know if it would work.my Galeon source version is 2.0.7(2008)

But there is no configure in the source filder when I tar xzvf mozilla-i686-pc-linux-gnu-1.8a6.tar.gz
,and the "INSTALL" in the Galeon source folder told me that I need to use ./configure to compile the mozilla.
Can you tell me where I can download the mozilla.tar.bz2?

Thanks in advance!
 
Old 02-17-2009, 11:19 AM   #9
John VV
Guru
 
Registered: Aug 2005
Posts: 12,698

Rep: Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687
WHY are you trying to use VERY OLD software as a dependency
and the INSTRUCTIONS for the VERY,VERY old mozilla should state to RUN THE installer script for the binary install
the source code needs a special config tool ( from the mozilla website )
but for a Dead version of mozilla it might not be around
install seamonkey 1.1.14

Code:
yum install seamonkey

AND INSTALL Galeon this way

yum install galeon
 
Old 02-18-2009, 07:34 PM   #10
keika
LQ Newbie
 
Registered: Feb 2009
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks John.
I am trying ................
 
Old 02-22-2009, 07:06 PM   #11
keika
LQ Newbie
 
Registered: Feb 2009
Posts: 24

Original Poster
Rep: Reputation: 15
hi,John,
Galeon is working now.

because there is really something wrong with the Galeon source code.
four pitches for the latest version of Galeon code,but I did not know.
I pitched.now it works.
Thanks for you suggestions!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP Error Parse error: parse error, unexpected $ in /home/content/S/k/i/SkinCare4U/h CowanServices Programming 2 12-09-2008 08:26 PM
Inkscape compilation error: *** [extension/internal/pdfinput/pdf-parser.o] Error 1 w1k0 Slackware 12 10-25-2008 09:53 AM
compilation error : /tmp/cczC6Kc3.s:7368: Error: unknown pseudo-op: `.ltorg' nankie Red Hat 0 08-19-2008 10:15 AM
Suse CUPS error: cups(File)DoRequest error:client-error-bad-request smdonelan Linux - Hardware 6 04-17-2007 06:46 PM
updating new installation of 9.3 ERROR...ERROR...ERROR Morbid Suse/Novell 3 08-15-2005 11:22 PM


All times are GMT -5. The time now is 07:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration