LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-06-2004, 12:01 PM   #1
makuz
LQ Newbie
 
Registered: Dec 2004
Distribution: fedora core 3
Posts: 4

Rep: Reputation: 0
alsamixer settings not restored in FC3


i recently upgraded my system from fc1 to fc3. i was using alsa with fc1 as well. the mixer settings are not restored at boot and everything is muted. i put the following lines in /etc/modprobe.conf, but it did not help.

install snd_intel8x0 /sbin/modprobe --ignore-install snd_intel8x0 && { /usr/sbin/alsactl restore >/dev/null 2>&1 || :; }
remove snd_intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || :; }; /sbin/modprobe -r --ignore-remove snd_intel8x0

i heard that udev might cause problems with alsamixer settings. my /etc/udev/devices directory was completely empty, so i tried

# MAKEDEV -d /etc/udev/devices/ mixer

unfortunately it did not solve the problem. do you have any idea what i am doing wrong? any help would be appreciated.
 
Old 12-06-2004, 01:29 PM   #2
Hiper
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Slackware 10.0
Posts: 100

Rep: Reputation: 15
It's very simple

set volume the way you like then run "alsactl store"

then place "alsactl restore" in some startup script (depends on distro)

(alsactl should be only available to root)
 
Old 12-07-2004, 03:44 AM   #3
makuz
LQ Newbie
 
Registered: Dec 2004
Distribution: fedora core 3
Posts: 4

Original Poster
Rep: Reputation: 0
thanks for your help. this should be automatic without tampering with startup scripts, shouldn't it? at least this is how it worked in fedora 1.
on the other hand, the modprobe.conf entries should do exactly what you suggest. after installing and before removing the alsa soundcard module it uses alsactl to store and restore the mixer settings, but it does not work for some reason.
i found some entries in /var/log/messages related to alsa that claim that alsa is already running at bootup. maybe it is related to the problem.

localhost alsasound: ALSA driver is already running.
localhost rc: Starting alsasound: succeeded
 
Old 12-07-2004, 04:05 AM   #4
maxut
Senior Member
 
Registered: May 2003
Location: istanbul
Distribution: debian - redhat - others
Posts: 1,188

Rep: Reputation: 50
here is my /etc/modprobe. maybe it help u
Code:
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx
 
Old 12-07-2004, 09:25 AM   #5
Belghouth
Member
 
Registered: Dec 2004
Location: Tunisia
Distribution: Redhat (Now Fedora), Mandrake, Suse, Debian.
Posts: 65

Rep: Reputation: 15
Unhappy Help !

I have the same problem with sound

here is my /etc/modprobe.conf file

Code:
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx
Did u resolve the problem?
 
Old 12-09-2004, 08:22 AM   #6
makuz
LQ Newbie
 
Registered: Dec 2004
Distribution: fedora core 3
Posts: 4

Original Poster
Rep: Reputation: 0
unfortunately it did not help. i cannot solve this, it seems that the install lines in modprobe.conf are not even executed. the remove part works or at least i always have something in /etc/asound.state in which alsactl strores the mixer settings, but for same reason the install part does not do anything.
 
Old 12-25-2004, 03:57 PM   #7
makuz
LQ Newbie
 
Registered: Dec 2004
Distribution: fedora core 3
Posts: 4

Original Poster
Rep: Reputation: 0
it seems that i managed to solve this at last.

# MAKEDEV -d /etc/udev/devices/ sound

creates lots of devices in /etc/udev/devices and when alsa starts up it manages to run alsactl and restores the mixer settings.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get alsamixer to save the sound settings. cheater1034 Linux - General 4 06-04-2012 08:01 AM
alsamixer does not save my settings brandonloserkid Slackware 15 09-09-2007 05:27 PM
Alsamixer settings wont stick SnowSurfAir Linux - Software 13 07-16-2004 11:19 PM
Alsa mixer (emu10k1) settings not restored after logging off kde 3.2 haimeltjnfg Linux - Hardware 2 05-03-2004 09:30 PM
ALSAmixer does not remember settings? Pwcca Linux - Software 3 08-05-2003 05:29 AM


All times are GMT -5. The time now is 08:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration