LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   akmod nvidia fedora 17 (http://www.linuxquestions.org/questions/fedora-35/akmod-nvidia-fedora-17-a-4175456850/)

rmknox 04-04-2013 10:03 AM

akmod nvidia fedora 17
 
I have an nvidia display card and have the driver NVIDIA UNIX x86 Kernel Module 304.64 installed
at this moment I also have the kmod-nvidia-3.8.4-102.fc17.i686.i686 version 1:304.64-7.fc17.9 installed and the akmod-nvidia.i686 version 1:304.64-7.fc17.8 installed.

Until a few months ago I did not need to update the kmod, it happened automagically when a new kernel arrived ( as I understand it was updated by the akmod the first time I booted the new release).

A few months ago that stopped and now I need to install the new kmod when I get a new kernel - no big deal - I've semi-automated it.

But I'm curious to understand what has changed and maybe to change it back.

when I look at a history listing I see that the akmod is being updated, but I note it no longer does it's thing
Code:

[knox@knox ~]$ sudo yum history list akmod-nvidia.i686
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
ID    | Login user              | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
  556 | richard knox <knox>      | 2013-03-23 17:35 | Update        |    1 
  529 | richard knox <knox>      | 2013-02-24 10:12 | E, I, U        |  22 EE
  521 | richard knox <knox>      | 2013-02-16 07:40 | E, I, U        |  13 EE
  510 | richard knox <knox>      | 2013-02-04 20:57 | Update        |    3 EE
  470 | System <unset>          | 2012-12-07 14:02 | E, I, O, U    | 2453 
  469 | System <unset>          | 2012-12-07 11:28 | E, I, O, U    | 2453 ##
  456 | richard knox <knox>      | 2012-11-28 09:12 | E, I, U        |  21 EE
  444 | richard knox <knox>      | 2012-11-22 19:01 | Update        |    5 
  421 | richard knox <knox>      | 2012-09-30 18:21 | Install        |  12

Is this because there is an option in the startup that tells whether to use it? I'm believe that the options have changed in a major way since the introduction of a daemon that controls things that used to be controlled by init files.

John VV 04-04-2013 01:08 PM

Did you have a read through the fedoraforum Nvidia guide page ?
http://www.forums.fedoraforum.org/sh...d.php?t=280750

i would recommend the "akmod-nvidia"

also be aware that the 304 nvidia driver has some nasty openGL2 bugs
that can make some 3d programs using gl2 not work right ( "y" and "z" axis can get filp-flopped )
this is fixed in the nvidia 310 and 313 drivers

rmknox 04-04-2013 02:17 PM

Quote:

Originally Posted by John VV (Post 4925168)
Did you have a read through the fedoraforum Nvidia guide page ?
http://www.forums.fedoraforum.org/sh...d.php?t=280750

i would recommend the "akmod-nvidia"

also be aware that the 304 nvidia driver has some nasty openGL2 bugs
that can make some 3d programs using gl2 not work right ( "y" and "z" axis can get filp-flopped )
this is fixed in the nvidia 310 and 313 drivers

Hi John

No I haven't read that page (sometimes we don't know what we don't know) but now that I know it exists I sure will.

Thanks so much for your help. And I'll look into the later drivers.

Dick
Post Script

Unless I'm wrong the page you referenced is the page I followed when I originally installed the nvidia driver. I have the akmod installed but from the history it looks like on 12/7/2012 someone ( maybe an upgrade) told the daemon to stop using it. I suspect I need some command to the daemon to tell it to use the akmod during startup.

PPS - I think it is called systemd - and I suspect there is some command to tell it to activate the akmod - but if this is so, "man systemd" is too convoluted to clearly tell a simple fellow like me how to use it.

PPPS - It appears that the ref page does not deal with how to use systemd to tell startup to use the akmod - or if it does I'm not clever enuf to deduce that fact.

rmknox 04-04-2013 09:40 PM

I think I figured it out
Code:


[knox@knox ~]$ systemctl is-enabled akmods.service
disabled
[knox@knox ~]$
[knox@knox ~]$ sudo systemctl enable akmods.service
[sudo] password for knox:
ln -s '/usr/lib/systemd/system/akmods.service' '/etc/systemd/system/multi-user.target.wants/akmods.service'
[knox@knox ~]$
[knox@knox ~]$ systemctl is-enabled akmods.service
enabled
[knox@knox ~]$

Now I wait till I get a new kernel and see if it works

If someone sees that I am confused - i.e. if I haven't figured it out - please let me know

Dick

John VV 04-05-2013 02:15 AM

changes to how the akmod is set up is something i am not really familiar with
i have been using the nvidia.run for so many years , even on fedora 18, that that is what i use


All times are GMT -5. The time now is 08:27 PM.