LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 04-25-2012, 08:33 PM   #1
pawan.mup
LQ Newbie
 
Registered: Apr 2012
Posts: 6

Rep: Reputation: Disabled
after kernel compilation reboot says mount : couldnot find filesystem '/dev/root'


I am trying to install a 2.6.34.11 kernel.

I just checked out fresh tar ball for linux-2.6.34.11.tar.bz2

and followed below steps for compilation

tar -xjvf linux-2.6.34.11.tar.bz2 -C /usr/src; cd /usr/src/linux-2.6.34.11
make menuconfig
make
make modules
make module_install
make install

after this I rebooted with the new image but it says

No volume groups found Volume group "VolGroup00" not found mount : couldnot find filesystem '/dev/root'

Can any1 please suggest me if I have missed any steps..
 
Old 04-25-2012, 08:53 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Have you compiled the drivers for your disk controller and the used filesystem into the kernel? Also, as it seems that you use LVM, so have you compiled the drivers for LVM into the kernel?
For more information about compiling a kernel for LVM have a look at the Gentoo Wiki.
 
Old 04-25-2012, 08:59 PM   #3
hydraMax
Member
 
Registered: Jul 2010
Location: Skynet
Distribution: Debian + Emacs
Posts: 467
Blog Entries: 60

Rep: Reputation: 51
It is a little hard to say, since you didn't tell us anything about your file system configuration or your boot loader configuration. Just guessing, I would suspect that you are using LVM on your system, but you did not include Device mapper support in your kernel configuration (I think it was under Multiple devices driver support category). Furthermore, if your root file system is on LVM, you may need to include DM support statically instead of as a module. If you are using RAID, there are additional drivers that are needed as well.

But if you tell us about your file system configuration, and also post your grub.conf file contents, we could give you a more informed opinion.
 
Old 04-25-2012, 09:29 PM   #4
pawan.mup
LQ Newbie
 
Registered: Apr 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi Thanks for the reply!!

Here is my grub.conf details, and image for "(2.6.34.11)" is not booting properly as I mentioned

Code:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
# splashimage=(hd0,0)/grub/splash.xpm.gz
serial --unit=0 --speed=115200
terminal --timeout=5 serial console
hiddenmenu
title Fedora (2.6.34.11)
        root (hd0,0)
        kernel /vmlinuz-2.6.34.11 ro root=/dev/VolGroup00/LogVol00 rhgb quiet maxcpus=1
        initrd /initrd-2.6.34.11.img

title Fedora (2.6.23-gcov)
        root (hd0,0)
        kernel /vmlinuz-2.6.23-gcov ro root=/dev/VolGroup00/LogVol00 rhgb quiet maxcpus=1
        initrd /initrd-2.6.23-gcov.img

title Fedora (2.6.23.1-42.fc8)
        root (hd0,0)
        kernel /vmlinuz-2.6.23.1-42.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet maxcpus=1
        initrd /initrd-2.6.23.1-42.fc8.img
/etc/fstab

Code:
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
I am also attaching my .config file kernel configuration..

I tried to check in the menuconfig but I am not sure which options should I select in the "Multiple devices driver support " to get the thing working.. please suggest
 
Old 04-25-2012, 09:35 PM   #5
pawan.mup
LQ Newbie
 
Registered: Apr 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Attaching the kernel config file used.
Attached Files
File Type: txt config.txt (95.1 KB, 7 views)
 
Old 04-25-2012, 11:39 PM   #6
hydraMax
Member
 
Registered: Jul 2010
Location: Skynet
Distribution: Debian + Emacs
Posts: 467
Blog Entries: 60

Rep: Reputation: 51
Quote:
Originally Posted by pawan.mup View Post
I am also attaching my .config file kernel configuration..

I tried to check in the menuconfig but I am not sure which options should I select in the "Multiple devices driver support " to get the thing working.. please suggest
From your boot config, it is clear that your root file system is on LVM. However, your .config shows that your kernel is set to compile the Device-mapper (BLK_DEV_DM) as a module. This is bad, because modules get stored on your root file system, and therefore are not available at boot up time. So, you need to go in menuconfig to the "Multiple devices driver support" category, find "Device mapper support", and switch it from "<M>" to "<*>", so it is compiled directly into the kernel. (Once you have highlighted "Device mapper support", press "Y" to switch it.)
 
Old 04-26-2012, 02:50 AM   #7
pawan.mup
LQ Newbie
 
Registered: Apr 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi HydraMax thank you for the reply and made the change as "CONFIG_BLK_DEV_DM=y" and rebooted I am still seeing the same problem..

I am attaching the config file for reference..


Quote:
From your boot config, it is clear that your root file system is on LVM. However, your .config shows that your kernel is set to compile the Device-mapper (BLK_DEV_DM) as a module. This is bad, because modules get stored on your root file system, and therefore are not available at boot up time. So, you need to go in menuconfig to the "Multiple devices driver support" category, find "Device mapper support", and switch it from "<M>" to "<*>", so it is compiled directly into the kernel. (Once you have highlighted "Device mapper support", press "Y" to switch it.)
Attached Files
File Type: txt config_CONFIG_BLK_DEV_DM=y.txt (95.2 KB, 3 views)
 
Old 04-27-2012, 02:41 AM   #8
hydraMax
Member
 
Registered: Jul 2010
Location: Skynet
Distribution: Debian + Emacs
Posts: 467
Blog Entries: 60

Rep: Reputation: 51
Hmm...

Where did your initrd (initrd-2.6.34.11.img) come from? If your kernel really is properly configured for LVM, my next thought would be that perhaps the initrd is not properly scanning for the volume group.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS "mount: could not find filesystem '/dev/root'" newDevlp Linux - Kernel 3 02-04-2012 04:51 AM
mount: could not find filesystem '/dev/root' jemenake Linux - General 12 02-04-2011 12:24 PM
FC6: "mount: could not find filesystem '/dev/root'" sancho Fedora - Installation 16 04-07-2010 08:35 PM
FC6: "mount: could not find filesystem '/dev/root'" cheerful Fedora - Installation 2 07-27-2007 03:36 PM
FC5t3 error: mount: could not find filesystem '/dev/root' pathall Fedora 1 03-10-2006 10:39 PM


All times are GMT -5. The time now is 01:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration