LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-23-2009, 03:28 AM   #16
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,500

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883

what is the output from
Quote:
whereis insmod
 
Old 02-23-2009, 06:50 AM   #17
shariefbe
Member
 
Registered: Aug 2008
Location: Tiruchirappalli, India
Distribution: UBUNTU 11.04
Posts: 367

Original Poster
Rep: Reputation: 31
The output of whereis insmod is


[sharief@localhost ~]$ whereis insmod
insmod: /sbin/insmod.static /sbin/insmod /usr/share/man/man8/insmod.8.gz
[sharief@localhost ~]$
 
Old 02-23-2009, 07:10 AM   #18
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,500

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
seems to me the PATH is screwed up when you use sudo
you could try to create another user and see if the problem persist with this user.

You could try to remove and reinstall sudo

also make sure
/etc/sudoers contains
Code:
root    ALL=(ALL) ALL
Another option is to use su
open a terminal and type
Code:
su
give the root password

no you are in a rootshell.

I never use sudo
 
Old 02-23-2009, 10:43 AM   #19
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,149

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Or just use sudo /sbin/insmod ... or (to avoid PATH problems) sudo /sbin/insmod.static .... Notice that those locations were listed in the output of the whereis command.

You might also consider using modprobe instead of insmod to load a kernel module. See man modprobe for more information. If you're following a instructions you found in a book, the suggestion to use insmod implies (to me) that the book may be somewhat outdated.
 
Old 02-23-2009, 10:43 PM   #20
shariefbe
Member
 
Registered: Aug 2008
Location: Tiruchirappalli, India
Distribution: UBUNTU 11.04
Posts: 367

Original Poster
Rep: Reputation: 31
I attached my sudoers file with this reply..please refer it and say what to do....
Attached Files
File Type: txt sudoers.txt (3.2 KB, 3 views)
 
Old 02-24-2009, 06:02 AM   #21
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,500

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Backup your sudoers file
mv /etc/sudoers /etc/sudoers.backup
Create a new sudoers file with the following content


Quote:
# /etc/sudoers
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the man page for details on how to write a sudoers file.
#
Defaults env_reset
# Host alias specification
# User alias specification
# Cmnd alias specification
# User privilege specification
root ALL=(ALL) ALL
# Uncomment to allow members of group sudo to not need a password
# (Note that later entries override this, so you might need to move
# it further down)
# %sudo ALL=NOPASSWD: ALL
recreate the sudo user
 
Old 02-24-2009, 04:39 PM   #22
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,149

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Well, your sudoers file looks fairly standard, although I, personally, would never use the NOPASSWD option for a command as potentially destructive as a command run with root privilege. (Entering the password gives to time to think before you act.)

I do notice that my sudoers uses a slightly different format for the env_keep string:
Code:
Defaults    env_keep =  "COLORS DISPLAY HOSTNAME HISTSIZE INPUTRC KDEDIR LS_COLORS"
Defaults    env_keep += "MAIL PS1 PS2 QTDIR USERNAME LANG LC_ADDRESS LC_CTYPE"
Defaults    env_keep += "LC_COLLATE LC_IDENTIFICATION LC_MEASUREMENT LC_MESSAGES"
Defaults    env_keep += "LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER LC_TELEPHONE"
Defaults    env_keep += "LC_TIME LC_ALL LANGUAGE LINGUAS _XKB_CHARSET XAUTHORITY"
But I'm on Fedora 10, not the old, unsupported, obsolete, Fedora 8.

Note, in any case, that PATH is not in the env_keep since it is set by the default PATH and ~/.bashrc of "root" when sudo spawns a sub-shell in which the command executes.

So, what happens when you do a $ sudo /sbin/insmod atl2.ko? If the command works, IIRC, you should get no output. (I think that insmod is like modprobe -- you only get output if there is a problem when the kernel module is inserted.)

Last edited by PTrenholme; 02-24-2009 at 04:41 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in accessing website nitaish Linux - Software 1 05-02-2007 02:59 PM
problem accessing the internet jeffry Linux - Networking 1 05-11-2006 01:12 AM
Problem when accessing to file. crime Linux - Newbie 2 04-15-2006 02:19 AM
Accessing second drive problem diana_chen23 Linux - Hardware 5 07-06-2005 11:01 AM
ACcessing problem hk_michael Linux - Networking 1 03-30-2005 11:52 PM


All times are GMT -5. The time now is 04:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration