LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-04-2009, 12:40 PM   #1
gharvey
LQ Newbie
 
Registered: Dec 2004
Location: London, UK
Distribution: Ubuntu, Debian, CentOS
Posts: 26

Rep: Reputation: 15
403 error when NamedVirtualHost is enabled - *not* SELinux related


Hi all,

I get a 403, access denied whenever I switch on NamedVirtualHost in Apache2 on my newly installed Fedora 10 laptop. All is fine until I uncomment the NamedVirtualHost line, then it alls goes wrong. 403 for everything!

I Googled a load this afternoon and turned up several mentions of this being related to SELinux. I did the advised chcon stuff, as detailed here:
http://thinkmuch.com/blog/archives/2...elinux-in-fc3/

That had no effect, so I disabled SELinux completely for the time being. Also no effect.

The website is Drupal and it's using Drupal's default .htaccess file (which I've never had a problem with before). Config looks like this:

Code:
<VirtualHost *:80>
  ServerName drivingforce              
  DocumentRoot /home/gharvey/workspace/driving-force/trunk/www
  ServerAdmin "webadmin@drupaler.co.uk"
  <Directory /home/gharvey/workspace/driving-force/trunk/www>
    Options Includes FollowSymLinks
    AllowOverride All
  </Directory>
</VirtualHost>
Worked on my old LAMPP installation and works on my CentOS 5 dev server. But not on Fedora 10, and I've no idea why?! =(

Edit: Also tried a test site with a simple "Hello world!" index.html file and no .htaccess. Plus someone in IRC suggested this, which I also tried - neither worked:

Code:
chcon -R unconfined_u:object_r:httpd_sys_content_t:s0 workspace

Last edited by gharvey; 05-04-2009 at 12:57 PM. Reason: additional info added
 
Old 05-04-2009, 03:33 PM   #2
gharvey
LQ Newbie
 
Registered: Dec 2004
Location: London, UK
Distribution: Ubuntu, Debian, CentOS
Posts: 26

Original Poster
Rep: Reputation: 15
Tried this as well:
http://www.linuxforums.org/forum/ser...tml#post414056

Didn't work. Also tried symlinking the workspace directory in my home directory to /var/www/html/workspace - also didn't work.

Interestingly, moving my workspace directory to /var/www/html/workspace *did* work, so it's clearly something to do with Apache having permissions outside of /var/www or having access to /home/* ... and not because of SELinux.

The UserDir stuff sounded promising, but yielded no results.

Still looking for answers.

Edit: commented our the mod_userdir module entirely and restarted Apache - same problem, so UserDir cannot be the cause either.

Last edited by gharvey; 05-04-2009 at 03:38 PM. Reason: additional info
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Http error 403 when vhosts enabled skalman93 Slackware 2 03-11-2009 09:35 AM
Http error 403 when vhosts enabled skalman93 Slackware 1 03-10-2009 04:15 PM
how do i tell of selinux is enabled or not? sneakyimp Linux - Newbie 2 10-22-2007 07:13 PM
apache related problem (HTTP Error 403 - Forbidden ) spandau Linux - Networking 29 09-01-2005 06:06 PM
FC3 SElinux 403 problem.... darkinsanity429 Linux - Networking 0 12-08-2004 02:45 PM


All times are GMT -5. The time now is 02:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration